aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:17:52 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:17:52 +0000
commit7d9018ba07ba848983908177ccf383ce75ddc880 (patch)
tree4f9414ff8937fb1b15deb9dd80bb1de56591efd1
parent7cd89c7ca705dd476b5ce6710c71f1afe2542ad7 (diff)
downloadports-7d9018ba07ba848983908177ccf383ce75ddc880.tar.gz
ports-7d9018ba07ba848983908177ccf383ce75ddc880.zip
textproc/codespell: Update to 2.2.5
- Convert to USE_PYTHON=pep517 Changes: https://github.com/codespell-project/codespell/releases
-rw-r--r--textproc/codespell/Makefile12
-rw-r--r--textproc/codespell/distinfo6
-rw-r--r--textproc/codespell/files/patch-pyproject.toml11
3 files changed, 21 insertions, 8 deletions
diff --git a/textproc/codespell/Makefile b/textproc/codespell/Makefile
index 7c01a91cd97a..c8385dbc981c 100644
--- a/textproc/codespell/Makefile
+++ b/textproc/codespell/Makefile
@@ -1,5 +1,5 @@
PORTNAME= codespell
-PORTVERSION= 2.2.2
+PORTVERSION= 2.2.5
CATEGORIES= textproc
MASTER_SITES= PYPI
@@ -10,14 +10,16 @@ WWW= https://github.com/codespell-project/codespell
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= python shebangfix
-USE_PYTHON= autoplist concurrent distutils noflavors
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=6.2:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist noflavors pep517
NO_ARCH= yes
SUB_FILES= pkg-message
SUB_LIST= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
-SHEBANG_FILES= bin/codespell
-
.include <bsd.port.mk>
diff --git a/textproc/codespell/distinfo b/textproc/codespell/distinfo
index 92f260c7bbb5..47c97bc5f609 100644
--- a/textproc/codespell/distinfo
+++ b/textproc/codespell/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1669057567
-SHA256 (codespell-2.2.2.tar.gz) = c4d00c02b5a2a55661f00d5b4b3b5a710fa803ced9a9d7e45438268b099c319c
-SIZE (codespell-2.2.2.tar.gz) = 213652
+TIMESTAMP = 1688166086
+SHA256 (codespell-2.2.5.tar.gz) = 6d9faddf6eedb692bf80c9a94ec13ab4f5fb585aabae5f3750727148d7b5be56
+SIZE (codespell-2.2.5.tar.gz) = 242918
diff --git a/textproc/codespell/files/patch-pyproject.toml b/textproc/codespell/files/patch-pyproject.toml
new file mode 100644
index 000000000000..1db0fbf6e7ed
--- /dev/null
+++ b/textproc/codespell/files/patch-pyproject.toml
@@ -0,0 +1,11 @@
+--- pyproject.toml.orig 2023-06-14 17:58:55 UTC
++++ pyproject.toml
+@@ -64,7 +64,7 @@ repository = "https://github.com/codespell-project/cod
+
+ [build-system]
+ build-backend = "setuptools.build_meta"
+-requires = ["setuptools>=64", "setuptools_scm[toml]>=6.2"]
++requires = ["setuptools>=61", "setuptools_scm[toml]>=6.2"]
+
+ [tool.setuptools_scm]
+ write_to = "codespell_lib/_version.py"