aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-07-09 15:58:59 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-07-09 16:04:31 +0000
commit7d9bad3564f1b91c66af8a4524612c6c8e5a1ac5 (patch)
tree06e5b8c720cc74ff4ccef62153cb1294f85c1c62
parent1207779d1fc8321cab649394bfd23178548c1b88 (diff)
downloadports-7d9bad3564f1b91c66af8a4524612c6c8e5a1ac5.tar.gz
ports-7d9bad3564f1b91c66af8a4524612c6c8e5a1ac5.zip
www/mod_php81: Fix CONFLICTS_INSTALL
- After d4b3ad6 mod_php* ports creates CONFLICTS with php* ports itself Reported by: vvd@unislabs.com Fixes: d4b3ad make CONFLICTS_INSTALL visible to PHP module ports MFH: 2022Q3 Sponsored by: Bounce Experts
-rw-r--r--www/mod_php81/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/www/mod_php81/Makefile b/www/mod_php81/Makefile
index 5cf31b881fe6..71638d30ba29 100644
--- a/www/mod_php81/Makefile
+++ b/www/mod_php81/Makefile
@@ -1,13 +1,17 @@
+PORTREVISION= 1
CATEGORIES= www devel
PKGNAMEPREFIX= mod_
MAINTAINER= bofh@FreeBSD.org
+CONFLICTS_INSTALL= mod_php[0-9][0-9]
+
PHP_PORT= lang/php81
MASTERDIR= ${.CURDIR}/../../${PHP_PORT}
-OPTIONS_DEFINE= AP2FILTER
+OPTIONS_DEFINE= AP2FILTER
+OPTIONS_EXCLUDE= CGI CLI EMBED FPM
+
AP2FILTER_DESC= Use Apache 2.x filter interface (experimental)
-OPTIONS_EXCLUDE=CGI CLI FPM EMBED
.include "${MASTERDIR}/Makefile"