aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2022-07-27 14:56:52 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2022-07-27 14:59:48 +0000
commit7de4b07516bfce49ce4dd9352bdddcc6ddec6ef7 (patch)
treeceec6de25b84b1d8931d3fab6034470116b58c23
parent5c8b0736fb28ac194e1c1f90639fcf8ee6ee3ad6 (diff)
downloadports-7de4b07516bfce49ce4dd9352bdddcc6ddec6ef7.tar.gz
ports-7de4b07516bfce49ce4dd9352bdddcc6ddec6ef7.zip
mail/postfix: remove interractive part of the script
pkg does not allow interractive script
-rw-r--r--mail/postfix/Makefile2
-rw-r--r--mail/postfix/files/pkg-install.in37
2 files changed, 2 insertions, 37 deletions
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index a4a357e08401..b4bfeeb1e26c 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -1,6 +1,6 @@
PORTNAME= postfix
DISTVERSION= 3.7.2
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= http://ftp.porcupine.org/mirrors/postfix-release/ \
diff --git a/mail/postfix/files/pkg-install.in b/mail/postfix/files/pkg-install.in
index 340c1df561e7..f4e07fb3759c 100644
--- a/mail/postfix/files/pkg-install.in
+++ b/mail/postfix/files/pkg-install.in
@@ -28,35 +28,6 @@ else
DEFAULT_REPLACE_MAILERCONF=y
fi
-ask() {
- local question default answer
-
- question=$1
- default=$2
- if [ -z "${PACKAGE_BUILDING}" -a "${BATCH}" = "no" ]; then
- read -p "${question} [${default}]? " answer
- fi
- if [ -z "${answer}" ]; then
- answer=${default}
- fi
- echo ${answer}
-}
-
-yesno() {
- local question default answer
-
- question=$1
- default=$2
- while :; do
- answer=$(ask "${question}" "${default}")
- case "${answer}" in
- [Yy]*) return 0;;
- [Nn]*) return 1;;
- esac
- echo "Please answer yes or no."
- done
-}
-
# ==============================================================================
# Respect POSTFIX_DEFAULT_MTA, do not ask for confirmation!
# (This helps tools like salt, ansible or puppet on new installations)
@@ -67,13 +38,7 @@ install_choice(){
if [ "${DEFAULT_REPLACE_MAILERCONF}" = "y" ]; then
install_mailer_conf ${mailerconf}
- elif [ "${DEFAULT_REPLACE_MAILERCONF}" = "n" -a -t 0 ]; then
- if yesno "Would you like to activate Postfix in ${mailerconf}" ${DEFAULT_REPLACE_MAILERCONF:="n"}; then
- install_mailer_conf ${mailerconf}
- else
- show_not_activated_msg ${mailerconf}
- fi
- else
+ elif [ "${DEFAULT_REPLACE_MAILERCONF}" = "n" ]; then
show_not_activated_msg ${mailerconf}
fi
}