aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-08-20 14:26:13 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-08-20 14:26:13 +0000
commit7e0be385c5d47d42f128264a376a7955daa10b1e (patch)
tree0bfb464ef5cbc4331319c483b6b93f0ad7002dab
parent7ca8216ae88c5e090c6c588671ee952e81d613e4 (diff)
downloadports-7e0be385c5d47d42f128264a376a7955daa10b1e.tar.gz
ports-7e0be385c5d47d42f128264a376a7955daa10b1e.zip
devel/jetbrains-pty4j: enable on powerpc64le
-rw-r--r--devel/jetbrains-pty4j/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/devel/jetbrains-pty4j/Makefile b/devel/jetbrains-pty4j/Makefile
index 599c80d4645c..72e15cf29c46 100644
--- a/devel/jetbrains-pty4j/Makefile
+++ b/devel/jetbrains-pty4j/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/JetBrains/pty4j
LICENSE= EPL
LICENSE_FILE= ${WRKSRC}/LICENSE
-ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS= amd64 powerpc64le
USES= gmake
@@ -22,15 +22,21 @@ GH_TAGNAME= 32b777311438b7a9c5de4cf56cde269ffd27e65e
DATADIR= ${PREFIX}/share/jetbrains/${PORTNAME}
-ALL_TARGET= linux_x86_64
+ALL_TARGET= linux_${ARCH:S/amd64/x86_64/:S/powerpc64le/ppc64le/}
BUILD_WRKSRC= ${WRKSRC}/native
MAKEFILE= Makefile_freebsd
PLIST_FILES= share/jetbrains/${PORTNAME}/${ARCH}/libpty.so
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64le
+BINARY_ALIAS= powerpc64le-linux-gnu-gcc=cc
+.endif
+
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/${ARCH}
${INSTALL_LIB} \
- ${WRKSRC}/os/freebsd/x86-64/libpty.so \
+ ${WRKSRC}/os/freebsd/${ARCH:S/amd64/x86-64/:S/powerpc64le/ppc64le/}/libpty.so \
${STAGEDIR}${DATADIR}/${ARCH}
.include <bsd.port.mk>