aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 17:15:23 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-25 17:19:23 +0000
commit7e5bafe0f1b95ae995ea9d59743519b368764b5b (patch)
tree8ce4ce1cf7ff19269f5ebd7d32675cc3d897217b
parent3e5d9959b8b21df5953242061a7fe1c3a34b6fb7 (diff)
downloadports-7e5bafe0f1b95ae995ea9d59743519b368764b5b.tar.gz
ports-7e5bafe0f1b95ae995ea9d59743519b368764b5b.zip
archivers/py-zopfli: Add make test
-rw-r--r--archivers/py-zopfli/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/archivers/py-zopfli/Makefile b/archivers/py-zopfli/Makefile
index a7c0f2433f72..be1fd65fe33b 100644
--- a/archivers/py-zopfli/Makefile
+++ b/archivers/py-zopfli/Makefile
@@ -13,6 +13,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0,1:devel/py-pytest@${PY_FLAVOR}
USES= python:3.7+ zip
USE_PYTHON= autoplist concurrent distutils
@@ -20,4 +21,7 @@ USE_PYTHON= autoplist concurrent distutils
post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+do-test:
+ cd ${WRKSRC} && ${SETENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} ${PYTHON_CMD} -m pytest -rs -v
+
.include <bsd.port.mk>