aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-02-18 16:36:34 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-02-18 16:36:34 +0000
commit7ebd2904f2b07f6cd12debff0aae1de1a4bc76fb (patch)
treedaadc19d4fdbf23696a681e8faec71a2a9e4957c
parent408b2300ea2ed1bac9d78f16cd62155bf03f70de (diff)
downloadports-7ebd2904f2b07f6cd12debff0aae1de1a4bc76fb.tar.gz
ports-7ebd2904f2b07f6cd12debff0aae1de1a4bc76fb.zip
This package provides parsing and rendering functions for XML. It is
based on the datatypes found in the xml-types package. This package is broken up into the following modules: * Text.XML: DOM-based parsing and rendering. This is the most commonly used module. * Text.XML.Cursor: A wrapper around Text.XML which allows bidirectional traversing of the DOM, similar to XPath. * Text.XML.Unresolved: A slight modification to Text.XML which does not require all entities to be resolved at parsing. The datatypes are slightly more complicated here, and therefore this module is only recommended when you need to deal directly with raw entities. * Text.XML.Stream.Parse: Streaming parser, including some streaming parser combinators. * Text.XML.Stream.Render: Streaming renderer. WWW: http://github.com/snoyberg/xml Obtained from: FreeBSD Haskell
Notes
Notes: svn path=/head/; revision=291698
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/hs-xml-enumerator/Makefile23
-rw-r--r--textproc/hs-xml-enumerator/distinfo2
-rw-r--r--textproc/hs-xml-enumerator/pkg-descr21
5 files changed, 48 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 1e6d3c2f9f28..dd5be7260005 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -260,6 +260,7 @@ X11_port= x11/hs-X11 # lib_depends
X11-xft_port= x11/hs-X11-xft
xhtml_port= textproc/hs-xhtml
xml_port= textproc/hs-xml
+xml-enumerator_port= textproc/hs-xml-enumerator
xml-types_port= textproc/hs-xml-types
xmlhtml_port= textproc/hs-xmlhtml
xmobar_port= x11/hs-xmobar # executable
diff --git a/textproc/Makefile b/textproc/Makefile
index b3d523f3e149..1d74b5adfe7d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -268,6 +268,7 @@
SUBDIR += hs-xhtml
SUBDIR += hs-xhtml-docs
SUBDIR += hs-xml
+ SUBDIR += hs-xml-enumerator
SUBDIR += hs-xml-types
SUBDIR += hs-xmlhtml
SUBDIR += hsb-aspell
diff --git a/textproc/hs-xml-enumerator/Makefile b/textproc/hs-xml-enumerator/Makefile
new file mode 100644
index 000000000000..dddd598d4e2f
--- /dev/null
+++ b/textproc/hs-xml-enumerator/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: hs-xml-enumerator
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= xml-enumerator
+PORTVERSION= 0.4.4.1
+CATEGORIES= textproc haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Pure utilities for dealing with XML with the enumerator
+
+LICENSE= BSD
+
+USE_CABAL= attoparsec>=0.10 attoparsec-enumerator>=0.3 blaze-builder>=0.2 \
+ blaze-builder-enumerator>=0.2 data-default>=0.2 \
+ enumerator>=0.4.5 failure>=0.1 text>=0.7 transformers>=0.2 \
+ xml-types>=0.3
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/textproc/hs-xml-enumerator/distinfo b/textproc/hs-xml-enumerator/distinfo
new file mode 100644
index 000000000000..2fa7d0c44b82
--- /dev/null
+++ b/textproc/hs-xml-enumerator/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/xml-enumerator-0.4.4.1.tar.gz) = f287ee652ef84b9de2ce3362b0f72cb66c3c9fadd03f8a1638c908d38f36966f
+SIZE (cabal/xml-enumerator-0.4.4.1.tar.gz) = 24051
diff --git a/textproc/hs-xml-enumerator/pkg-descr b/textproc/hs-xml-enumerator/pkg-descr
new file mode 100644
index 000000000000..516e508c72ea
--- /dev/null
+++ b/textproc/hs-xml-enumerator/pkg-descr
@@ -0,0 +1,21 @@
+This package provides parsing and rendering functions for XML. It is
+based on the datatypes found in the xml-types package. This package is
+broken up into the following modules:
+
+ * Text.XML: DOM-based parsing and rendering. This is the most commonly
+ used module.
+
+ * Text.XML.Cursor: A wrapper around Text.XML which allows bidirectional
+ traversing of the DOM, similar to XPath.
+
+ * Text.XML.Unresolved: A slight modification to Text.XML which does not
+ require all entities to be resolved at parsing. The datatypes are
+ slightly more complicated here, and therefore this module is only
+ recommended when you need to deal directly with raw entities.
+
+ * Text.XML.Stream.Parse: Streaming parser, including some streaming
+ parser combinators.
+
+ * Text.XML.Stream.Render: Streaming renderer.
+
+WWW: http://github.com/snoyberg/xml