aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-03-19 23:10:59 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-03-19 23:51:43 +0000
commit7fcd80373a9fefea4a9ec576aa2a63216b54bdd5 (patch)
tree317c60a4c7587171ed70ffd48c8a1e8867ad0dda
parentc81a35f67ddc906c0dbb16931957a053296993d2 (diff)
downloadports-7fcd80373a9fefea4a9ec576aa2a63216b54bdd5.tar.gz
ports-7fcd80373a9fefea4a9ec576aa2a63216b54bdd5.zip
graphics/py-open3d-python: Remove expired port:
2023-03-20 graphics/py-open3d-python: Broken since 2020
-rw-r--r--MOVED1
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-open3d-python/Makefile41
-rw-r--r--graphics/py-open3d-python/distinfo3
-rw-r--r--graphics/py-open3d-python/files/patch-CMakeLists.txt69
-rw-r--r--graphics/py-open3d-python/files/patch-External_CMakeLists.txt11
-rw-r--r--graphics/py-open3d-python/files/patch-External_pybind11_tools_pybind11Tools.cmake32
-rw-r--r--graphics/py-open3d-python/files/patch-Python_CMakeLists.txt22
-rw-r--r--graphics/py-open3d-python/pkg-descr2
9 files changed, 1 insertions, 181 deletions
diff --git a/MOVED b/MOVED
index d67aa44bfeed..bcb3de473f85 100644
--- a/MOVED
+++ b/MOVED
@@ -17800,3 +17800,4 @@ chinese/brise||2023-03-19|Has expired: Broken since 2020
cad/NASTRAN-95||2023-03-19|Has expired: Broken since 2020
lang/dlv||2023-03-19|Has expired: Broken since 2020
net/nfs-ganesha-kmod||2023-03-19|Has expired: Broken since 2020
+graphics/py-open3d-python||2023-03-19|Has expired: Broken since 2020
diff --git a/graphics/Makefile b/graphics/Makefile
index beb2cd85c48e..ef084d877800 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -894,7 +894,6 @@
SUBDIR += py-mpl-interactions
SUBDIR += py-mpl-scatter-density
SUBDIR += py-nwdiag
- SUBDIR += py-open3d-python
SUBDIR += py-opencolorio
SUBDIR += py-openimageio
SUBDIR += py-openshadinglanguage
diff --git a/graphics/py-open3d-python/Makefile b/graphics/py-open3d-python/Makefile
deleted file mode 100644
index b867efed0550..000000000000
--- a/graphics/py-open3d-python/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-PORTNAME= open3d-python
-DISTVERSIONPREFIX= v
-DISTVERSION= 0.2
-PORTREVISION= 5
-CATEGORIES= graphics
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-
-MAINTAINER= yuri@FreeBSD.org
-COMMENT= Modern library for 3D data processing (Python binding)
-WWW= http://www.open3d.org/
-
-LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/../LICENSE
-
-LIB_DEPENDS= libOpen3D.so:graphics/open3d
-
-USES= cmake compiler:c++11-lang eigen:3 fortran localbase:ldflags \
- pkgconfig python:3.6+
-USE_GITHUB= yes
-GH_ACCOUNT= IntelVCL
-GH_PROJECT= Open3D
-USE_PYTHON= flavors
-
-CMAKE_ARGS= -DPYTHON_EXECUTABLE:FILEPATH=${PYTHON_CMD} -DPYTHON_SITE_PACKAGES:STRING=lib/${PYTHON_VERSION}/site-packages
-CMAKE_ON= BUILD_SHARED_LIBS BUILD_PYTHON_MODULE
-CMAKE_OFF= BUILD_TESTS BUILD_PYTHON_TESTS BUILD_PYTHON_TUTORIALS BUILD_TINYFILEDIALOGS
-
-WRKSRC_SUBDIR= src
-LDFLAGS+= -pthread # https://github.com/IntelVCL/Open3D/issues/510
-
-PLIST_FILES= ${PYTHON_SITELIBDIR}/open3d.so
-
-.include <bsd.port.pre.mk>
-
-.if !exists(/usr/include/c++/v1/experimental/optional) && ${CHOSEN_COMPILER_TYPE} == clang
-BROKEN= Base C++ compiler is missing the header <experimental/optional>, see bug\#249538
-.endif
-DEPRECATED= Broken since 2020
-EXPIRATION_DATE= 2023-03-20
-
-.include <bsd.port.post.mk>
diff --git a/graphics/py-open3d-python/distinfo b/graphics/py-open3d-python/distinfo
deleted file mode 100644
index 87e7acd55887..000000000000
--- a/graphics/py-open3d-python/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1534664509
-SHA256 (IntelVCL-Open3D-v0.2_GH0.tar.gz) = 7102113df033b3e240d4429267067274d379a8609fe10231133ad7e15faed41d
-SIZE (IntelVCL-Open3D-v0.2_GH0.tar.gz) = 59368304
diff --git a/graphics/py-open3d-python/files/patch-CMakeLists.txt b/graphics/py-open3d-python/files/patch-CMakeLists.txt
deleted file mode 100644
index 6032f7247299..000000000000
--- a/graphics/py-open3d-python/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,69 +0,0 @@
---- CMakeLists.txt.orig 2018-07-01 05:50:57 UTC
-+++ CMakeLists.txt
-@@ -181,26 +181,26 @@ include_directories(${PROJECT_SOURCE_DIR
- include_directories(${EXTERNAL_INCLUDE_DIRS})
-
- # Open3D libraries
--add_subdirectory(Core)
--add_subdirectory(Tools)
--add_subdirectory(IO)
--add_subdirectory(Visualization)
-+#add_subdirectory(Core)
-+#add_subdirectory(Tools)
-+#add_subdirectory(IO)
-+#add_subdirectory(Visualization)
-
--add_library(${CMAKE_PROJECT_NAME} $<TARGET_OBJECTS:Core> $<TARGET_OBJECTS:IO> $<TARGET_OBJECTS:Visualization>)
-+#add_library(${CMAKE_PROJECT_NAME} $<TARGET_OBJECTS:Core> $<TARGET_OBJECTS:IO> $<TARGET_OBJECTS:Visualization>)
-
- # headless rendering
- if (ENABLE_HEADLESS_RENDERING)
- find_package(OSMesa REQUIRED)
-- include_directories(${OSMESA_INCLUDE_DIR})
-- target_link_libraries(${CMAKE_PROJECT_NAME} ${OSMESA_LIBRARY})
-+ #include_directories(${OSMESA_INCLUDE_DIR})
-+ #target_link_libraries(${CMAKE_PROJECT_NAME} ${OSMESA_LIBRARY})
- else ()
- find_package(OpenGL REQUIRED)
-- target_link_libraries(${CMAKE_PROJECT_NAME} ${OPENGL_LIBRARIES})
-+ #target_link_libraries(${CMAKE_PROJECT_NAME} ${OPENGL_LIBRARIES})
- endif ()
-
--target_link_libraries(${CMAKE_PROJECT_NAME}
-- ${EXTERNAL_LIBRARIES}
-- ${OMP_LIBRARIES})
-+#target_link_libraries(${CMAKE_PROJECT_NAME}
-+# ${EXTERNAL_LIBRARIES}
-+# ${OMP_LIBRARIES})
-
- # Tests
- if (BUILD_TESTS)
-@@ -259,19 +259,19 @@ configure_file(Open3DConfigVersion.cmake
- "${PROJECT_BINARY_DIR}/Open3DConfigVersion.cmake" @ONLY)
-
- # install
--install(TARGETS ${CMAKE_PROJECT_NAME}
-- RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX}/bin
-- LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib
-- ARCHIVE DESTINATION ${CMAKE_INSTALL_PREFIX}/lib)
-+#install(TARGETS ${CMAKE_PROJECT_NAME}
-+# RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX}/bin
-+# LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib
-+# ARCHIVE DESTINATION ${CMAKE_INSTALL_PREFIX}/lib)
-
- file(GLOB HEADERS_ROOT "${CMAKE_CURRENT_SOURCE_DIR}/*.h")
--install(FILES ${HEADERS_ROOT} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/${CMAKE_PROJECT_NAME})
-+#install(FILES ${HEADERS_ROOT} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/${CMAKE_PROJECT_NAME})
-
- # Install the Open3DConfig.cmake and Open3DConfigVersion.cmake
--install(FILES
-- "${PROJECT_BINARY_DIR}${CMAKE_FILES_DIRECTORY}/Open3DConfig.cmake"
-- "${PROJECT_BINARY_DIR}/Open3DConfigVersion.cmake"
-- DESTINATION "${INSTALL_CMAKE_DIR}" COMPONENT dev)
-+#install(FILES
-+# "${PROJECT_BINARY_DIR}${CMAKE_FILES_DIRECTORY}/Open3DConfig.cmake"
-+# "${PROJECT_BINARY_DIR}/Open3DConfigVersion.cmake"
-+# DESTINATION "${INSTALL_CMAKE_DIR}" COMPONENT dev)
-
- # uninstall target
- if (NOT TARGET uninstall)
diff --git a/graphics/py-open3d-python/files/patch-External_CMakeLists.txt b/graphics/py-open3d-python/files/patch-External_CMakeLists.txt
deleted file mode 100644
index f77f629c7d58..000000000000
--- a/graphics/py-open3d-python/files/patch-External_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- External/CMakeLists.txt.orig 2018-08-19 05:58:00 UTC
-+++ External/CMakeLists.txt
-@@ -159,7 +159,7 @@ if (BUILD_TINYFILEDIALOGS)
- set(tinyfiledialogs_LIBRARIES tinyfiledialogs)
- INSTALL_HEADERS(tinyfiledialogs)
- else ()
-- message(SEND_ERROR "TINYFILEDIALOGS dependency not met.")
-+ #message(SEND_ERROR "TINYFILEDIALOGS dependency not met.")
- endif ()
-
- # rply
diff --git a/graphics/py-open3d-python/files/patch-External_pybind11_tools_pybind11Tools.cmake b/graphics/py-open3d-python/files/patch-External_pybind11_tools_pybind11Tools.cmake
deleted file mode 100644
index c9e3397c3a34..000000000000
--- a/graphics/py-open3d-python/files/patch-External_pybind11_tools_pybind11Tools.cmake
+++ /dev/null
@@ -1,32 +0,0 @@
---- External/pybind11/tools/pybind11Tools.cmake.orig 2018-09-02 16:32:40 UTC
-+++ External/pybind11/tools/pybind11Tools.cmake
-@@ -69,17 +69,19 @@ function(_pybind11_add_lto_flags target_
- set(cxx_append ";-fno-fat-lto-objects")
- endif()
-
-- if (CMAKE_CXX_COMPILER_ID MATCHES "Clang" AND prefer_thin_lto)
-- _pybind11_return_if_cxx_and_linker_flags_work(HAS_FLTO_THIN
-- "-flto=thin${cxx_append}" "-flto=thin${linker_append}"
-- PYBIND11_LTO_CXX_FLAGS PYBIND11_LTO_LINKER_FLAGS)
-- endif()
-+ # Disable -flto because it fails on 12: /usr/local/bin/ld: /usr/bin/../lib/LLVMgold.so: error loading plugin: Cannot open "/usr/bin/../lib/LLVMgold.so"
-+ # It is only activated on 12, not 11, for some reason.
-+ #if (CMAKE_CXX_COMPILER_ID MATCHES "Clang" AND prefer_thin_lto)
-+ # _pybind11_return_if_cxx_and_linker_flags_work(HAS_FLTO_THIN
-+ # "-flto=thin${cxx_append}" "-flto=thin${linker_append}"
-+ # PYBIND11_LTO_CXX_FLAGS PYBIND11_LTO_LINKER_FLAGS)
-+ #endif()
-
-- if (NOT HAS_FLTO_THIN)
-- _pybind11_return_if_cxx_and_linker_flags_work(HAS_FLTO
-- "-flto${cxx_append}" "-flto${linker_append}"
-- PYBIND11_LTO_CXX_FLAGS PYBIND11_LTO_LINKER_FLAGS)
-- endif()
-+ #if (NOT HAS_FLTO_THIN)
-+ # _pybind11_return_if_cxx_and_linker_flags_work(HAS_FLTO
-+ # "-flto${cxx_append}" "-flto${linker_append}"
-+ # PYBIND11_LTO_CXX_FLAGS PYBIND11_LTO_LINKER_FLAGS)
-+ #endif()
- elseif (CMAKE_CXX_COMPILER_ID MATCHES "Intel")
- # Intel equivalent to LTO is called IPO
- _pybind11_return_if_cxx_and_linker_flags_work(HAS_INTEL_IPO
diff --git a/graphics/py-open3d-python/files/patch-Python_CMakeLists.txt b/graphics/py-open3d-python/files/patch-Python_CMakeLists.txt
deleted file mode 100644
index 371581f23cda..000000000000
--- a/graphics/py-open3d-python/files/patch-Python_CMakeLists.txt
+++ /dev/null
@@ -1,22 +0,0 @@
---- Python/CMakeLists.txt.orig 2018-07-01 05:50:57 UTC
-+++ Python/CMakeLists.txt
-@@ -29,8 +29,8 @@ target_link_libraries(${PACKAGE_NAME} PR
- file(GLOB PY_HELPER_FILES "Helper/*.py")
- add_custom_target(PythonHelper ALL SOURCES ${PY_HELPER_FILES})
- set_target_properties(PythonHelper PROPERTIES FOLDER "Python")
--add_custom_command(TARGET PythonHelper POST_BUILD
--COMMAND ${CMAKE_COMMAND} -E copy_directory "${PROJECT_SOURCE_DIR}/Python/Helper/" "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/${CMAKE_CFG_INTDIR}")
-+#add_custom_command(TARGET PythonHelper POST_BUILD
-+#COMMAND ${CMAKE_COMMAND} -E copy_directory "${PROJECT_SOURCE_DIR}/Python/Helper" "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/")
- add_dependencies(${PACKAGE_NAME} PythonHelper)
-
- if (BUILD_PYTHON_TESTS)
-@@ -70,7 +70,7 @@ set_target_properties(${PACKAGE_NAME} PR
- ARCHIVE_OUTPUT_DIRECTORY "${CMAKE_ARCHIVE_OUTPUT_DIRECTORY}/Python")
-
- # find the python site-packages location
--execute_process(COMMAND ${PYTHON_EXECUTABLE} -m site --user-site OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
-+#execute_process(COMMAND ${PYTHON_EXECUTABLE} -m site --user-site OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
-
- # configure installer to copy the python module to the python site-packages
- install(TARGETS ${PACKAGE_NAME} DESTINATION ${PYTHON_SITE_PACKAGES})
diff --git a/graphics/py-open3d-python/pkg-descr b/graphics/py-open3d-python/pkg-descr
deleted file mode 100644
index 5a6b1770f61d..000000000000
--- a/graphics/py-open3d-python/pkg-descr
+++ /dev/null
@@ -1,2 +0,0 @@
-The Python binding of Open3D, an open-source library that supports rapid
-development of software that deals with 3D data.