aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-03 06:03:44 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-10-03 06:03:44 +0000
commit7fea2bffc61514432cb0da504cef54f2fe8fe771 (patch)
tree843cf3eb78c14bbe2825371a0c156318585d401a
parenteb23cc343d7f452643964e35692b1b14a8625cd0 (diff)
downloadports-7fea2bffc61514432cb0da504cef54f2fe8fe771.tar.gz
ports-7fea2bffc61514432cb0da504cef54f2fe8fe771.zip
shells/bash: Revise fix when NLS is off
The fix commited in 17f1bb50e42a45dc64fc898cd9cae905d7262bda clashed with cc83ec0f744fb159bd48303d15c09aa0c6cb38a4. The later is a more elegant solution that doesn't require to drop the header files from being installed. This commit reverts changes from 17f1bb50e42a45dc64fc898cd9cae905d7262bda.
-rw-r--r--shells/bash/Makefile2
-rw-r--r--shells/bash/pkg-plist200
2 files changed, 101 insertions, 101 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 59e37945f965..fcf0d36ef938 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -5,7 +5,7 @@ PORTNAME= bash
#PATCHLEVEL= 0
#PORTVERSION= 5.2.${PATCHLEVEL:S/^0//g}
PORTVERSION= 5.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= shells
MASTER_SITES= GNU
#DISTNAME= ${PORTNAME}-${PORTVERSION:R}
diff --git a/shells/bash/pkg-plist b/shells/bash/pkg-plist
index 6209a48f0fd2..35ea19a1fdbb 100644
--- a/shells/bash/pkg-plist
+++ b/shells/bash/pkg-plist
@@ -1,6 +1,105 @@
@shell bin/bash
-@shell bin/rbash
bin/bashbug
+@shell bin/rbash
+%%NO_STATIC%%include/bash/alias.h
+%%NO_STATIC%%include/bash/array.h
+%%NO_STATIC%%include/bash/arrayfunc.h
+%%NO_STATIC%%include/bash/assoc.h
+%%NO_STATIC%%include/bash/bashansi.h
+%%NO_STATIC%%include/bash/bashintl.h
+%%NO_STATIC%%include/bash/bashjmp.h
+%%NO_STATIC%%include/bash/bashtypes.h
+%%NO_STATIC%%include/bash/builtins.h
+%%NO_STATIC%%include/bash/builtins/bashgetopt.h
+%%NO_STATIC%%include/bash/builtins/builtext.h
+%%NO_STATIC%%include/bash/builtins/common.h
+%%NO_STATIC%%include/bash/builtins/getopt.h
+%%NO_STATIC%%include/bash/command.h
+%%NO_STATIC%%include/bash/config-bot.h
+%%NO_STATIC%%include/bash/config-top.h
+%%NO_STATIC%%include/bash/config.h
+%%NO_STATIC%%include/bash/conftypes.h
+%%NO_STATIC%%include/bash/dispose_cmd.h
+%%NO_STATIC%%include/bash/error.h
+%%NO_STATIC%%include/bash/execute_cmd.h
+%%NO_STATIC%%include/bash/externs.h
+%%NO_STATIC%%include/bash/general.h
+%%NO_STATIC%%include/bash/hashlib.h
+%%NO_STATIC%%include/bash/include/ansi_stdlib.h
+%%NO_STATIC%%include/bash/include/chartypes.h
+%%NO_STATIC%%include/bash/include/filecntl.h
+%%NO_STATIC%%include/bash/include/gettext.h
+%%NO_STATIC%%include/bash/include/maxpath.h
+%%NO_STATIC%%include/bash/include/memalloc.h
+%%NO_STATIC%%include/bash/include/ocache.h
+%%NO_STATIC%%include/bash/include/posixdir.h
+%%NO_STATIC%%include/bash/include/posixjmp.h
+%%NO_STATIC%%include/bash/include/posixstat.h
+%%NO_STATIC%%include/bash/include/posixtime.h
+%%NO_STATIC%%include/bash/include/posixwait.h
+%%NO_STATIC%%include/bash/include/shmbchar.h
+%%NO_STATIC%%include/bash/include/shmbutil.h
+%%NO_STATIC%%include/bash/include/shtty.h
+%%NO_STATIC%%include/bash/include/stat-time.h
+%%NO_STATIC%%include/bash/include/stdc.h
+%%NO_STATIC%%include/bash/include/systimes.h
+%%NO_STATIC%%include/bash/include/typemax.h
+%%NO_STATIC%%include/bash/include/unionwait.h
+%%NO_STATIC%%include/bash/jobs.h
+%%NO_STATIC%%include/bash/make_cmd.h
+%%NO_STATIC%%include/bash/pathnames.h
+%%NO_STATIC%%include/bash/quit.h
+%%NO_STATIC%%include/bash/shell.h
+%%NO_STATIC%%include/bash/sig.h
+%%NO_STATIC%%include/bash/siglist.h
+%%NO_STATIC%%include/bash/signames.h
+%%NO_STATIC%%include/bash/subst.h
+%%NO_STATIC%%include/bash/syntax.h
+%%NO_STATIC%%include/bash/unwind_prot.h
+%%NO_STATIC%%include/bash/variables.h
+%%NO_STATIC%%include/bash/version.h
+%%NO_STATIC%%include/bash/xmalloc.h
+%%NO_STATIC%%include/bash/y.tab.h
+%%NO_STATIC%%lib/bash/Makefile.inc
+%%NO_STATIC%%lib/bash/Makefile.sample
+%%NO_STATIC%%lib/bash/accept
+%%NO_STATIC%%lib/bash/basename
+%%NO_STATIC%%lib/bash/csv
+%%NO_STATIC%%lib/bash/cut
+%%NO_STATIC%%lib/bash/dirname
+%%NO_STATIC%%lib/bash/dsv
+%%NO_STATIC%%lib/bash/fdflags
+%%NO_STATIC%%lib/bash/finfo
+%%NO_STATIC%%lib/bash/getconf
+%%NO_STATIC%%lib/bash/head
+%%NO_STATIC%%lib/bash/id
+%%NO_STATIC%%lib/bash/ln
+%%NO_STATIC%%lib/bash/loadables.h
+%%NO_STATIC%%lib/bash/logname
+%%NO_STATIC%%lib/bash/mkdir
+%%NO_STATIC%%lib/bash/mkfifo
+%%NO_STATIC%%lib/bash/mktemp
+%%NO_STATIC%%lib/bash/mypid
+%%NO_STATIC%%lib/bash/pathchk
+%%NO_STATIC%%lib/bash/print
+%%NO_STATIC%%lib/bash/printenv
+%%NO_STATIC%%lib/bash/push
+%%NO_STATIC%%lib/bash/realpath
+%%NO_STATIC%%lib/bash/rm
+%%NO_STATIC%%lib/bash/rmdir
+%%NO_STATIC%%lib/bash/seq
+%%NO_STATIC%%lib/bash/setpgid
+%%NO_STATIC%%lib/bash/sleep
+%%NO_STATIC%%lib/bash/stat
+%%NO_STATIC%%lib/bash/strftime
+%%NO_STATIC%%lib/bash/sync
+%%NO_STATIC%%lib/bash/tee
+%%NO_STATIC%%lib/bash/truefalse
+%%NO_STATIC%%lib/bash/tty
+%%NO_STATIC%%lib/bash/uname
+%%NO_STATIC%%lib/bash/unlink
+%%NO_STATIC%%lib/bash/whoami
+%%NO_STATIC%%libdata/pkgconfig/bash.pc
man/man1/bash.1.gz
man/man1/bashbug.1.gz
%%NLS%%share/locale/af/LC_MESSAGES/bash.mo
@@ -42,102 +141,3 @@ man/man1/bashbug.1.gz
%%NLS%%share/locale/vi/LC_MESSAGES/bash.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/bash.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/bash.mo
-%%NLS%%%%NO_STATIC%%include/bash/alias.h
-%%NLS%%%%NO_STATIC%%include/bash/array.h
-%%NLS%%%%NO_STATIC%%include/bash/arrayfunc.h
-%%NLS%%%%NO_STATIC%%include/bash/assoc.h
-%%NLS%%%%NO_STATIC%%include/bash/bashansi.h
-%%NLS%%%%NO_STATIC%%include/bash/bashintl.h
-%%NLS%%%%NO_STATIC%%include/bash/bashjmp.h
-%%NLS%%%%NO_STATIC%%include/bash/bashtypes.h
-%%NLS%%%%NO_STATIC%%include/bash/builtins.h
-%%NLS%%%%NO_STATIC%%include/bash/builtins/bashgetopt.h
-%%NLS%%%%NO_STATIC%%include/bash/builtins/builtext.h
-%%NLS%%%%NO_STATIC%%include/bash/builtins/common.h
-%%NLS%%%%NO_STATIC%%include/bash/builtins/getopt.h
-%%NLS%%%%NO_STATIC%%include/bash/command.h
-%%NLS%%%%NO_STATIC%%include/bash/config-bot.h
-%%NLS%%%%NO_STATIC%%include/bash/config-top.h
-%%NLS%%%%NO_STATIC%%include/bash/config.h
-%%NLS%%%%NO_STATIC%%include/bash/conftypes.h
-%%NLS%%%%NO_STATIC%%include/bash/dispose_cmd.h
-%%NLS%%%%NO_STATIC%%include/bash/error.h
-%%NLS%%%%NO_STATIC%%include/bash/execute_cmd.h
-%%NLS%%%%NO_STATIC%%include/bash/externs.h
-%%NLS%%%%NO_STATIC%%include/bash/general.h
-%%NLS%%%%NO_STATIC%%include/bash/hashlib.h
-%%NLS%%%%NO_STATIC%%include/bash/include/ansi_stdlib.h
-%%NLS%%%%NO_STATIC%%include/bash/include/chartypes.h
-%%NLS%%%%NO_STATIC%%include/bash/include/filecntl.h
-%%NLS%%%%NO_STATIC%%include/bash/include/gettext.h
-%%NLS%%%%NO_STATIC%%include/bash/include/maxpath.h
-%%NLS%%%%NO_STATIC%%include/bash/include/memalloc.h
-%%NLS%%%%NO_STATIC%%include/bash/include/ocache.h
-%%NLS%%%%NO_STATIC%%include/bash/include/posixdir.h
-%%NLS%%%%NO_STATIC%%include/bash/include/posixjmp.h
-%%NLS%%%%NO_STATIC%%include/bash/include/posixstat.h
-%%NLS%%%%NO_STATIC%%include/bash/include/posixtime.h
-%%NLS%%%%NO_STATIC%%include/bash/include/posixwait.h
-%%NLS%%%%NO_STATIC%%include/bash/include/shmbchar.h
-%%NLS%%%%NO_STATIC%%include/bash/include/shmbutil.h
-%%NLS%%%%NO_STATIC%%include/bash/include/shtty.h
-%%NLS%%%%NO_STATIC%%include/bash/include/stat-time.h
-%%NLS%%%%NO_STATIC%%include/bash/include/stdc.h
-%%NLS%%%%NO_STATIC%%include/bash/include/systimes.h
-%%NLS%%%%NO_STATIC%%include/bash/include/typemax.h
-%%NLS%%%%NO_STATIC%%include/bash/include/unionwait.h
-%%NLS%%%%NO_STATIC%%include/bash/jobs.h
-%%NLS%%%%NO_STATIC%%include/bash/make_cmd.h
-%%NLS%%%%NO_STATIC%%include/bash/pathnames.h
-%%NLS%%%%NO_STATIC%%include/bash/quit.h
-%%NLS%%%%NO_STATIC%%include/bash/shell.h
-%%NLS%%%%NO_STATIC%%include/bash/sig.h
-%%NLS%%%%NO_STATIC%%include/bash/siglist.h
-%%NLS%%%%NO_STATIC%%include/bash/signames.h
-%%NLS%%%%NO_STATIC%%include/bash/subst.h
-%%NLS%%%%NO_STATIC%%include/bash/syntax.h
-%%NLS%%%%NO_STATIC%%include/bash/unwind_prot.h
-%%NLS%%%%NO_STATIC%%include/bash/variables.h
-%%NLS%%%%NO_STATIC%%include/bash/version.h
-%%NLS%%%%NO_STATIC%%include/bash/xmalloc.h
-%%NLS%%%%NO_STATIC%%include/bash/y.tab.h
-%%NLS%%%%NO_STATIC%%lib/bash/Makefile.inc
-%%NLS%%%%NO_STATIC%%lib/bash/Makefile.sample
-%%NLS%%%%NO_STATIC%%lib/bash/accept
-%%NLS%%%%NO_STATIC%%lib/bash/basename
-%%NLS%%%%NO_STATIC%%lib/bash/csv
-%%NLS%%%%NO_STATIC%%lib/bash/cut
-%%NLS%%%%NO_STATIC%%lib/bash/dirname
-%%NLS%%%%NO_STATIC%%lib/bash/dsv
-%%NLS%%%%NO_STATIC%%lib/bash/fdflags
-%%NLS%%%%NO_STATIC%%lib/bash/finfo
-%%NLS%%%%NO_STATIC%%lib/bash/getconf
-%%NLS%%%%NO_STATIC%%lib/bash/head
-%%NLS%%%%NO_STATIC%%lib/bash/id
-%%NLS%%%%NO_STATIC%%lib/bash/ln
-%%NLS%%%%NO_STATIC%%lib/bash/loadables.h
-%%NLS%%%%NO_STATIC%%lib/bash/logname
-%%NLS%%%%NO_STATIC%%lib/bash/mkdir
-%%NLS%%%%NO_STATIC%%lib/bash/mkfifo
-%%NLS%%%%NO_STATIC%%lib/bash/mktemp
-%%NLS%%%%NO_STATIC%%lib/bash/mypid
-%%NLS%%%%NO_STATIC%%lib/bash/pathchk
-%%NLS%%%%NO_STATIC%%lib/bash/print
-%%NLS%%%%NO_STATIC%%lib/bash/printenv
-%%NLS%%%%NO_STATIC%%lib/bash/push
-%%NLS%%%%NO_STATIC%%lib/bash/realpath
-%%NLS%%%%NO_STATIC%%lib/bash/rm
-%%NLS%%%%NO_STATIC%%lib/bash/rmdir
-%%NLS%%%%NO_STATIC%%lib/bash/seq
-%%NLS%%%%NO_STATIC%%lib/bash/setpgid
-%%NLS%%%%NO_STATIC%%lib/bash/sleep
-%%NLS%%%%NO_STATIC%%lib/bash/stat
-%%NLS%%%%NO_STATIC%%lib/bash/strftime
-%%NLS%%%%NO_STATIC%%lib/bash/sync
-%%NLS%%%%NO_STATIC%%lib/bash/tee
-%%NLS%%%%NO_STATIC%%lib/bash/truefalse
-%%NLS%%%%NO_STATIC%%lib/bash/tty
-%%NLS%%%%NO_STATIC%%lib/bash/uname
-%%NLS%%%%NO_STATIC%%lib/bash/unlink
-%%NLS%%%%NO_STATIC%%lib/bash/whoami
-%%NLS%%%%NO_STATIC%%libdata/pkgconfig/bash.pc