aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-05-16 12:36:12 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-05-16 22:19:47 +0000
commit804ac2395851da1f7e19c986895ebc92277a573e (patch)
tree288e5ba1043e643aa5df29ecccb36245502ff5a2
parentf923df1176eb6d8a38bb9ef465bb1b6388ca817f (diff)
downloadports-804ac2395851da1f7e19c986895ebc92277a573e.tar.gz
ports-804ac2395851da1f7e19c986895ebc92277a573e.zip
net/openmpi: fix build on powerpc*
configure:16066: checking for short float configure:16066: cc -c -DNDEBUG -O2 -pipe -I/usr/local/include/gcc13 -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing -finline-functions -isystem /usr/local/include conftest.c >&5 conftest.c:149:13: error: 'short float' is invalid 149 | if (sizeof (short float)) | ^ 1 error generated.
-rw-r--r--net/openmpi/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/openmpi/Makefile b/net/openmpi/Makefile
index 2535dce33f3d..f99e2fcdc58b 100644
--- a/net/openmpi/Makefile
+++ b/net/openmpi/Makefile
@@ -106,7 +106,7 @@ PLIST_SUB+= NO_MCA_PATCHER_OVERWRITE="@comment "
PLIST_SUB+= NO_MCA_PATCHER_OVERWRITE=""
.endif
-.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 170
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 170 && !${ARCH:Mpowerpc*}
PLIST_SUB+= SHORTFLOAT=""
.else
PLIST_SUB+= SHORTFLOAT="@comment "