aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-21 20:45:34 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-21 20:45:34 +0000
commit805c652f35b30a8cfe251f3d8c95c0ca881b23ba (patch)
tree6bdde1cb0714acae1251f544234163d6e31fed25
parent16e6c37f8936a664e813cacf9b16eead7759fabc (diff)
downloadports-805c652f35b30a8cfe251f3d8c95c0ca881b23ba.tar.gz
ports-805c652f35b30a8cfe251f3d8c95c0ca881b23ba.zip
- Mark remaining mod_* ports MAKE_JOBS_SAFE=yes
PR: ports/134611 Approved by: pav (#bsdports)
Notes
Notes: svn path=/head/; revision=234362
-rw-r--r--korean/mod_url/Makefile2
-rw-r--r--www/mod_auth_form/Makefile2
-rw-r--r--www/mod_auth_ldap/Makefile2
-rw-r--r--www/mod_auth_mysql2/Makefile2
-rw-r--r--www/mod_auth_mysql41_ap2/Makefile2
-rw-r--r--www/mod_auth_mysql_another/Makefile2
-rw-r--r--www/mod_auth_pam/Makefile2
-rw-r--r--www/mod_auth_xradius/Makefile2
-rw-r--r--www/mod_blosxom/Makefile2
-rw-r--r--www/mod_clamav/Makefile2
-rw-r--r--www/mod_dnssd/Makefile2
-rw-r--r--www/mod_domaintree/Makefile2
-rw-r--r--www/mod_encoding/Makefile2
-rw-r--r--www/mod_evasive/Makefile2
-rw-r--r--www/mod_extract_forwarded/Makefile2
-rw-r--r--www/mod_extract_forwarded_ap13/Makefile2
-rw-r--r--www/mod_fcgid/Makefile2
-rw-r--r--www/mod_fileiri/Makefile2
-rw-r--r--www/mod_geoip/Makefile2
-rw-r--r--www/mod_geoip2/Makefile2
-rw-r--r--www/mod_gzip/Makefile2
-rw-r--r--www/mod_gzip2/Makefile2
-rw-r--r--www/mod_jk-apache2/Makefile2
-rw-r--r--www/mod_jk/Makefile2
-rw-r--r--www/mod_limitipconn/Makefile2
-rw-r--r--www/mod_limitipconn2/Makefile2
-rw-r--r--www/mod_line_edit/Makefile2
-rw-r--r--www/mod_lisp2/Makefile2
-rw-r--r--www/mod_log_dbd/Makefile2
-rw-r--r--www/mod_log_firstbyte/Makefile2
-rw-r--r--www/mod_log_sql/Makefile2
-rw-r--r--www/mod_log_sql2-dtc/Makefile2
-rw-r--r--www/mod_macro22/Makefile2
-rw-r--r--www/mod_memcache/Makefile2
-rw-r--r--www/mod_ntlm/Makefile2
-rw-r--r--www/mod_proctitle/Makefile2
-rw-r--r--www/mod_proxy_add_forward/Makefile2
-rw-r--r--www/mod_proxy_html/Makefile2
-rw-r--r--www/mod_proxy_xml/Makefile2
-rw-r--r--www/mod_ruby/Makefile2
-rw-r--r--www/mod_scgi/Makefile2
-rw-r--r--www/mod_security/Makefile2
-rw-r--r--www/mod_security21/Makefile2
-rw-r--r--www/mod_shapvh/Makefile2
-rw-r--r--www/mod_sqlinclude/Makefile2
-rw-r--r--www/mod_transform/Makefile2
-rw-r--r--www/mod_uid/Makefile2
-rw-r--r--www/mod_wsgi/Makefile2
-rw-r--r--www/mod_wsgi3/Makefile2
-rw-r--r--www/mod_xmlns/Makefile2
-rw-r--r--www/mod_xsendfile/Makefile2
51 files changed, 102 insertions, 0 deletions
diff --git a/korean/mod_url/Makefile b/korean/mod_url/Makefile
index 1e7acc2ab486..bafc552cbc2a 100644
--- a/korean/mod_url/Makefile
+++ b/korean/mod_url/Makefile
@@ -13,6 +13,8 @@ DISTFILES= ${PORTNAME}.c readme.${PORTNAME}
MAINTAINER= cjh@FreeBSD.org
COMMENT= Apache module for manipulating euc-kr encoded URL
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3
USE_ICONV= yes
diff --git a/www/mod_auth_form/Makefile b/www/mod_auth_form/Makefile
index 314df0f35b42..d8b83a066e8a 100644
--- a/www/mod_auth_form/Makefile
+++ b/www/mod_auth_form/Makefile
@@ -14,6 +14,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= net@arrishq.net
COMMENT= MySQL based form authentication module for Apache 2.x
+MAKE_JOBS_SAFE= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MYSQL= YES
diff --git a/www/mod_auth_ldap/Makefile b/www/mod_auth_ldap/Makefile
index 5ff59de53939..fe1d048b9771 100644
--- a/www/mod_auth_ldap/Makefile
+++ b/www/mod_auth_ldap/Makefile
@@ -17,6 +17,8 @@ DISTNAME= modauthldap_apache2
MAINTAINER= gerrit.beine@gmx.de
COMMENT= Apache module to authenticate against an LDAP directory
+MAKE_JOBS_SAFE= yes
+
USE_OPENLDAP= yes
USE_APACHE= 2.0+
AP_FAST_BUILD= yes
diff --git a/www/mod_auth_mysql2/Makefile b/www/mod_auth_mysql2/Makefile
index 5904b70edc52..766e9f092306 100644
--- a/www/mod_auth_mysql2/Makefile
+++ b/www/mod_auth_mysql2/Makefile
@@ -16,6 +16,8 @@ DIST_SUBDIR= apache22
MAINTAINER= mm@FreeBSD.org
COMMENT= MySQL-based authentication module with VirtualHost support
+MAKE_JOBS_SAFE= yes
+
LATEST_LINK= mod_auth_mysql2
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/www/mod_auth_mysql41_ap2/Makefile b/www/mod_auth_mysql41_ap2/Makefile
index 16f513f39169..5b2eaf23f7b8 100644
--- a/www/mod_auth_mysql41_ap2/Makefile
+++ b/www/mod_auth_mysql41_ap2/Makefile
@@ -15,6 +15,8 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= maske@maske.org
COMMENT= MySQL 4.1 and Apache 2 port of mod_auth_mysql
+MAKE_JOBS_SAFE= yes
+
USE_MYSQL= YES
WANT_MYSQL_VER= 41
diff --git a/www/mod_auth_mysql_another/Makefile b/www/mod_auth_mysql_another/Makefile
index 492f6f3c9f08..8c97a5fa3ae2 100644
--- a/www/mod_auth_mysql_another/Makefile
+++ b/www/mod_auth_mysql_another/Makefile
@@ -15,6 +15,8 @@ PKGNAMESUFFIX= _another
MAINTAINER= mbr@FreeBSD.org
COMMENT= Allows users to use MySQL databases for user authentication
+MAKE_JOBS_SAFE= yes
+
USE_MYSQL= YES
SHORTMODNAME= mysql_auth
diff --git a/www/mod_auth_pam/Makefile b/www/mod_auth_pam/Makefile
index 27c7900c1c17..9d131934ee14 100644
--- a/www/mod_auth_pam/Makefile
+++ b/www/mod_auth_pam/Makefile
@@ -15,6 +15,8 @@ MASTER_SITES= http://pam.sourceforge.net/mod_auth_pam/dist/ \
MAINTAINER= anders@FreeBSD.org
COMMENT= Allows users to use PAM modules for user authentication
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3
AP_FAST_BUILD= yes
diff --git a/www/mod_auth_xradius/Makefile b/www/mod_auth_xradius/Makefile
index 1ba3b2198a3d..4a8457d76ae5 100644
--- a/www/mod_auth_xradius/Makefile
+++ b/www/mod_auth_xradius/Makefile
@@ -12,6 +12,8 @@ MASTER_SITES= http://www.outoforder.cc/downloads/mod_auth_xradius/
MAINTAINER= mwlucas@FreeBSD.org
COMMENT= Enables RADIUS authentication
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 2.0+
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/www/mod_blosxom/Makefile b/www/mod_blosxom/Makefile
index 06122b2f25e2..ec8033ffbb53 100644
--- a/www/mod_blosxom/Makefile
+++ b/www/mod_blosxom/Makefile
@@ -15,6 +15,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
MAINTAINER= ychsiao@ychsiao.org
COMMENT= Apache module to build the extremely lightweight Weblog environment
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3
AP_FAST_BUILD= yes
AP_GENPLIST= yes
diff --git a/www/mod_clamav/Makefile b/www/mod_clamav/Makefile
index 536c2a89d60a..ee7002a4903a 100644
--- a/www/mod_clamav/Makefile
+++ b/www/mod_clamav/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= http://software.othello.ch/mod_clamav/ \
MAINTAINER= tmueko@kommunity.net
COMMENT= Scans content delivered by the Apache20 proxy module for viruses
+MAKE_JOBS_SAFE= yes
+
USE_AUTOTOOLS= libtool:15
USE_APACHE= 2.2
GNU_CONFIGURE= yes
diff --git a/www/mod_dnssd/Makefile b/www/mod_dnssd/Makefile
index da3ac6bc638e..4053b1ff82fa 100644
--- a/www/mod_dnssd/Makefile
+++ b/www/mod_dnssd/Makefile
@@ -16,6 +16,8 @@ COMMENT= An Apache module that provides DNS-SD capabilities
LIB_DEPENDS= avahi-client.3:${PORTSDIR}/net/avahi-app
+MAKE_JOBS_SAFE= yes
+
USE_GMAKE= yes
USE_APACHE= 2.2+
GNU_CONFIGURE= yes
diff --git a/www/mod_domaintree/Makefile b/www/mod_domaintree/Makefile
index 0ef6e83b5f87..d4e9d76de527 100644
--- a/www/mod_domaintree/Makefile
+++ b/www/mod_domaintree/Makefile
@@ -14,6 +14,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= danger@FreeBSD.org
COMMENT= Hostname to filesystem mapper for Apache 2
+MAKE_JOBS_SAFE= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_APACHE= 2.0+
AP_FAST_BUILD= YES
diff --git a/www/mod_encoding/Makefile b/www/mod_encoding/Makefile
index 9452184a8de1..ce529f182781 100644
--- a/www/mod_encoding/Makefile
+++ b/www/mod_encoding/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= http://webdav.todo.gr.jp/download/
MAINTAINER= edwin@mavetju.org
COMMENT= Apache module for non-ascii filename interoperability
+MAKE_JOBS_SAFE= yes
+
# This port will work with the following version of Apache and anything newer.
# Mostly because of the dependency of mod_dav.
#APACHE_VERSION= 1.3.6
diff --git a/www/mod_evasive/Makefile b/www/mod_evasive/Makefile
index 36a621b256b8..a066828b0804 100644
--- a/www/mod_evasive/Makefile
+++ b/www/mod_evasive/Makefile
@@ -16,6 +16,8 @@ DIST_SUBDIR= apache2
MAINTAINER= kiwi@oav.net
COMMENT= An Apache module to try to protect the HTTP Server from DoS/DDoS attacks
+MAKE_JOBS_SAFE= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_APACHE= 1.3+
diff --git a/www/mod_extract_forwarded/Makefile b/www/mod_extract_forwarded/Makefile
index 8951f2336da1..8130adbf9cae 100644
--- a/www/mod_extract_forwarded/Makefile
+++ b/www/mod_extract_forwarded/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= http://web.warhound.org/${PORTNAME}/ \
MAINTAINER= anders@FreeBSD.org
COMMENT= An Apache module that can make proxied requests appear with client IP
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3
AP_FAST_BUILD= yes
AP_GENPLIST= yes
diff --git a/www/mod_extract_forwarded_ap13/Makefile b/www/mod_extract_forwarded_ap13/Makefile
index 8951f2336da1..8130adbf9cae 100644
--- a/www/mod_extract_forwarded_ap13/Makefile
+++ b/www/mod_extract_forwarded_ap13/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= http://web.warhound.org/${PORTNAME}/ \
MAINTAINER= anders@FreeBSD.org
COMMENT= An Apache module that can make proxied requests appear with client IP
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3
AP_FAST_BUILD= yes
AP_GENPLIST= yes
diff --git a/www/mod_fcgid/Makefile b/www/mod_fcgid/Makefile
index 32579deea8bd..621df1428fcd 100644
--- a/www/mod_fcgid/Makefile
+++ b/www/mod_fcgid/Makefile
@@ -15,6 +15,8 @@ DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= hemi@puresimplicity.net
COMMENT= An alternative FastCGI module for Apache2
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 2.0+
SUB_FILES= pkg-message
diff --git a/www/mod_fileiri/Makefile b/www/mod_fileiri/Makefile
index 2c96c4f2c540..627f7166818d 100644
--- a/www/mod_fileiri/Makefile
+++ b/www/mod_fileiri/Makefile
@@ -14,6 +14,8 @@ DIST_SUBDIR= apache2
MAINTAINER= chinsan@FreeBSD.org
COMMENT= A http IRIs module for Apache 2
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 20+
PLIST_SUB= APACHE_DIR=${APACHEMODDIR}
diff --git a/www/mod_geoip/Makefile b/www/mod_geoip/Makefile
index ddcaadf88a9e..afec0ceff524 100644
--- a/www/mod_geoip/Makefile
+++ b/www/mod_geoip/Makefile
@@ -18,6 +18,8 @@ COMMENT= An Apache module that provides the country code of the client's IP
BUILD_DEPENDS= GeoIP>=1.4.4:${PORTSDIR}/net/GeoIP
RUN_DEPENDS= GeoIP>=1.4.4:${PORTSDIR}/net/GeoIP
+MAKE_JOBS_SAFE= yes
+
CONFLICTS= mod_geoip2-[0-9]*
USE_APACHE= 1.3
diff --git a/www/mod_geoip2/Makefile b/www/mod_geoip2/Makefile
index dd0632e079fa..a4b8d1705389 100644
--- a/www/mod_geoip2/Makefile
+++ b/www/mod_geoip2/Makefile
@@ -17,6 +17,8 @@ COMMENT= An Apache module that provides the country code of the client's IP
BUILD_DEPENDS= GeoIP>=1.4.4:${PORTSDIR}/net/GeoIP
RUN_DEPENDS= GeoIP>=1.4.4:${PORTSDIR}/net/GeoIP
+MAKE_JOBS_SAFE= yes
+
CONFLICTS= mod_geoip-[0-9]*
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
diff --git a/www/mod_gzip/Makefile b/www/mod_gzip/Makefile
index 95721770fbb8..40b681f9694f 100644
--- a/www/mod_gzip/Makefile
+++ b/www/mod_gzip/Makefile
@@ -15,6 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ale@FreeBSD.org
COMMENT= An Internet Content Acceleration module for Apache
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3
MAKE_ENV+= "APXS=${APXS}"
ALL_TARGET= build
diff --git a/www/mod_gzip2/Makefile b/www/mod_gzip2/Makefile
index 7221d9b6fdc6..6d8f1ed5855a 100644
--- a/www/mod_gzip2/Makefile
+++ b/www/mod_gzip2/Makefile
@@ -15,6 +15,8 @@ DISTNAME= mod_gzip-${PORTVERSION}
MAINTAINER= sec@42.org
COMMENT= An Internet Content Acceleration module for Apache2+
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 2.0+
AP_FAST_BUILD= yes
AP_GENPLIST= yes
diff --git a/www/mod_jk-apache2/Makefile b/www/mod_jk-apache2/Makefile
index 4152cf8b9ad0..072d418cb7c2 100644
--- a/www/mod_jk-apache2/Makefile
+++ b/www/mod_jk-apache2/Makefile
@@ -14,4 +14,6 @@ LATEST_LINK= mod_jk-ap2
MAINTAINER= girgen@FreeBSD.org
COMMENT= Apache2 JK module for connecting to Tomcat using AJP1X
+MAKE_JOBS_SAFE= yes
+
.include "${MASTERDIR}/Makefile"
diff --git a/www/mod_jk/Makefile b/www/mod_jk/Makefile
index 7cc40cf883a3..aef68b2424d9 100644
--- a/www/mod_jk/Makefile
+++ b/www/mod_jk/Makefile
@@ -17,6 +17,8 @@ DISTNAME= tomcat-connectors-${PORTVERSION}-src
MAINTAINER?= girgen@FreeBSD.org
COMMENT?= Apache JK module for connecting to Tomcat using AJP1X
+MAKE_JOBS_SAFE= yes
+
USE_APACHE?= 1.3+
.include <bsd.port.pre.mk>
diff --git a/www/mod_limitipconn/Makefile b/www/mod_limitipconn/Makefile
index 864cd8658b3f..8790db57a1d9 100644
--- a/www/mod_limitipconn/Makefile
+++ b/www/mod_limitipconn/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= http://dominia.org/djao/limit/
MAINTAINER= ychsiao@ychsiao.org
COMMENT= Limit the number of simultaneous connections from a single IP address
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3
PLIST_FILES= ${APACHEMODDIR}/mod_limitipconn.so
diff --git a/www/mod_limitipconn2/Makefile b/www/mod_limitipconn2/Makefile
index fab273898432..e48b0b5e5639 100644
--- a/www/mod_limitipconn2/Makefile
+++ b/www/mod_limitipconn2/Makefile
@@ -14,6 +14,8 @@ DIST_SUBDIR= apache2
MAINTAINER= ychsiao@ychsiao.org
COMMENT= Allows you to limit the number of simultaneous connexions
+MAKE_JOBS_SAFE= yes
+
LATEST_LINK= mod_limitipconn2
USE_APACHE= 2.0+
diff --git a/www/mod_line_edit/Makefile b/www/mod_line_edit/Makefile
index b79957c0a90f..4ad7f21edbf5 100644
--- a/www/mod_line_edit/Makefile
+++ b/www/mod_line_edit/Makefile
@@ -16,6 +16,8 @@ DISTFILES= mod_line_edit.c
MAINTAINER= dom@helenmarks.co.uk
COMMENT= Apache module for simple text rewriting
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 2.0+
do-extract:
diff --git a/www/mod_lisp2/Makefile b/www/mod_lisp2/Makefile
index 850c3154bce0..5df839462163 100644
--- a/www/mod_lisp2/Makefile
+++ b/www/mod_lisp2/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= http://freebsd.minira.nl/
MAINTAINER= viktor.leis@googlemail.com
COMMENT= Apache2 module for use with Common Lisp
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 20+
AP_FAST_BUILD= YES
AP_GENPLIST= YES
diff --git a/www/mod_log_dbd/Makefile b/www/mod_log_dbd/Makefile
index 55d2593e2e43..af464137c60a 100644
--- a/www/mod_log_dbd/Makefile
+++ b/www/mod_log_dbd/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= http://bfoz.net/projects/${PORTNAME}/release/
MAINTAINER= bfoz@bfoz.net
COMMENT= Uses APR DBD to store Apache access logs in a database
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 2.2+
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/www/mod_log_firstbyte/Makefile b/www/mod_log_firstbyte/Makefile
index 181606fd0bd4..89e7d1cd1b02 100644
--- a/www/mod_log_firstbyte/Makefile
+++ b/www/mod_log_firstbyte/Makefile
@@ -14,6 +14,8 @@ DISTFILES= ${PORTNAME}.c readme.txt
MAINTAINER= leeym@FreeBSD.org
COMMENT= Log the time between request and the first byte of the response served
+MAKE_JOBS_SAFE= yes
+
PROJECTHOST= mod-log-firstbyte
USE_APACHE= 2.0+
MOD= mod_log_firstbyte
diff --git a/www/mod_log_sql/Makefile b/www/mod_log_sql/Makefile
index c3af789676a8..31eaa0741901 100644
--- a/www/mod_log_sql/Makefile
+++ b/www/mod_log_sql/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= http://www.outoforder.cc/downloads/${PORTNAME}/
MAINTAINER= lev@FreeBSD.org
COMMENT= Allows Apache to log to a MySQL database
+MAKE_JOBS_SAFE= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_MYSQL= yes
diff --git a/www/mod_log_sql2-dtc/Makefile b/www/mod_log_sql2-dtc/Makefile
index 01366e96713d..647229dde778 100644
--- a/www/mod_log_sql2-dtc/Makefile
+++ b/www/mod_log_sql2-dtc/Makefile
@@ -14,6 +14,8 @@ PKGNAMESUFFIX= -dtc
MAINTAINER= scrappy@freebsd.org
COMMENT= Allows Apache to log to a MySQL database
+MAKE_JOBS_SAFE= yes
+
LATEST_LINK= mod_log_sql2
GNU_CONFIGURE= yes
USE_BZIP2= yes
diff --git a/www/mod_macro22/Makefile b/www/mod_macro22/Makefile
index 8b3371af4942..38e81e473c5b 100644
--- a/www/mod_macro22/Makefile
+++ b/www/mod_macro22/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= http://www.cri.ensmp.fr/~coelho/mod_macro/
MAINTAINER= lukasz@wasikowski.net
COMMENT= Apache 2.2.x module for use macros in config files
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 22
LATEST_LINK= mod_macro22
AP_FAST_BUILD= YES
diff --git a/www/mod_memcache/Makefile b/www/mod_memcache/Makefile
index d02c2f233c97..ab8819390077 100644
--- a/www/mod_memcache/Makefile
+++ b/www/mod_memcache/Makefile
@@ -15,6 +15,8 @@ COMMENT= Apache 2.2.x module to manage apr_memcache connections
LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr
+MAKE_JOBS_SAFE= yes
+
GNU_CONFIGURE= yes
PROJECTHOST= modmemcache
USE_APACHE= 2.2+
diff --git a/www/mod_ntlm/Makefile b/www/mod_ntlm/Makefile
index 975cd4f7b7e0..a38135a59dba 100644
--- a/www/mod_ntlm/Makefile
+++ b/www/mod_ntlm/Makefile
@@ -14,6 +14,8 @@ MASTER_SITE_SUBDIR= modntlm
MAINTAINER= skv@FreeBSD.org
COMMENT= NTLM authentication module for the Apache webserver
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3
MAKE_ENV= APXS=${APXS}
diff --git a/www/mod_proctitle/Makefile b/www/mod_proctitle/Makefile
index 9bf743359198..078cc05cfe5b 100644
--- a/www/mod_proctitle/Makefile
+++ b/www/mod_proctitle/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= ftp://ftp.springdaemons.com/soft/
MAINTAINER= stas@FreeBSD.org
COMMENT= Set httpd process titles to reflect currently processed request
+MAKE_JOBS_SAFE= yes
+
USE_APACHE?= 2.0+
GNU_CONFIGURE= yes
USE_BZIP2= yes
diff --git a/www/mod_proxy_add_forward/Makefile b/www/mod_proxy_add_forward/Makefile
index 305201a01995..c5e0d03a7c15 100644
--- a/www/mod_proxy_add_forward/Makefile
+++ b/www/mod_proxy_add_forward/Makefile
@@ -16,6 +16,8 @@ EXTRACT_SUFX= .c
MAINTAINER= anders@FreeBSD.org
COMMENT= Apache module that adds a client IP header to outgoing proxy requests
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3
AP_FAST_BUILD= yes
AP_GENPLIST= yes
diff --git a/www/mod_proxy_html/Makefile b/www/mod_proxy_html/Makefile
index 008eef81ad65..3a12f75b2b41 100644
--- a/www/mod_proxy_html/Makefile
+++ b/www/mod_proxy_html/Makefile
@@ -14,6 +14,8 @@ DISTNAME= ${PORTNAME}
MAINTAINER= dsl@bitwizards.com.au
COMMENT= Apache module for rewriting HTML links in proxied content
+MAKE_JOBS_SAFE= yes
+
SUB_FILES= pkg-message
USE_APACHE= 2.0+
AP_FAST_BUILD= YES
diff --git a/www/mod_proxy_xml/Makefile b/www/mod_proxy_xml/Makefile
index ea620913cdb5..50dbef12d6c3 100644
--- a/www/mod_proxy_xml/Makefile
+++ b/www/mod_proxy_xml/Makefile
@@ -15,6 +15,8 @@ DISTFILES= xmlns.h mod_proxy_xml.c
MAINTAINER= dom@helenmarks.co.uk
COMMENT= Apache module for rewriting URI references in XML
+MAKE_JOBS_SAFE= yes
+
USE_GNOME= libxml2
USE_APACHE= 2.0+
diff --git a/www/mod_ruby/Makefile b/www/mod_ruby/Makefile
index a3670a120baa..6fd6913afd63 100644
--- a/www/mod_ruby/Makefile
+++ b/www/mod_ruby/Makefile
@@ -16,6 +16,8 @@ COMMENT= An Apache module that embeds Ruby interpreter within
LIB_DEPENDS= eruby.10:${PORTSDIR}/textproc/eruby
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3+
USE_RUBY= yes
USE_PERL5_BUILD= yes
diff --git a/www/mod_scgi/Makefile b/www/mod_scgi/Makefile
index 27878d37ba2c..0456108cb004 100644
--- a/www/mod_scgi/Makefile
+++ b/www/mod_scgi/Makefile
@@ -16,6 +16,8 @@ DISTNAME= scgi-${PORTVERSION:S/.a/a/}
MAINTAINER= dryice@dryice.name
COMMENT= Apache module that implements the client side of the SCGI protocol
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3+
WRKSRC= ${WRKDIR}/${DISTNAME}/${SCGI_DIR}
diff --git a/www/mod_security/Makefile b/www/mod_security/Makefile
index 32b79bce3aa8..a6d6bcd671d4 100644
--- a/www/mod_security/Makefile
+++ b/www/mod_security/Makefile
@@ -15,6 +15,8 @@ DISTNAME= ${PORTNAME:S/_//:S/2//}-apache_${PORTVERSION}
MAINTAINER= araujo@FreeBSD.org
COMMENT= An intrusion detection and prevention engine
+MAKE_JOBS_SAFE= yes
+
LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre \
apr-1.3:${PORTSDIR}/devel/apr
diff --git a/www/mod_security21/Makefile b/www/mod_security21/Makefile
index 4ad9dd86b05c..723e799ac3d3 100644
--- a/www/mod_security21/Makefile
+++ b/www/mod_security21/Makefile
@@ -14,6 +14,8 @@ DISTNAME= ${PORTNAME:S/_//:S/21//}-apache_${PORTVERSION}
MAINTAINER= araujo@FreeBSD.org
COMMENT= An intrusion detection and prevention engine
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 2.0+
AP_FAST_BUILD= yes
AP_GENPLIST= yes
diff --git a/www/mod_shapvh/Makefile b/www/mod_shapvh/Makefile
index d2a829f9edc4..4205e8157ca8 100644
--- a/www/mod_shapvh/Makefile
+++ b/www/mod_shapvh/Makefile
@@ -15,6 +15,8 @@ EXTRACT_SUFX= .c
MAINTAINER= steven@krx.nl
COMMENT= Apache module that provides virtual hosts from a database
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3
USE_MYSQL= yes
diff --git a/www/mod_sqlinclude/Makefile b/www/mod_sqlinclude/Makefile
index 196aff945fe1..7a8f0e79cf8f 100644
--- a/www/mod_sqlinclude/Makefile
+++ b/www/mod_sqlinclude/Makefile
@@ -15,6 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= anders@FreeBSD.org
COMMENT= An Apache module implementing config inclusion from MySQL databases
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3
USE_MYSQL= yes
diff --git a/www/mod_transform/Makefile b/www/mod_transform/Makefile
index 5a71844c7e3e..be3ae5871ac2 100644
--- a/www/mod_transform/Makefile
+++ b/www/mod_transform/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= http://www.outoforder.cc/downloads/mod_transform/
MAINTAINER= stan@stormier.net
COMMENT= An XSLT and XIncludes Filter module for Apache 2.0
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 2.0
USE_AUTOTOOLS= libtool:15
HAS_CONFIGURE= yes
diff --git a/www/mod_uid/Makefile b/www/mod_uid/Makefile
index ef27111d6dfd..dfb74d224cbd 100644
--- a/www/mod_uid/Makefile
+++ b/www/mod_uid/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= ftp://ftp.lexa.ru/pub/apache-rus/contrib/
MAINTAINER= leeym@FreeBSD.org
COMMENT= A module issuing the "correct" cookies for counting the site visitors
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3+
PORTDOCS= README.html
diff --git a/www/mod_wsgi/Makefile b/www/mod_wsgi/Makefile
index aa51cbc01acb..59ceb6e06641 100644
--- a/www/mod_wsgi/Makefile
+++ b/www/mod_wsgi/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= douglas@douglasthrift.net
COMMENT= Python WSGI adapter module for Apache
+MAKE_JOBS_SAFE= yes
+
PROJECTHOST= modwsgi
USE_APACHE= 1.3+
diff --git a/www/mod_wsgi3/Makefile b/www/mod_wsgi3/Makefile
index aa51cbc01acb..59ceb6e06641 100644
--- a/www/mod_wsgi3/Makefile
+++ b/www/mod_wsgi3/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= douglas@douglasthrift.net
COMMENT= Python WSGI adapter module for Apache
+MAKE_JOBS_SAFE= yes
+
PROJECTHOST= modwsgi
USE_APACHE= 1.3+
diff --git a/www/mod_xmlns/Makefile b/www/mod_xmlns/Makefile
index 9e1d9cce6cfd..ac74a5b5112b 100644
--- a/www/mod_xmlns/Makefile
+++ b/www/mod_xmlns/Makefile
@@ -15,6 +15,8 @@ DISTFILES= xmlns.h mod_xmlns.c
MAINTAINER= dom@helenmarks.co.uk
COMMENT= Apache module for XML namespaces
+MAKE_JOBS_SAFE= yes
+
USE_GNOME= libxml2
USE_APACHE= 2.0+
diff --git a/www/mod_xsendfile/Makefile b/www/mod_xsendfile/Makefile
index 4bb3103c92e3..88d15eeb1841 100644
--- a/www/mod_xsendfile/Makefile
+++ b/www/mod_xsendfile/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= http://celebnamer.celebworld.ws/stuff/mod_xsendfile/
MAINTAINER= potatosaladx@gmail.com
COMMENT= An Apache2 module that processes X-SENDFILE headers
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 2.0+
AP_FAST_BUILD= yes
AP_GENPLIST= yes