aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-23 14:20:31 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-23 14:31:01 +0000
commit8084815bd8a7b4b79c7ae26ff7abddf4b1795a05 (patch)
tree932fcd6f7324fa769f5bb2b3f566c865320eabc6
parentf1d329ab26127a42fa8ca73b33eae4dc40203673 (diff)
downloadports-8084815bd8a7b4b79c7ae26ff7abddf4b1795a05.tar.gz
ports-8084815bd8a7b4b79c7ae26ff7abddf4b1795a05.zip
astro/py-ro: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--astro/py-ro/Makefile6
-rw-r--r--astro/py-ro/files/patch-setup.py11
2 files changed, 15 insertions, 2 deletions
diff --git a/astro/py-ro/Makefile b/astro/py-ro/Makefile
index 5e55c80b0d4a..88a88e5dca5b 100644
--- a/astro/py-ro/Makefile
+++ b/astro/py-ro/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ro
PORTVERSION= 3.6.9
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= astro python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,10 +14,12 @@ WWW= https://staff.washington.edu/rowen/ROPackage/Overview.html \
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/docs/License.txt
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/astro/py-ro/files/patch-setup.py b/astro/py-ro/files/patch-setup.py
new file mode 100644
index 000000000000..297aca09eb0c
--- /dev/null
+++ b/astro/py-ro/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2015-11-02 21:50:21 UTC
++++ setup.py
+@@ -45,7 +45,7 @@ setup(
+ print(("%s version %s" % (PkgName, Version.__version__)))
+
+ setup(
+- name = PkgName,
++ name = PkgName.lower(),
+ version = Version.__version__,
+ description = "Collection of utilities including general algorithms, astronomical transformations and Tkinter widgets",
+ long_description = long_description,