aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 16:22:22 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 17:03:02 +0000
commit808769fdda874bfe1cd27cf65973cf7458638758 (patch)
tree1dbe595cf7493c0e32e8b7879cd782d2182e2fdd
parentff78a16bf827b34df61bc3d37992fb7f9811bb75 (diff)
downloadports-808769fdda874bfe1cd27cf65973cf7458638758.tar.gz
ports-808769fdda874bfe1cd27cf65973cf7458638758.zip
astro/libosmpbf: Fix build with protobuf 22+
-rw-r--r--astro/libosmpbf/Makefile4
-rw-r--r--astro/libosmpbf/files/patch-protobuf11
2 files changed, 13 insertions, 2 deletions
diff --git a/astro/libosmpbf/Makefile b/astro/libosmpbf/Makefile
index 0b57580847d4..ef91f55e6cde 100644
--- a/astro/libosmpbf/Makefile
+++ b/astro/libosmpbf/Makefile
@@ -17,7 +17,7 @@ USE_GITHUB= yes
GH_ACCOUNT= scrosby
GH_PROJECT= OSM-binary
-USES= cmake compiler:c++11-lang
-USE_CXXSTD= c++11
+USES= cmake compiler:c++17-lang
+USE_CXXSTD= c++17
.include <bsd.port.mk>
diff --git a/astro/libosmpbf/files/patch-protobuf b/astro/libosmpbf/files/patch-protobuf
new file mode 100644
index 000000000000..499906ee3407
--- /dev/null
+++ b/astro/libosmpbf/files/patch-protobuf
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2021-01-06 13:47:22 UTC
++++ CMakeLists.txt
+@@ -4,7 +4,7 @@ project(osmpbf VERSION 1.5.0)
+
+ include(GNUInstallDirs)
+
+-set(CMAKE_CXX_STANDARD 11)
++set(CMAKE_CXX_STANDARD 17)
+
+ find_package(Protobuf REQUIRED)
+