aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2021-09-01 16:46:12 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2021-09-01 16:46:12 +0000
commit80ad8b0db81a8385fe904c753e38b46afcc16e91 (patch)
tree86fba564ee7fa27916ba9fcfab26ce8db1e6b6f5
parent1eb8f96f4c2e89587a466430ba10c21d319558bf (diff)
downloadports-80ad8b0db81a8385fe904c753e38b46afcc16e91.tar.gz
ports-80ad8b0db81a8385fe904c753e38b46afcc16e91.zip
www/firefox: update to 92.0 (rc1)
-rw-r--r--www/firefox/Makefile5
-rw-r--r--www/firefox/distinfo6
-rw-r--r--www/firefox/files/patch-bug161891425
-rw-r--r--www/firefox/files/patch-bug165961210
-rw-r--r--www/firefox/files/patch-bug166411530
-rw-r--r--www/firefox/files/patch-freebsd1110
6 files changed, 34 insertions, 52 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index a59a25a12fed..9bc4084f5dec 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -1,8 +1,7 @@
# Created by: Alan Eldridge <alane@FreeBSD.org>
PORTNAME= firefox
-DISTVERSION= 91.0.2
-PORTREVISION= 1
+DISTVERSION= 92.0
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
@@ -13,7 +12,7 @@ MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nspr>=4.32:devel/nspr \
- nss>=3.68:security/nss \
+ nss>=3.69:security/nss \
icu>=67.1,1:devel/icu \
libevent>=2.1.8:devel/libevent \
harfbuzz>=2.8.1:print/harfbuzz \
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index a6f187bfd8aa..2ce0b78ee4e0 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1629750305
-SHA256 (firefox-91.0.2.source.tar.xz) = 23523af27631e24dd7dbab8429bcd0d828133e9d32b7ab343495c6e15912f6b5
-SIZE (firefox-91.0.2.source.tar.xz) = 381193820
+TIMESTAMP = 1630410984
+SHA256 (firefox-92.0.source.tar.xz) = a6a681bbf7d5f8d5e75a8fda629de16a94d2b8938584e20510dda7eea0358dd0
+SIZE (firefox-92.0.source.tar.xz) = 381561996
diff --git a/www/firefox/files/patch-bug1618914 b/www/firefox/files/patch-bug1618914
index c52ac49018b2..915f6415360c 100644
--- a/www/firefox/files/patch-bug1618914
+++ b/www/firefox/files/patch-bug1618914
@@ -3,16 +3,9 @@ From: Jan Beich <jbeich@FreeBSD.org>
Date: Fri, 28 Feb 2020 16:49:38 +0000
Subject: Bug 1618914 - [Wayland] Fall back to ftruncate if posix_fallocate isn't supported by filesystem.
-diff --git widget/gtk/WaylandShmBuffer.cpp widget/gtk/WaylandShmBuffer.cpp
-index 42eeedd3429ac..2a5c23d287413 100644
---- widget/gtk/WaylandShmBuffer.cpp
-+++ widget/gtk/WaylandShmBuffer.cpp
-@@ -67,36 +67,37 @@ static int WaylandAllocateShmMemory(int aSize) {
- return -1;
- }
-
- int ret = 0;
- #ifdef HAVE_POSIX_FALLOCATE
+--- widget/gtk/WaylandBuffer.cpp.orig 2021-08-31 14:09:31.912165000 +0200
++++ widget/gtk/WaylandBuffer.cpp 2021-08-31 14:20:08.723307000 +0200
+@@ -72,7 +72,9 @@
do {
ret = posix_fallocate(fd, 0, aSize);
} while (ret == EINTR);
@@ -23,7 +16,7 @@ index 42eeedd3429ac..2a5c23d287413 100644
NS_WARNING(
nsPrintfCString("posix_fallocate() fails to allocate shm memory: %s",
strerror(ret))
- .get());
+@@ -80,7 +82,7 @@
close(fd);
return -1;
}
@@ -32,10 +25,7 @@ index 42eeedd3429ac..2a5c23d287413 100644
do {
ret = ftruncate(fd, aSize);
} while (ret < 0 && errno == EINTR);
- if (ret < 0) {
- NS_WARNING(nsPrintfCString("ftruncate() fails to allocate shm memory: %s",
- strerror(ret))
- .get());
+@@ -91,7 +93,6 @@
close(fd);
fd = -1;
}
@@ -43,8 +33,3 @@ index 42eeedd3429ac..2a5c23d287413 100644
return fd;
}
-
- /* static */
- RefPtr<WaylandShmPool> WaylandShmPool::Create(
- const RefPtr<nsWaylandDisplay>& aWaylandDisplay, int aSize) {
- RefPtr<WaylandShmPool> shmPool = new WaylandShmPool(aSize);
diff --git a/www/firefox/files/patch-bug1659612 b/www/firefox/files/patch-bug1659612
index f8ca9dc2d6ee..dce125b883d2 100644
--- a/www/firefox/files/patch-bug1659612
+++ b/www/firefox/files/patch-bug1659612
@@ -20,8 +20,8 @@ media/libcubeb/src/cubeb_alsa.c:1168:3: note: include the header <stdlib.h> or e
^
2 errors generated.
---- media/libcubeb/src/cubeb_alsa.c~
-+++ media/libcubeb/src/cubeb_alsa.c
+--- media/libcubeb/src/cubeb_alsa.c.orig 2021-08-31 14:26:24.530548000 +0200
++++ media/libcubeb/src/cubeb_alsa.c 2021-08-31 14:26:43.081470000 +0200
@@ -5,9 +5,7 @@
* accompanying file LICENSE for details.
*/
@@ -30,6 +30,6 @@ media/libcubeb/src/cubeb_alsa.c:1168:3: note: include the header <stdlib.h> or e
-#define _BSD_SOURCE
-#define _XOPEN_SOURCE 500
+#define _GNU_SOURCE 1
- #include <pthread.h>
- #include <sys/time.h>
- #include <assert.h>
+ #include "cubeb-internal.h"
+ #include "cubeb/cubeb.h"
+ #include <alsa/asoundlib.h>
diff --git a/www/firefox/files/patch-bug1664115 b/www/firefox/files/patch-bug1664115
index 05bc6a15e35f..8a6e82d59b1f 100644
--- a/www/firefox/files/patch-bug1664115
+++ b/www/firefox/files/patch-bug1664115
@@ -3,9 +3,9 @@ using any cubeb backends other than pulse-rust to play media. The loss of
such change will be that users will not be able to do profiling on threads
created by libcubeb.
---- dom/media/AudioStream.cpp.orig 2021-03-20 22:57:21.194862000 +0100
-+++ dom/media/AudioStream.cpp 2021-03-20 23:00:50.527112000 +0100
-@@ -26,7 +26,6 @@
+--- dom/media/AudioStream.cpp.orig 2021-09-01 15:26:18.998745000 +0200
++++ dom/media/AudioStream.cpp 2021-09-01 15:34:45.227435000 +0200
+@@ -27,7 +27,6 @@
#endif
#include "Tracing.h"
#include "webaudio/blink/DenormalDisabler.h"
@@ -13,29 +13,27 @@ created by libcubeb.
// Use abort() instead of exception in SoundTouch.
#define ST_NO_EXCEPTION_HANDLING 1
-@@ -139,9 +138,7 @@
+@@ -140,9 +139,7 @@
mTimeStretcher(nullptr),
mState(INITIALIZED),
mDataSource(aSource),
- mPrefillQuirk(false),
-- mAudioThreadId(0),
+- mAudioThreadId(ProfilerThreadId{}),
- mSandboxed(CubebUtils::SandboxEnabled()) {}
+ mPrefillQuirk(false) {}
AudioStream::~AudioStream() {
LOG("deleted, state %d", mState);
-@@ -565,21 +562,7 @@
+@@ -582,19 +579,7 @@
aWriter.Available());
}
-bool AudioStream::CheckThreadIdChanged() {
--#ifdef MOZ_GECKO_PROFILER
-- auto id = profiler_current_thread_id();
+- ProfilerThreadId id = profiler_current_thread_id();
- if (id != mAudioThreadId) {
- mAudioThreadId = id;
- return true;
- }
--#endif
- return false;
-}
-
@@ -46,7 +44,7 @@ created by libcubeb.
WebCore::DenormalDisabler disabler;
TRACE_AUDIO_CALLBACK_BUDGET(aFrames, mAudioClock.GetInputRate());
-@@ -635,9 +618,6 @@
+@@ -650,9 +635,6 @@
mDumpFile.Write(static_cast<const AudioDataValue*>(aBuffer),
aFrames * mOutChannels);
@@ -56,9 +54,9 @@ created by libcubeb.
return aFrames - writer.Available();
}
---- dom/media/AudioStream.h.orig 2021-03-20 23:01:10.169773000 +0100
-+++ dom/media/AudioStream.h 2021-03-20 23:01:56.622691000 +0100
-@@ -294,7 +294,6 @@
+--- dom/media/AudioStream.h.orig 2021-09-01 15:26:35.926655000 +0200
++++ dom/media/AudioStream.h 2021-09-01 15:35:53.435096000 +0200
+@@ -297,7 +297,6 @@
template <typename Function, typename... Args>
int InvokeCubeb(Function aFunction, Args&&... aArgs);
@@ -66,12 +64,12 @@ created by libcubeb.
// The monitor is held to protect all access to member variables.
Monitor mMonitor;
-@@ -328,9 +327,6 @@
+@@ -331,9 +330,6 @@
// the default device is used. It is set
// during the Init() in decoder thread.
RefPtr<AudioDeviceInfo> mSinkInfo;
-- /* Contains the id of the audio thread, from profiler_get_thread_id. */
-- std::atomic<int> mAudioThreadId;
+- // Contains the id of the audio thread, from profiler_get_thread_id.
+- std::atomic<ProfilerThreadId> mAudioThreadId;
- const bool mSandboxed = false;
MozPromiseHolder<MediaSink::EndedPromise> mEndedPromise;
diff --git a/www/firefox/files/patch-freebsd11 b/www/firefox/files/patch-freebsd11
index 5478a3f12a3c..4d075051751a 100644
--- a/www/firefox/files/patch-freebsd11
+++ b/www/firefox/files/patch-freebsd11
@@ -7,8 +7,8 @@ media/libcubeb/src/cubeb_oss.c:850:13: warning: comparison of integers of differ
if (nfr > s->bufframes) {
~~~ ^ ~~~~~~~~~~~~
---- media/libcubeb/src/cubeb_oss.c.orig 2020-12-07 23:35:05 UTC
-+++ media/libcubeb/src/cubeb_oss.c
+--- media/libcubeb/src/cubeb_oss.c.orig 2021-08-31 15:32:30.862769000 +0200
++++ media/libcubeb/src/cubeb_oss.c 2021-08-31 15:33:07.421620000 +0200
@@ -10,6 +10,9 @@
* accompanying file LICENSE for details.
*/
@@ -16,6 +16,6 @@ media/libcubeb/src/cubeb_oss.c:850:13: warning: comparison of integers of differ
+#if defined(__FreeBSD__) && __FreeBSD__ < 12
+#define _WITH_GETLINE
+#endif
- #include <assert.h>
- #include <ctype.h>
- #include <limits.h>
+ #include "cubeb-internal.h"
+ #include "cubeb/cubeb.h"
+ #include "cubeb_mixer.h"