aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>2005-12-17 11:36:22 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>2005-12-17 11:36:22 +0000
commit80dbdba7e60c210a0ece8f754eca881c1d3a2d69 (patch)
tree60992742beb4d9c89cdfa8c937889d2f375293eb
parentf8b5b7e6fe9d0c04cd0ce84010b0657a862989b8 (diff)
downloadports-80dbdba7e60c210a0ece8f754eca881c1d3a2d69.tar.gz
ports-80dbdba7e60c210a0ece8f754eca881c1d3a2d69.zip
Upgrade to version 1.1.34
Add a workaround (patch-mg_m_init.c) so that it works on FreeBSD 6 (see PR kern/87208)
Notes
Notes: svn path=/head/; revision=151374
-rw-r--r--comms/mgetty+sendfax/Makefile4
-rw-r--r--comms/mgetty+sendfax/distinfo4
-rw-r--r--comms/mgetty+sendfax/files/patch-mg_m_init.c25
3 files changed, 29 insertions, 4 deletions
diff --git a/comms/mgetty+sendfax/Makefile b/comms/mgetty+sendfax/Makefile
index ab6fe5de524a..a622f14d9b49 100644
--- a/comms/mgetty+sendfax/Makefile
+++ b/comms/mgetty+sendfax/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= mgetty
-PORTVERSION= 1.1.33
+PORTVERSION= 1.1.34
PORTREVISION= 0
CATEGORIES= comms
MASTER_SITES= ftp://alpha.greenie.net/pub/mgetty/source/1.1/
-DISTNAME= ${PORTNAME}${PORTVERSION}-Apr10
+DISTNAME= ${PORTNAME}${PORTVERSION}-Nov30
MAINTAINER= jmz@FreeBSD.org
COMMENT= Handle external logins, send and receive faxes
diff --git a/comms/mgetty+sendfax/distinfo b/comms/mgetty+sendfax/distinfo
index 9d0bddf87c42..38257a993e97 100644
--- a/comms/mgetty+sendfax/distinfo
+++ b/comms/mgetty+sendfax/distinfo
@@ -1,2 +1,2 @@
-MD5 (mgetty1.1.33-Apr10.tar.gz) = d61a2bd343111be35250496710393bd5
-SIZE (mgetty1.1.33-Apr10.tar.gz) = 1024596
+MD5 (mgetty1.1.34-Nov30.tar.gz) = d34f9bf55cadbcf62dc044c9de88a148
+SIZE (mgetty1.1.34-Nov30.tar.gz) = 1027591
diff --git a/comms/mgetty+sendfax/files/patch-mg_m_init.c b/comms/mgetty+sendfax/files/patch-mg_m_init.c
new file mode 100644
index 000000000000..96d390c28241
--- /dev/null
+++ b/comms/mgetty+sendfax/files/patch-mg_m_init.c
@@ -0,0 +1,25 @@
+--- mg_m_init.c.orig Sat Nov 26 17:47:44 2005
++++ mg_m_init.c Sat Dec 17 12:24:51 2005
+@@ -269,7 +269,7 @@
+ if (fd > 0)
+ {
+ (void) close(0);
+- if (dup(fd) != 0)
++ if (dup2(fd,0) != 0)
+ {
+ lprintf( L_FATAL, "mod: cannot make %s stdin", devname );
+ return ERROR;
+@@ -281,11 +281,11 @@
+ (void) close(1);
+ (void) close(2);
+
+- if (dup(0) != 1)
++ if (dup2(0,1) != 1)
+ {
+ lprintf( L_FATAL, "mod: cannot dup to stdout"); return ERROR;
+ }
+- if (dup(0) != 2)
++ if (dup2(0,2) != 2)
+ {
+ lprintf( L_FATAL, "mod: cannot dup to stderr"); return ERROR;
+ }