aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-11 18:41:50 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-11 19:16:22 +0000
commit8111a7a3fc3f0c89e9035e23bd42339a725d1897 (patch)
treea9a71ab3175e1fc426def3b7a0da3134736e4c9b
parent761e1abcc6cc2418af9ee941c2c35d6f51b21760 (diff)
downloadports-8111a7a3fc3f0c89e9035e23bd42339a725d1897.tar.gz
ports-8111a7a3fc3f0c89e9035e23bd42339a725d1897.zip
lang/qscheme: Fix buils with llvm15
- Pet portclippy - Adopt port
-rw-r--r--lang/qscheme/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/lang/qscheme/Makefile b/lang/qscheme/Makefile
index cc6a035e0124..cd91e7fb45fe 100644
--- a/lang/qscheme/Makefile
+++ b/lang/qscheme/Makefile
@@ -4,7 +4,7 @@ PORTREVISION= 10
CATEGORIES= lang scheme
MASTER_SITES= http://www.sof.ch/dan/qscheme/files/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Small and fast Scheme interpreter
WWW= https://www.sof.ch/dan/qscheme/index-e.html
@@ -16,17 +16,26 @@ LIB_DEPENDS= libavcall.so:devel/libffcall \
USES= gmake localbase perl5 shebangfix
USE_PERL5= build
+
SHEBANG_FILES= mkoptable
+
GNU_CONFIGURE= yes
-CFLAGS+= -fPIC
MAKE_ARGS= PCRE_LIB="-L${LOCALBASE}/lib -lpcre"
+CFLAGS+= -fPIC
+
PLIST_SUB= VERSION="${PORTVERSION}"
PORTDOCS= *
OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|-lpthread|-pthread| ; \