aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 14:24:38 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 14:45:29 +0000
commit812ce11abdb11b0e99837911e2cc0c41b3228557 (patch)
treeac55ab27eec1db0139a558e06d3a3a3ec78dc7bf
parentf788ffc0839908f2b4e63a44b148011d4e463d44 (diff)
downloadports-812ce11abdb11b0e99837911e2cc0c41b3228557.tar.gz
ports-812ce11abdb11b0e99837911e2cc0c41b3228557.zip
games/scourge: Fix build with llvm16
- Add LICENSE GPLv2 - Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--games/scourge/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/games/scourge/Makefile b/games/scourge/Makefile
index b5aa965b69e3..ce63d88fd6de 100644
--- a/games/scourge/Makefile
+++ b/games/scourge/Makefile
@@ -1,6 +1,6 @@
PORTNAME= scourge
PORTVERSION= 0.21.1
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= games
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION:S/$/.src/}
@@ -10,27 +10,33 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Rogue-like game
WWW= http://scourge.sourceforge.net/
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libfreetype.so:print/freetype2
RUN_DEPENDS= ${LOCALBASE}/${DATADIR_REL}/config/scourge.cfg:games/scourge-data
USES= autoreconf compiler gettext gl gmake localbase pkgconfig sdl
-GNU_CONFIGURE= yes
+USE_CXXSTD= c++14
USE_GL= gl
USE_SDL= sdl image mixer net ttf
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-data-dir=${DATADIR}
+
CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
CXXFLAGS_clang= -Wno-c++11-narrowing
-CONFIGURE_ARGS= --with-data-dir=${DATADIR}
-
+BINARY_ALIAS= freetype-config=true
SUB_FILES= pkg-message
-PLIST_FILES= bin/${PORTNAME}
+
WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME}
+
OPTIONS_DEFINE= DEBUG
-DEBUG_CONFIGURE_ENABLE= debug
-BINARY_ALIAS= freetype-config=true
+DEBUG_CONFIGURE_ENABLE= debug
post-patch:
@${REINPLACE_CMD} -e 's|GLvoid|void|g' ${WRKSRC}/src/sdlhandler.cpp ${WRKSRC}/src/sdlhandler.h