aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-07-29 09:32:50 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-07-29 09:32:50 +0000
commit81f872958299f92774429dcc83f5c83145a2e9f9 (patch)
tree61283b59170354f498fb5c08cbde6ab7de2a8a64
parent494b925c03d8c48c84c1f553b76183d64bd72e6e (diff)
downloadports-81f872958299f92774429dcc83f5c83145a2e9f9.tar.gz
ports-81f872958299f92774429dcc83f5c83145a2e9f9.zip
Fix build with newer binutils [1].
While here doing some portlint petting. Switch to USES gmake and pathfix. GNOME_DESKTOP_VERSION is ment for bsd.gnome.mk internal only, remove it. Reported by: bapt [1]
Notes
Notes: svn path=/head/; revision=323878
-rw-r--r--sysutils/gnome-system-tools/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/sysutils/gnome-system-tools/Makefile b/sysutils/gnome-system-tools/Makefile
index 3545f69828dc..38950e171824 100644
--- a/sysutils/gnome-system-tools/Makefile
+++ b/sysutils/gnome-system-tools/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gnomesystemtools
-# Date created: 17 May 2004
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
-#
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/sysutils/gnome-system-tools/Makefile,v 1.103 2010/10/25 09:44:29 kwm Exp $
-#
PORTNAME= gnome-system-tools
PORTVERSION= 2.32.0
@@ -16,16 +12,14 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Tools to configure workstations
-LIB_DEPENDS= oobs-1.5:${PORTSDIR}/devel/liboobs \
- polkit-gtk-1.0:${PORTSDIR}/sysutils/polkit-gnome
+LIB_DEPENDS= oobs-1:${PORTSDIR}/devel/liboobs \
+ polkit-gtk-1:${PORTSDIR}/sysutils/polkit-gnome
USE_BZIP2= yes
-USE_GMAKE= yes
INSTALLS_ICONS= yes
-USES= gettext
+USES= gettext gmake pathfix pkgconfig
USE_LDCONFIG= yes
-GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomehack gnomeprefix intlhack nautilus2
+USE_GNOME= gnomeprefix intlhack nautilus2
USE_AUTOTOOLS= libtool
INSTALLS_OMF= yes
CONFIGURE_ARGS= --enable-services
@@ -34,4 +28,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
GLIB_SCHEMAS= org.gnome.system-tools.gschema.xml
+post-patch:
+ @${REINPLACE_CMD} -e 's|gmodule-export-2.0|gmodule-export-2.0 gthread-2.0|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>