aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@mehnert.org>2024-05-18 13:58:52 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2024-05-18 13:58:52 +0000
commit823ece70ac6733aaee83ae2fbfd5829e6e843657 (patch)
treed509837f09159ed4ebfdb7d3a7f8df4441377340
parent0388df5cca4de42c745be13e4133d84bd4b3e1bc (diff)
downloadports-823ece70ac6733aaee83ae2fbfd5829e6e843657.tar.gz
ports-823ece70ac6733aaee83ae2fbfd5829e6e843657.zip
devel/ocaml-opam: Update to 2.1.6
-rw-r--r--devel/ocaml-opam/Makefile10
-rw-r--r--devel/ocaml-opam/distinfo6
-rw-r--r--devel/ocaml-opam/files/patch-src__ext_ocaml-patches_0001-Fix-relocation-ocaml-32-bit.patch17
3 files changed, 10 insertions, 23 deletions
diff --git a/devel/ocaml-opam/Makefile b/devel/ocaml-opam/Makefile
index c304d6169d1e..6ee5fe018b62 100644
--- a/devel/ocaml-opam/Makefile
+++ b/devel/ocaml-opam/Makefile
@@ -1,6 +1,5 @@
PORTNAME= opam
-DISTVERSION= 2.1.5
-PORTREVISION= 3
+DISTVERSION= 2.1.6
CATEGORIES= devel
MASTER_SITES= https://github.com/ocaml/opam/releases/download/${DISTVERSION}/
PKGNAMEPREFIX= ocaml-
@@ -14,14 +13,12 @@ LICENSE= LGPL21
RUN_DEPENDS= curl:ftp/curl \
gpatch:devel/patch \
- gmake:devel/gmake \
- ${RUN_DEPENDS_${ARCH}}
-RUN_DEPENDS_armv6= ${LOCALBASE}/bin/as:devel/binutils
-RUN_DEPENDS_armv7= ${LOCALBASE}/bin/as:devel/binutils
+ gmake:devel/gmake
USES= gmake
ARCH!= uname -p
.if ${ARCH} == armv6 || ${ARCH} == armv7
+RUN_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
USE_BINUTILS= yes
.endif
@@ -35,6 +32,7 @@ ALL_TARGET= cold-lib-ext cold-all
LDFLAGS_armv6= -Wl,-z,notext
LDFLAGS_armv7= -Wl,-z,notext
LDFLAGS_powerpc= -Wl,-z,notext
+LDFLAGS_i386= -Wl,-z,notext
LDFLAGS+= ${LDFLAGS_${ARCH}}
NOPRECIOUSMAKEVARS= yes
diff --git a/devel/ocaml-opam/distinfo b/devel/ocaml-opam/distinfo
index b31e09268ad9..4b15d663b0ad 100644
--- a/devel/ocaml-opam/distinfo
+++ b/devel/ocaml-opam/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1685599850
-SHA256 (opam-full-2.1.5.tar.gz) = 09f8d9e410b2f5723c2bfedbf7970e3b305f5017895fcd91759f05e753ddcea5
-SIZE (opam-full-2.1.5.tar.gz) = 10801367
+TIMESTAMP = 1715883550
+SHA256 (opam-full-2.1.6.tar.gz) = d2af5edc85f552e0cf5ec0ddcc949d94f2dc550dc5df595174a06a4eaf8af628
+SIZE (opam-full-2.1.6.tar.gz) = 11704198
diff --git a/devel/ocaml-opam/files/patch-src__ext_ocaml-patches_0001-Fix-relocation-ocaml-32-bit.patch b/devel/ocaml-opam/files/patch-src__ext_ocaml-patches_0001-Fix-relocation-ocaml-32-bit.patch
index d80febb53acc..23e6f41d0a99 100644
--- a/devel/ocaml-opam/files/patch-src__ext_ocaml-patches_0001-Fix-relocation-ocaml-32-bit.patch
+++ b/devel/ocaml-opam/files/patch-src__ext_ocaml-patches_0001-Fix-relocation-ocaml-32-bit.patch
@@ -1,20 +1,9 @@
--- src_ext/ocaml-patches/0001-Fix-relocation-ocaml-32-bit.patch.orig 2023-05-27 13:17:37 UTC
+++ src_ext/ocaml-patches/0001-Fix-relocation-ocaml-32-bit.patch
-@@ -0,0 +1,43 @@
+@@ -0,0 +1,32 @@
+--- a/configure.orig 2023-05-27 13:13:22 UTC
++++ a/configure
-+@@ -14070,6 +14070,10 @@
-+ case $CC,$host in #(
-+ gcc*,powerpc-*-linux*) :
-+ mksharedlib="$CC -shared -mbss-plt \$(LDFLAGS)" ;; #(
-++ *,i[3456]86-*) :
-++ # Disable DT_TEXTREL warnings on Linux and BSD i386
-++ # See https://github.com/ocaml/ocaml/issues/9800
-++ mksharedlib="$CC -shared \$(LDFLAGS) -Wl,-z,notext" ;; #(
-+ *) :
-+ mksharedlib="$CC -shared \$(LDFLAGS)" ;;
-+ esac
-+@@ -14256,12 +14260,20 @@ case $host in #(
++@@ -14256,12 +14256,20 @@ case $host in #(
+ arch=amd64; system=win64 ;; #(
+ powerpc64le*-*-linux*) :
+ arch=power; model=ppc64le; system=elf ;; #(
@@ -35,7 +24,7 @@
+ s390x*-*-linux*) :
+ arch=s390x; model=z10; system=elf ;; #(
+ # expected to match "gnueabihf" as well as "musleabihf"
-+@@ -14281,6 +14285,8 @@
++@@ -14281,6 +14289,8 @@
+ arch=arm; model=armv6; system=linux_eabi ;; #(
+ armv6*-*-freebsd*) :
+ arch=arm; model=armv6; system=freebsd ;; #(