aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 15:41:29 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 15:41:48 +0000
commit82403f12dfb62e98c15484a884890ff14017af1a (patch)
treecb9fe2068cb996c274ef6dfc4af51f5a13231252
parent414e7619c80751684fbc437f8e4402972243bd8b (diff)
downloadports-82403f12dfb62e98c15484a884890ff14017af1a.tar.gz
ports-82403f12dfb62e98c15484a884890ff14017af1a.zip
irc/scrollz: Fix build with llvm16
- Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--irc/scrollz/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/irc/scrollz/Makefile b/irc/scrollz/Makefile
index 57d7257c0710..ff31780f816d 100644
--- a/irc/scrollz/Makefile
+++ b/irc/scrollz/Makefile
@@ -16,9 +16,11 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
USES= gmake iconv ncurses
USE_GITHUB= yes
+
GNU_CONFIGURE= yes
DATADIR= ${PREFIX}/share/${PORTNAME:tl}
+
PLIST_SUB= SCROLLZ_VER="${PORTVERSION}"
OPTIONS_DEFINE= IPV6 REGEX UTF8
@@ -26,13 +28,13 @@ OPTIONS_DEFAULT= OPENSSL REGEX UTF8
OPTIONS_RADIO= SSL
OPTIONS_RADIO_SSL= GNUTLS OPENSSL
-IPV6_CONFIGURE_ENABLE= ipv6
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_USES= pkgconfig
GNUTLS_CONFIGURE_ON= --with-ssl
-REGEX_CONFIGURE_ENABLE= regexp
+IPV6_CONFIGURE_ENABLE= ipv6
OPENSSL_USES= ssl
OPENSSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE}
+REGEX_CONFIGURE_ENABLE= regexp
UTF8_CONFIGURE_ENABLE= utf8
.include <bsd.port.pre.mk>
@@ -41,6 +43,10 @@ UTF8_CONFIGURE_ENABLE= utf8
CFLAGS+= -Wno-error=int-conversion
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
.if !empty(ICONV_LIB)
CONFIGURE_ENV+=ac_cv_func_iconv_open=yes
.endif