aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-15 10:37:29 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-15 10:37:29 +0000
commit834b9cb4da3b5f38f4e619912679c88f278211ec (patch)
tree6d4bdf286c061775af14f3882b949fd2a2e13efd
parenteb99cd429973782307aa9845e9d15083ffc345ea (diff)
downloadports-834b9cb4da3b5f38f4e619912679c88f278211ec.tar.gz
ports-834b9cb4da3b5f38f4e619912679c88f278211ec.zip
graphics/photoflare: fix build on powerpc
src/workers/filterworkermp.cpp:23:10: fatal error: 'omp.h' file not found
-rw-r--r--graphics/photoflare/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/graphics/photoflare/Makefile b/graphics/photoflare/Makefile
index faec11b36c16..22fc1f4164e2 100644
--- a/graphics/photoflare/Makefile
+++ b/graphics/photoflare/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
LIB_DEPENDS= libGraphicsMagick++.so:graphics/GraphicsMagick
-USES= compiler:c++17-lang desktop-file-utils gl qmake qt:5 localbase pkgconfig
+USES= desktop-file-utils gl qmake qt:5 localbase pkgconfig
USE_GITHUB= yes
USE_QT= core gui network printsupport widgets buildtools_build linguisttools_build
USE_GL= gl
@@ -22,4 +22,12 @@ LDFLAGS+= `pkg-config --libs GraphicsMagick++` ${LDFLAGS_${CHOSEN_COMPILER_TYPE}
LDFLAGS_clang= -lomp
LDFLAGS_gcc= -fopenmp
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++17-lang
+.endif
+
.include <bsd.port.mk>