aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-03-12 12:54:40 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-12-26 16:25:11 +0000
commit835345903638cc1f348e0a81f479a18dadc44b98 (patch)
tree5d1277255a681c42ed2b8f16ae4ca99b049b3ea9
parent7f3b6b6ff1d14d268cfe7beba115643d995ba108 (diff)
downloadports-835345903638cc1f348e0a81f479a18dadc44b98.tar.gz
ports-835345903638cc1f348e0a81f479a18dadc44b98.zip
x11/cliphist: add new port
cliphist is clipboard history "manager" for wayland - write clipboard changes to a history file - recall history with dmenu (for example) - both text and images are supported - clipboard is preserved byte-for-byte - leading / trailing whitespace / no whitespace or newlines are preserved - won’t break fancy editor selections like vim wordwise, linewise, block mode - no concept of a picker, only pipes https://github.com/sentriz/cliphist
-rw-r--r--x11/Makefile1
-rw-r--r--x11/cliphist/Makefile32
-rw-r--r--x11/cliphist/distinfo9
-rw-r--r--x11/cliphist/pkg-descr11
4 files changed, 53 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 7bed8e4f543d..c62452c55323 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -39,6 +39,7 @@
SUBDIR += cinnamon-session
SUBDIR += cl-clx
SUBDIR += cl-clx-sbcl
+ SUBDIR += cliphist
SUBDIR += clipman
SUBDIR += compton-conf
SUBDIR += conlecterm
diff --git a/x11/cliphist/Makefile b/x11/cliphist/Makefile
new file mode 100644
index 000000000000..566ad48cba77
--- /dev/null
+++ b/x11/cliphist/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= cliphist
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.1
+CATEGORIES= x11 wayland
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Wayland clipboard manager
+WWW= https://github.com/sentriz/cliphist
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+USE_GITHUB= yes
+GH_ACCOUNT= sentriz
+GH_TUPLE= etcd-io:bbolt:v1.3.6:etcd_io_bbolt/vendor/go.etcd.io/bbolt \
+ golang:sys:3681064d5158:golang_sys/vendor/golang.org/x/sys \
+ matryer:is:v1.4.0:matryer_is/vendor/github.com/matryer/is
+PLIST_FILES= bin/${PORTNAME}
+
+OPTIONS_DEFINE= FZF
+OPTIONS_DEFAULT=FZF
+
+FZF_DESC= Script with only unique lines and previews
+FZF_RUN_DEPENDS= fzf:textproc/fzf
+FZF_PLIST_FILES= bin/${PORTNAME}-fzf
+
+post-install-FZF-on:
+ @${INSTALL_SCRIPT} ${WRKSRC}/contrib/${FZF_PLIST_FILES:T} \
+ ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/cliphist/distinfo b/x11/cliphist/distinfo
new file mode 100644
index 000000000000..ac2cf9a81134
--- /dev/null
+++ b/x11/cliphist/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1647089680
+SHA256 (sentriz-cliphist-v0.3.1_GH0.tar.gz) = 381b92356e76229c5d15c2d42b3ee63734b7463aacbd200087abd6ed3c30c5ce
+SIZE (sentriz-cliphist-v0.3.1_GH0.tar.gz) = 18757
+SHA256 (etcd-io-bbolt-v1.3.6_GH0.tar.gz) = a2e524f7f32c44fa0765de192ac0789c585010cadd2c2ddcf9518e858a96ec1f
+SIZE (etcd-io-bbolt-v1.3.6_GH0.tar.gz) = 98025
+SHA256 (golang-sys-3681064d5158_GH0.tar.gz) = c084b1b6a081b78986c7364ec483397d6c128aa447ab672aa132fda309bd4db7
+SIZE (golang-sys-3681064d5158_GH0.tar.gz) = 1258557
+SHA256 (matryer-is-v1.4.0_GH0.tar.gz) = 9fdffa00496e767c2585c2fd7dbb018bee65b6f65f95aaeb96966719fbdd3ddc
+SIZE (matryer-is-v1.4.0_GH0.tar.gz) = 89607
diff --git a/x11/cliphist/pkg-descr b/x11/cliphist/pkg-descr
new file mode 100644
index 000000000000..c55beb34ab16
--- /dev/null
+++ b/x11/cliphist/pkg-descr
@@ -0,0 +1,11 @@
+cliphist is clipboard history "manager" for wayland
+
+- write clipboard changes to a history file
+- recall history with dmenu (for example)
+- both text and images are supported
+- clipboard is preserved byte-for-byte
+ - leading / trailing whitespace / no whitespace or newlines are
+ preserved
+ - won’t break fancy editor selections like vim wordwise, linewise,
+ block mode
+- no concept of a picker, only pipes