aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 17:35:03 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 18:26:13 +0000
commit83a63a66b6daaa39954b194f9acf18faacee2142 (patch)
treec9230cc77139756cbb31f6d11a49abca4d253ff1
parent8cd4394245dbc74a6bab678798c5d6e2ec053921 (diff)
downloadports-83a63a66b6daaa39954b194f9acf18faacee2142.tar.gz
ports-83a63a66b6daaa39954b194f9acf18faacee2142.zip
graphics/ampasCTL: Fix build with llvm16
Sponsored by: The FreeBSD Foundation
-rw-r--r--graphics/ampasCTL/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/graphics/ampasCTL/Makefile b/graphics/ampasCTL/Makefile
index 6899054e8b00..58ec697fdba0 100644
--- a/graphics/ampasCTL/Makefile
+++ b/graphics/ampasCTL/Makefile
@@ -17,20 +17,20 @@ LIB_DEPENDS= libImath.so:math/Imath \
libtiff.so:graphics/tiff \
libAcesContainer.so:graphics/ampasACES-container
-USES= compiler:c++11-lang cmake pathfix pkgconfig
-USE_LDCONFIG= yes
+USES= cmake compiler:c++11-lang localbase:ldflags pathfix pkgconfig
+USE_CXXSTD= c++11
USE_GITHUB= yes
-
GH_ACCOUNT= ampas
GH_PROJECT= CTL
GH_TAGNAME= 57b48a2
+USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include/OpenEXR -I${LOCALBASE}/include/Imath
-LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= *
OPTIONS_DEFINE= DOCS
-PORTDOCS= *
DOCSRCDIR1= ${WRKSRC}
DOC_FILES1= AUTHORS CHANGELOG README.md
DOCSRCDIR2= ${WRKSRC}/doc