aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 14:59:38 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 15:53:03 +0000
commit83aaa5d8aaa761df50a5904cd9084d6b99b34ed6 (patch)
treee9696d290527e25c86b83e93a29cb60a616bc239
parent10a048804600b194ba3eff825a34a024ed2a085d (diff)
downloadports-83aaa5d8aaa761df50a5904cd9084d6b99b34ed6.tar.gz
ports-83aaa5d8aaa761df50a5904cd9084d6b99b34ed6.zip
x11-wm/blackbox: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--x11-wm/blackbox/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/x11-wm/blackbox/Makefile b/x11-wm/blackbox/Makefile
index 9f2480d7e1f1..c4097601a3f0 100644
--- a/x11-wm/blackbox/Makefile
+++ b/x11-wm/blackbox/Makefile
@@ -12,24 +12,27 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= pathfix pkgconfig iconv xorg
+USE_CXXSTD= c++14
USE_XORG= x11 xft
GNU_CONFIGURE= yes
+
LDFLAGS+= ${ICONV_LIB}
PORTDOCS= README.bbtools README.bsetbg
-MANPAGES= bsetbg.1 bsetroot.1
OPTIONS_DEFINE= TOOLS_ONLY DOCS
TOOLS_ONLY_DESC= Do not install window manager, only tools
-TOOLS_ONLY_INSTALL_TARGET= -C util install # XXX dirty hack :(
TOOLS_ONLY_MAKE_ARGS= SUBDIRS="doc lib util" bin_PROGRAMS=bsetroot
+TOOLS_ONLY_INSTALL_TARGET= -C util install # XXX dirty hack :(
TOOLS_ONLY_VARS= PKGNAMESUFFIX=-tools \
COMMENT+="(tools only)"
TOOLS_ONLY_VARS_OFF= PORTDOCS+="AUTHORS COMPLIANCE ChangeLog README RELNOTES TODO"
+MANPAGES= bsetbg.1 bsetroot.1
+
.include <bsd.port.options.mk>
.if ${ARCH} == armv6 || ${ARCH} == armv7 || ${ARCH} == powerpc