aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-03 23:04:44 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-03 23:04:44 +0000
commit83f7357c87ae604238f596915905c471a4241942 (patch)
tree660688730262580a2276d19b9a90eb58f70a3f3f
parent9aaccaed7d0e000844966e72551a5375ac718636 (diff)
downloadports-83f7357c87ae604238f596915905c471a4241942.tar.gz
ports-83f7357c87ae604238f596915905c471a4241942.zip
Remove support for OSVERSION < 5
Notes
Notes: svn path=/head/; revision=200757
-rw-r--r--ftp/ftp-tls/Makefile8
-rw-r--r--ftp/ftpd-tls/Makefile4
-rw-r--r--ftp/ncftpd/Makefile4
-rw-r--r--games/netris/Makefile11
-rw-r--r--games/xtris/Makefile6
-rw-r--r--irc/irssi/Makefile4
-rw-r--r--irc/netwalker-ircc/Makefile8
7 files changed, 6 insertions, 39 deletions
diff --git a/ftp/ftp-tls/Makefile b/ftp/ftp-tls/Makefile
index 4240a4c30c5a..591996e77021 100644
--- a/ftp/ftp-tls/Makefile
+++ b/ftp/ftp-tls/Makefile
@@ -23,12 +23,6 @@ MAN1= ftp-tls.1
CONFIGURE_ARGS= --with-openssl-dir=${OPENSSLBASE}
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400000
-BROKEN= Not supported on systems prior to FreeBSD 4.0 (missing getaddrinfo())
-.endif
-
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/ftp ${PREFIX}/bin/ftp-tls
@${INSTALL_MAN} ${WRKSRC}/ftp.1.TLS ${PREFIX}/man/man1/ftp-tls.1
@@ -39,4 +33,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/ftp/ftpd-tls/Makefile b/ftp/ftpd-tls/Makefile
index 1651d40fbf89..068597e9eacf 100644
--- a/ftp/ftpd-tls/Makefile
+++ b/ftp/ftpd-tls/Makefile
@@ -27,10 +27,6 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 400000
-BROKEN= "Not supported on systems prior to FreeBSD 4.0 (missing getaddrinfo())"
-.endif
-
post-patch:
.for i in README.TLS ftpd.8.TLS pathnames.h tlsutil.c
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/${i}
diff --git a/ftp/ncftpd/Makefile b/ftp/ncftpd/Makefile
index cf2a2e6468a5..484f5b0ccda7 100644
--- a/ftp/ncftpd/Makefile
+++ b/ftp/ncftpd/Makefile
@@ -28,10 +28,8 @@ RESTRICTED= 30 day evaluation license
.if ${OSVERSION} >= 600000
BINVER= 6.0
-.elif ${OSVERSION} >= 500000
+.else
BINVER= 5.4
-.elif ${OSVERSION} >= 491000
-BINVER= 4.11
.else
BROKEN= FreeBSD version too old
.endif
diff --git a/games/netris/Makefile b/games/netris/Makefile
index 65fddfe69ef0..16f0eeb2ba14 100644
--- a/games/netris/Makefile
+++ b/games/netris/Makefile
@@ -20,17 +20,10 @@ COMMENT= A network head to head version of T*tris
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS= --cc '${CC}' --copt '${CFLAGS}'
-MAN1= netris.1
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
-.else
-CONFIGURE_ARGS+= --disable-ipv6
-.endif
+MAN1= netris.1
post-install:
${INSTALL_MAN} ${FILESDIR}/netris.1 ${PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/xtris/Makefile b/games/xtris/Makefile
index 1db8e665af0c..d463a805bb26 100644
--- a/games/xtris/Makefile
+++ b/games/xtris/Makefile
@@ -24,10 +24,6 @@ WRKSRC= ${WRKDIR}/xtris
USE_X_PREFIX= yes
MAN6= xtris.6 xtserv.6 xtbot.6
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 400014
MAKE_ENV= IPV6_CFLAGS="-DINET6"
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index 34c8721069cc..bba1a8437a27 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -63,12 +63,8 @@ CONFIGURE_ARGS+= --with-socks
.endif
.if defined(WITH_IPV6)
-.if ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
CATEGORIES+= ipv6
-.else
-BROKEN= This version of FreeBSD does not support IPv6. Please use WITH_IPV6=no
-.endif
.endif
.if defined(WITH_BOT)
diff --git a/irc/netwalker-ircc/Makefile b/irc/netwalker-ircc/Makefile
index 88b2026a378d..2777c55f3fdb 100644
--- a/irc/netwalker-ircc/Makefile
+++ b/irc/netwalker-ircc/Makefile
@@ -20,12 +20,6 @@ MAN1= netwalker.1
LDFLAGS= -lncurses ${PTHREAD_LIBS}
CFLAGS?= -O2 -Wall
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400010
-LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
-.endif
-
post-patch:
@${SED} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/config.h > ${WRKSRC}/config.h.freebsd
@@ -43,4 +37,4 @@ do-install:
@${MKDIR} ${DATADIR}
${CP} ${WRKSRC}/help/* ${PREFIX}/share/netwalker-ircc
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>