aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-04 22:17:11 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-04 22:17:11 +0000
commit849ee6c94fe3272b7f7db3232a30f6801ef8bfec (patch)
tree35f426fe810706739865778e4d89e485ae175a34
parentd7964bc2699613e5b855a60b33978c6926fed4ac (diff)
downloadports-849ee6c94fe3272b7f7db3232a30f6801ef8bfec.tar.gz
ports-849ee6c94fe3272b7f7db3232a30f6801ef8bfec.zip
Remove NOPORTDOCS and NOPORTEXAMPLES.
Notes
Notes: svn path=/head/; revision=360671
-rw-r--r--security/autossh/Makefile6
-rw-r--r--security/clamtk/Makefile4
-rw-r--r--security/fwbuilder/Makefile8
-rw-r--r--security/lasso/Makefile5
-rw-r--r--security/mindterm-binary/Makefile12
-rw-r--r--security/mussh/Makefile6
-rw-r--r--security/opensaml2/Makefile6
-rw-r--r--security/outguess/Makefile4
-rw-r--r--security/p5-Filter-CBC/Makefile4
-rw-r--r--security/pam_pwdfile/Makefile4
-rw-r--r--security/py-gnutls/Makefile4
-rw-r--r--security/skipfish/Makefile10
-rw-r--r--security/sqlninja/Makefile4
-rw-r--r--security/webscarab/Makefile4
14 files changed, 41 insertions, 40 deletions
diff --git a/security/autossh/Makefile b/security/autossh/Makefile
index f0db40abaa87..0968963b0864 100644
--- a/security/autossh/Makefile
+++ b/security/autossh/Makefile
@@ -14,11 +14,15 @@ GNU_CONFIGURE= yes
PORTDOCS= CHANGES README
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's,cp autossh.1 ,$$\{BSD_INSTALL_MAN\} autossh.1 ,g' ${WRKSRC}/${MAKEFILE}.in
@${REINPLACE_CMD} -e 's,cp autossh ,$$\{BSD_INSTALL_PROGRAM\} autossh ,g' ${WRKSRC}/${MAKEFILE}.in
@${REINPLACE_CMD} -e 's,cp ,$$\{BSD_INSTALL_DATA\} ,g' ${WRKSRC}/${MAKEFILE}.in
-.if defined(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
@${REINPLACE_CMD} -Ee '/doc/d' ${WRKSRC}/${MAKEFILE}.in
.endif
diff --git a/security/clamtk/Makefile b/security/clamtk/Makefile
index 9743b5d4e79f..2acc4175bd41 100644
--- a/security/clamtk/Makefile
+++ b/security/clamtk/Makefile
@@ -30,6 +30,8 @@ MAN1= ${PORTNAME}.1
LINGUAS= `${LS} ${WRKSRC}/po/*.mo | ${XARGS} ${BASENAME} -s .mo`
+OPTIONS_DEFINE= DOCS
+
post-extract:
@${GUNZIP_CMD} ${WRKSRC}/${PORTNAME}.1.gz
@@ -53,11 +55,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/po/$${l}.mo \
${STAGEDIR}${PREFIX}/share/locale/$${l}/LC_MESSAGES/${PORTNAME}.mo; \
done
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in CHANGES DISCLAIMER README
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/security/fwbuilder/Makefile b/security/fwbuilder/Makefile
index 9f4ec097c518..d648ec2f7d5b 100644
--- a/security/fwbuilder/Makefile
+++ b/security/fwbuilder/Makefile
@@ -20,6 +20,8 @@ DISTVERSIONSUFFIX= .${BUILD}
MAINTAINER= cy@FreeBSD.org
COMMENT= Firewall Builder GUI and policy compilers
+#OPTIONS_DEFINE= DOCS
+
.if defined(PKGNAMESUFFIX) && ${PKGNAMESUFFIX} == -devel
CONFLICTS= fwbuilder-[234].* fwbuilder-devel-[234].* \
libfwbuilder-[234].* libfwbuilder-devel-[234].*
@@ -60,9 +62,7 @@ MAKE_ENV= INSTALL_ROOT=${STAGEDIR}
USE_LDCONFIG= yes
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
-.if !defined(NOPORTDOCS)
PORTDOCS= *
-.endif
.include <bsd.port.pre.mk>
@@ -81,7 +81,7 @@ post-install:
@${ECHO} please make sure to backup your fwbuilder database files
@${ECHO} prior to invoking fwbuilder for the first time.
-.if defined(NOPORTDOCS)
-BROKEN= NOPORTDOCS is incomplete in this port
+.if empty(PORT_OPTIONS:MDOCS)
+BROKEN= DOCS must be enabled in this port
.endif
.include <bsd.port.post.mk>
diff --git a/security/lasso/Makefile b/security/lasso/Makefile
index 99f09bb38055..7f6ecae66f4b 100644
--- a/security/lasso/Makefile
+++ b/security/lasso/Makefile
@@ -23,7 +23,7 @@ USE_LDCONFIG= yes
USE_OPENSSL= yes
USE_PYTHON_BUILD= yes
-OPTIONS_DEFINE= PERL PHP PYTHON
+OPTIONS_DEFINE= PERL PHP PYTHON DOCS
.include <bsd.port.options.mk>
@@ -60,8 +60,5 @@ PLIST_SUB+= WITH_PYTHON="@comment "
post-install:
${RM} -f ${STAGEDIR}${PREFIX}/lib/perl5/${PERL_VER}/${PERL_ARCH}/perllocal.pod
-.ifdef(NOPORTDOCS)
- ${RM} -rf ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/security/mindterm-binary/Makefile b/security/mindterm-binary/Makefile
index 7bef0f5d6a41..726194fb1e72 100644
--- a/security/mindterm-binary/Makefile
+++ b/security/mindterm-binary/Makefile
@@ -19,18 +19,18 @@ NO_WRKSUBDIR= yes
NO_BUILD= yes
NO_CDROM= Do not sell for profit
+OPTIONS_DEFINE= DOCS
+
post-extract:
- @${CP} ${DISTDIR}/mindterm-ssh.html ${WRKSRC}
- @${MV} ${WRKSRC}/mindtermfull.jar ${WRKSRC}/mindterm.jar
+ ${CP} ${DISTDIR}/mindterm-ssh.html ${WRKSRC}
+ ${MV} ${WRKSRC}/mindtermfull.jar ${WRKSRC}/mindterm.jar
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/java/mindterm
- @${INSTALL_DATA} ${WRKSRC}/mindterm.jar ${STAGEDIR}${PREFIX}/share/java/mindterm/
-.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/mindterm.jar ${STAGEDIR}${PREFIX}/share/java/mindterm/
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for DOC in CHANGES FAQ FEATURES PLATFORMS TODO mindterm-ssh.html
- @${INSTALL_DATA} ${WRKSRC}/${DOC} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${DOC} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/security/mussh/Makefile b/security/mussh/Makefile
index bdbcaecc79d5..69f7ff36ad27 100644
--- a/security/mussh/Makefile
+++ b/security/mussh/Makefile
@@ -17,19 +17,19 @@ PORTDOCS= BUGS CHANGES EXAMPLES README
PLIST_FILES= bin/mussh
WRKSRC= ${WRKDIR}/${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
post-patch:
- @${REINPLACE_CMD} -e "s,^#!/bin/bash,#!/usr/bin/env bash,g" \
+ ${REINPLACE_CMD} -e "s,^#!/bin/bash,#!/usr/bin/env bash,g" \
-e "s,seq 1 ,jot 1 ,g" \
${WRKSRC}/${PORTNAME}
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/security/opensaml2/Makefile b/security/opensaml2/Makefile
index 682b0798a2cc..e06f6a108fb1 100644
--- a/security/opensaml2/Makefile
+++ b/security/opensaml2/Makefile
@@ -24,13 +24,17 @@ CONFIGURE_ARGS+=--with-log4shib=${LOCALBASE} --with-openssl=${OPENSSLBASE} \
USES= gmake pkgconfig
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's,^pkgdocdir.*=.*,pkgdocdir = ${DOCSDIR},' \
${WRKSRC}/doc/Makefile.in
@${REINPLACE_CMD} -e 's|echo aout|echo elf|g' \
${WRKSRC}/configure
-.if defined(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
@${REINPLACE_CMD} -e '/^SUBDIRS/s,doc ,,' ${WRKSRC}/Makefile.in
.endif
diff --git a/security/outguess/Makefile b/security/outguess/Makefile
index 5c12dd42194c..4a58d22aa5a4 100644
--- a/security/outguess/Makefile
+++ b/security/outguess/Makefile
@@ -20,15 +20,15 @@ GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/outguess
PORTDOCS= ChangeLog README STIRMARK-README TODO
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/outguess ${STAGEDIR}${PREFIX}/bin
${LN} -sf outguess ${STAGEDIR}${PREFIX}/bin/extract
${INSTALL_MAN} ${WRKSRC}/outguess.1 ${STAGEDIR}${PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/security/p5-Filter-CBC/Makefile b/security/p5-Filter-CBC/Makefile
index f39c34e7fc89..2aa16ad444c2 100644
--- a/security/p5-Filter-CBC/Makefile
+++ b/security/p5-Filter-CBC/Makefile
@@ -19,11 +19,11 @@ PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
USES= perl5
USE_PERL5= configure
+OPTIONS_DEFINE= EXAMPLES
+
post-install:
-.ifndef(NOPORTEXAMPLES)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
-.endif
.include <bsd.port.mk>
diff --git a/security/pam_pwdfile/Makefile b/security/pam_pwdfile/Makefile
index 70f15184e3e1..3e4164627238 100644
--- a/security/pam_pwdfile/Makefile
+++ b/security/pam_pwdfile/Makefile
@@ -16,16 +16,16 @@ PLIST_FILES= lib/pam_pwdfile.so
PORTDOCS= README INSTALL changelog
CFLAGS+= -I${WRKSRC}
+OPTIONS_DEFINE= DOCS
+
post-patch:
${REINPLACE_CMD} -e 's|#include <features.h>||g' ${WRKSRC}/pam_pwdfile.c
${CP} ${FILESDIR}/_pam_macros.h ${WRKSRC}
post-install:
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for docs in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${docs} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/security/py-gnutls/Makefile b/security/py-gnutls/Makefile
index 7b6854545b2e..517930f220e1 100644
--- a/security/py-gnutls/Makefile
+++ b/security/py-gnutls/Makefile
@@ -19,15 +19,15 @@ PYDISTUTILS_PKGNAME= python_gnutls
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+OPTIONS_DEFINE= EXAMPLES
+
post-patch:
${REINPLACE_CMD} -e "s|include_dirs=.*|include_dirs=\['${LOCALBASE}/include'\],|" ${WRKSRC}/setup.py
${REINPLACE_CMD} -e "s|library_dirs=.*|library_dirs=\['${LOCALBASE}/lib'\],|" ${WRKSRC}/setup.py
${REINPLACE_CMD} -e "s|\.26||g" ${WRKSRC}/gnutls/library/functions.py
-.if !defined(NOPORTEXAMPLES)
post-install:
@${MKDIR} ${STAGEDIR}/${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/ ${STAGEDIR}/${EXAMPLESDIR}
-.endif
.include <bsd.port.mk>
diff --git a/security/skipfish/Makefile b/security/skipfish/Makefile
index d1b720a7929e..50ecca213084 100644
--- a/security/skipfish/Makefile
+++ b/security/skipfish/Makefile
@@ -20,11 +20,9 @@ LIB_DEPENDS= idn:${PORTSDIR}/dns/libidn \
USES= gmake
SUB_FILES= pkg-message
-.if !defined(NOPORTDOCS)
-PORTDOCS= README COPYING ChangeLog
-.endif
+OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
+PORTDOCS= README COPYING ChangeLog
post-patch:
@${REINPLACE_CMD} -e 's:"skipfish.wl":"${DATADIR}/dictionaries/complete.wl":' \
@@ -36,11 +34,9 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/doc/skipfish.1 ${STAGEDIR}${PREFIX}/man/man1
(cd ${WRKSRC}/assets/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/assets/)
(cd ${WRKSRC}/dictionaries/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/dictionaries/)
-.if !defined(NOPORTDOCS)
${MKDIR} ${STAGEDIR}${DOCSDIR}
. for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
. endfor
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/sqlninja/Makefile b/security/sqlninja/Makefile
index b1f846392ecd..e7ee1e94dea5 100644
--- a/security/sqlninja/Makefile
+++ b/security/sqlninja/Makefile
@@ -21,6 +21,8 @@ RUN_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
USES= perl5
NO_BUILD= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${ETCDIR}
${MKDIR} ${STAGEDIR}${ETCDIR}/scripts
@@ -34,11 +36,9 @@ do-install:
. for i in churrasco.exe dnstun.exe nc.exe
${INSTALL_SCRIPT} ${WRKSRC}/apps/${i} ${STAGEDIR}${ETCDIR}/apps
. endfor
-.if !defined(NOPORTDOCS)
${MKDIR} ${STAGEDIR}${DOCSDIR}
. for i in sqlninja-howto.html sqlninja.conf.example
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
. endfor
-.endif
.include <bsd.port.mk>
diff --git a/security/webscarab/Makefile b/security/webscarab/Makefile
index 83be7712865b..ad4d325c8e70 100644
--- a/security/webscarab/Makefile
+++ b/security/webscarab/Makefile
@@ -20,6 +20,8 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
PORTDOCS= README LICENSE ChangeLog
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
post-extract:
@@ -37,11 +39,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jar ${STAGEDIR}${DATADIR}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}_lite
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
. for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
. endfor
-.endif
.include <bsd.port.post.mk>