aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Hummel <david.hummel@gmail.com>2023-04-28 03:38:37 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-04-30 18:41:42 +0000
commit84c697c41d13d0bc8d1fe1cf9d6f81410c77630f (patch)
treec92e6785aabb6d5bfd0649b415465184765d0318
parentc2133565c4fc8e45495fd60a1077496a4c39208f (diff)
downloadports-84c697c41d13d0bc8d1fe1cf9d6f81410c77630f.tar.gz
ports-84c697c41d13d0bc8d1fe1cf9d6f81410c77630f.zip
graphics/mapnik: Revert Mapnik removal & update to 3.1.0
Mapnik is a Free Toolkit for developing mapping applications. It's written in C++ and there are Python bindings to facilitate fast-paced agile development. It can comfortably be used for both desktop and web development, which was something wanted from the beginning. Mapnik is about making beautiful maps. It uses the AGG library and offers world class anti-aliasing rendering with subpixel accuracy for geographic data. It is written from scratch in modern C++ and doesn't suffer from design decisions made a decade ago. When it comes to handling common software tasks such as memory management, filesystem access, regular expressions, parsing and so on, Mapnik doesn't re-invent the wheel, but utilizes best of breed industry standard libraries from boost.org. Changelog: https://github.com/mapnik/mapnik/blob/v3.1.0/CHANGELOG.md WWW: http://www.mapnik.org/ PR: 241805 Pull Request: https://github.com/freebsd/freebsd-ports/pull/157
-rw-r--r--MOVED1
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/mapnik/Makefile123
-rw-r--r--graphics/mapnik/distinfo9
-rw-r--r--graphics/mapnik/pkg-descr13
-rw-r--r--graphics/mapnik/pkg-plist482
6 files changed, 628 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index d518e2d7f04c..3c7fdde21014 100644
--- a/MOVED
+++ b/MOVED
@@ -12839,7 +12839,6 @@ devel/p5-rpm-build-perl||2020-01-10|Has expired: Broken for more than 7 months
devel/shedskin||2020-01-10|Has expired: Broken for more than 3 months, unmaintained
games/stonesoup-sdl||2020-01-10|Has expired: Broken for more than 8 months
games/xtris||2020-01-10|Has expired: Broken for more than 3 months
-graphics/mapnik||2020-01-10|Has expired: Broken for more than 8 months
lang/js_of_ocaml||2020-01-10|Has expired: Depends on broken and expiring devel/ocaml-deriving-ocsigen
lang/rubinius||2020-01-10|Has expired: Broken for more than 7 months
sysutils/hfm||2020-01-10|Has expired: Broken for more than 4 months
diff --git a/graphics/Makefile b/graphics/Makefile
index fc8d900b1195..35749c612821 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -554,6 +554,7 @@
SUBDIR += maim
SUBDIR += mandelbulber
SUBDIR += mapcache
+ SUBDIR += mapnik
SUBDIR += mapserver
SUBDIR += mapyrus
SUBDIR += matplotlib-cpp
diff --git a/graphics/mapnik/Makefile b/graphics/mapnik/Makefile
new file mode 100644
index 000000000000..afc9598738ce
--- /dev/null
+++ b/graphics/mapnik/Makefile
@@ -0,0 +1,123 @@
+PORTNAME= mapnik
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.1.0
+CATEGORIES= graphics geography
+MASTER_SITES= https://github.com/mapnik/mapnik/releases/download/${DISTVERSIONFULL}/
+
+PATCH_SITES= https://github.com/mapnik/mapnik/commit/
+PATCHFILES= 8944e81367d2b3b91a41e24116e1813c01491e5d.patch \
+ 83779b7b6bdd229740b1b5e12a4a8fe27114cb7d.patch \
+ 7f0daee8b37d8cf6eff32529b1762ffd5104f3f3.patch
+PATCH_DIST_STRIP= -p1 -F3
+
+MAINTAINER= david.hummel@gmail.com
+COMMENT= Free Toolkit For Developing Mapping Applications
+WWW= http://www.mapnik.org/
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu
+LIB_DEPENDS= libboost_system.so:devel/boost-libs \
+ libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz \
+ libicuuc.so:devel/icu
+RUN_DEPENDS= dejavu>0:x11-fonts/dejavu
+
+USES= compiler:c++14-lang gmake gnome pkgconfig python tar:bzip2
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+MAKE_ARGS= PYTHON="${PYTHON_CMD}"
+MAKE_ENV= JOBS=${MAKE_JOBS_NUMBER}
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= CPP_TESTS=False \
+ CUSTOM_CFLAGS="${CFLAGS}" \
+ CUSTOM_CXXFLAGS="${CXXFLAGS}" \
+ CUSTOM_LDFLAGS="${LDFLAGS}" \
+ DEMO=False \
+ DESTDIR="${STAGEDIR}" \
+ FAST=True \
+ INPUT_PLUGINS="`${ECHO} ${INPUT_PLUGINS} | ${TR} ' ' ,`" \
+ SVG2PNG=True \
+ SYSTEM_FONTS=${LOCALBASE}/share/fonts/dejavu \
+ XMLPARSER=libxml2
+CONFIGURE_ENV= PYTHON="${PYTHON_CMD}"
+
+PORTDOCS= AUTHORS.md CHANGELOG.md CODE_OF_CONDUCT.md INSTALL.md README.md docs/*
+
+INPUT_PLUGINS= csv raster shape geojson topojson
+
+OPTIONS_DEFINE= CAIRO DOCS JPEG PNG PROJ TIFF WEBP
+OPTIONS_DEFAULT= CAIRO GDAL JPEG OGR PGRASTER PNG POSTGIS PROJ SQLITE3 \
+ TIFF WEBP
+OPTIONS_GROUP= INPUT
+OPTIONS_GROUP_INPUT= GDAL OGR PGRASTER POSTGIS SQLITE3
+OPTIONS_SUB= yes
+
+INPUT_DESC= Input plugins
+GDAL_DESC= GDAL input plugin
+OGR_DESC= OGR input plugin
+POSTGIS_DESC= PostGIS input plugin
+PGRASTER_DESC= PGraster input plugin
+SQLITE3_DESC= SQLite input plugin
+
+PROJ_DESC= PROJ support
+
+CAIRO_DESC= Enable cairo rendering
+
+GDAL_VARS= INPUT_PLUGINS+=gdal
+GDAL_LIB_DEPENDS= libgdal.so:graphics/gdal
+OGR_VARS= INPUT_PLUGINS+=ogr
+OGR_LIB_DEPENDS= libgdal.so:graphics/gdal
+POSTGIS_VARS= INPUT_PLUGINS+=postgis
+POSTGIS_USES= pgsql
+PGRASTER_VARS= INPUT_PLUGINS+=pgraster
+PGRASTER_USES= pgsql
+SQLITE3_VARS= INPUT_PLUGINS+=sqlite
+SQLITE3_LIB_DEPENDS= libsqlite3.so:databases/sqlite3
+
+PNG_LIB_DEPENDS= libpng.so:graphics/png
+PNG_MAKE_ARGS_OFF= PNG=False
+JPEG_USES= jpeg
+JPEG_MAKE_ARGS_OFF= JPEG=False
+TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
+TIFF_MAKE_ARGS_OFF= TIFF=False
+WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
+WEBP_MAKE_ARGS_OFF= WEBP=False
+PROJ_LIB_DEPENDS= libproj.so:graphics/proj
+PROJ_MAKE_ARGS_OFF= PROJ=False
+
+CAIRO_LIB_DEPENDS= libcairo.so:graphics/cairo
+CAIRO_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>=1.8.2:graphics/py-cairo@${PY_FLAVOR}
+CAIRO_MAKE_ARGS_OFF= CAIRO=False
+
+pre-configure-SQLITE3-on:
+ @if ! ${LOCALBASE}/bin/sqlite3 :memory: 'create virtual table foo using rtree(pkid, xmin, xmax, ymin, ymax)' > /dev/null 2>&1; then \
+ ${ECHO_MSG} "" ; \
+ ${ECHO_MSG} "The SQLite plugin requires libsqlite3 built with RTREE support"; \
+ ${ECHO_MSG} "Please, reinstall 'databases/sqlite3' port with R*Tree module enabled"; \
+ ${ECHO_MSG} "" ; \
+ ${FALSE} ; \
+ fi
+
+post-patch:
+ @${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' \
+ -e 's#/usr/include#${LOCALBASE}/include#g' \
+ -e "s#'/usr/' + LIBDIR_SCHEMA_DEFAULT#'${LOCALBASE}/' + LIBDIR_SCHEMA_DEFAULT#g" \
+ ${WRKSRC}/SConstruct
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mapnik-index \
+ ${STAGEDIR}${PREFIX}/bin/mapnik-render \
+ ${STAGEDIR}${PREFIX}/bin/shapeindex \
+ ${STAGEDIR}${PREFIX}/bin/svg2png
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/mapnik/input/*.input
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS.md CHANGELOG.md CODE_OF_CONDUCT.md INSTALL.md README.md ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/docs
+ @cd ${WRKSRC} && ${INSTALL_DATA} docs/* ${STAGEDIR}${DOCSDIR}/docs
+
+.include <bsd.port.mk>
diff --git a/graphics/mapnik/distinfo b/graphics/mapnik/distinfo
new file mode 100644
index 000000000000..df164881b392
--- /dev/null
+++ b/graphics/mapnik/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1677423842
+SHA256 (mapnik-v3.1.0.tar.bz2) = 43d76182d2a975212b4ad11524c74e577576c11039fdab5286b828397d8e6261
+SIZE (mapnik-v3.1.0.tar.bz2) = 10110740
+SHA256 (8944e81367d2b3b91a41e24116e1813c01491e5d.patch) = a8c98fed2e0c72c2b48bf1ea81fe17dd79878429d82f32243ddcf61a5b4e4541
+SIZE (8944e81367d2b3b91a41e24116e1813c01491e5d.patch) = 89836
+SHA256 (83779b7b6bdd229740b1b5e12a4a8fe27114cb7d.patch) = c80ca2cded88dfebff4efc92febb847fef1c8e3ade4795852ecf04a4b82724af
+SIZE (83779b7b6bdd229740b1b5e12a4a8fe27114cb7d.patch) = 698
+SHA256 (7f0daee8b37d8cf6eff32529b1762ffd5104f3f3.patch) = 2bb3ab61ed128fd5ae48e8e0943d8d0ae37b070418c21774ba987a4973f21800
+SIZE (7f0daee8b37d8cf6eff32529b1762ffd5104f3f3.patch) = 1071
diff --git a/graphics/mapnik/pkg-descr b/graphics/mapnik/pkg-descr
new file mode 100644
index 000000000000..c135e17339d5
--- /dev/null
+++ b/graphics/mapnik/pkg-descr
@@ -0,0 +1,13 @@
+Mapnik is a Free Toolkit for developing mapping applications. It's
+written in C++ and there are Python bindings to facilitate fast-paced
+agile development. It can comfortably be used for both desktop and web
+development, which was something wanted from the beginning.
+
+Mapnik is about making beautiful maps. It uses the AGG library and
+offers world class anti-aliasing rendering with subpixel accuracy for
+geographic data. It is written from scratch in modern C++ and doesn't
+suffer from design decisions made a decade ago. When it comes to
+handling common software tasks such as memory management, filesystem
+access, regular expressions, parsing and so on, Mapnik doesn't re-invent
+the wheel, but utilizes best of breed industry standard libraries from
+boost.org.
diff --git a/graphics/mapnik/pkg-plist b/graphics/mapnik/pkg-plist
new file mode 100644
index 000000000000..ad33d31d5aad
--- /dev/null
+++ b/graphics/mapnik/pkg-plist
@@ -0,0 +1,482 @@
+bin/mapnik-config
+bin/mapnik-index
+bin/mapnik-render
+bin/shapeindex
+bin/svg2png
+include/mapnik/agg/agg_alpha_mask_u8.h
+include/mapnik/agg/agg_arc.h
+include/mapnik/agg/agg_array.h
+include/mapnik/agg/agg_arrowhead.h
+include/mapnik/agg/agg_basics.h
+include/mapnik/agg/agg_bezier_arc.h
+include/mapnik/agg/agg_bitset_iterator.h
+include/mapnik/agg/agg_blur.h
+include/mapnik/agg/agg_bounding_rect.h
+include/mapnik/agg/agg_bspline.h
+include/mapnik/agg/agg_clip_liang_barsky.h
+include/mapnik/agg/agg_color_gray.h
+include/mapnik/agg/agg_color_rgba.h
+include/mapnik/agg/agg_config.h
+include/mapnik/agg/agg_conv_adaptor_vcgen.h
+include/mapnik/agg/agg_conv_adaptor_vpgen.h
+include/mapnik/agg/agg_conv_bspline.h
+include/mapnik/agg/agg_conv_clip_polygon.h
+include/mapnik/agg/agg_conv_clip_polyline.h
+include/mapnik/agg/agg_conv_close_polygon.h
+include/mapnik/agg/agg_conv_concat.h
+include/mapnik/agg/agg_conv_contour.h
+include/mapnik/agg/agg_conv_curve.h
+include/mapnik/agg/agg_conv_dash.h
+include/mapnik/agg/agg_conv_gpc.h
+include/mapnik/agg/agg_conv_marker.h
+include/mapnik/agg/agg_conv_marker_adaptor.h
+include/mapnik/agg/agg_conv_offset.h
+include/mapnik/agg/agg_conv_segmentator.h
+include/mapnik/agg/agg_conv_shorten_path.h
+include/mapnik/agg/agg_conv_smooth_poly1.h
+include/mapnik/agg/agg_conv_stroke.h
+include/mapnik/agg/agg_conv_transform.h
+include/mapnik/agg/agg_conv_unclose_polygon.h
+include/mapnik/agg/agg_curves.h
+include/mapnik/agg/agg_dda_line.h
+include/mapnik/agg/agg_ellipse.h
+include/mapnik/agg/agg_ellipse_bresenham.h
+include/mapnik/agg/agg_embedded_raster_fonts.h
+include/mapnik/agg/agg_font_cache_manager.h
+include/mapnik/agg/agg_gamma_functions.h
+include/mapnik/agg/agg_gamma_lut.h
+include/mapnik/agg/agg_glyph_raster_bin.h
+include/mapnik/agg/agg_gradient_lut.h
+include/mapnik/agg/agg_gsv_text.h
+include/mapnik/agg/agg_image_accessors.h
+include/mapnik/agg/agg_image_filters.h
+include/mapnik/agg/agg_line_aa_basics.h
+include/mapnik/agg/agg_math.h
+include/mapnik/agg/agg_math_stroke.h
+include/mapnik/agg/agg_path_length.h
+include/mapnik/agg/agg_path_storage.h
+include/mapnik/agg/agg_path_storage_integer.h
+include/mapnik/agg/agg_pattern_filters_rgba.h
+include/mapnik/agg/agg_pixfmt_amask_adaptor.h
+include/mapnik/agg/agg_pixfmt_base.h
+include/mapnik/agg/agg_pixfmt_gray.h
+include/mapnik/agg/agg_pixfmt_rgb.h
+include/mapnik/agg/agg_pixfmt_rgb_packed.h
+include/mapnik/agg/agg_pixfmt_rgba.h
+include/mapnik/agg/agg_pixfmt_transposer.h
+include/mapnik/agg/agg_rasterizer_cells_aa.h
+include/mapnik/agg/agg_rasterizer_compound_aa.h
+include/mapnik/agg/agg_rasterizer_outline.h
+include/mapnik/agg/agg_rasterizer_outline_aa.h
+include/mapnik/agg/agg_rasterizer_scanline_aa.h
+include/mapnik/agg/agg_rasterizer_sl_clip.h
+include/mapnik/agg/agg_renderer_base.h
+include/mapnik/agg/agg_renderer_markers.h
+include/mapnik/agg/agg_renderer_mclip.h
+include/mapnik/agg/agg_renderer_outline_aa.h
+include/mapnik/agg/agg_renderer_outline_image.h
+include/mapnik/agg/agg_renderer_primitives.h
+include/mapnik/agg/agg_renderer_raster_text.h
+include/mapnik/agg/agg_renderer_scanline.h
+include/mapnik/agg/agg_rendering_buffer.h
+include/mapnik/agg/agg_rendering_buffer_dynarow.h
+include/mapnik/agg/agg_rounded_rect.h
+include/mapnik/agg/agg_scanline_bin.h
+include/mapnik/agg/agg_scanline_boolean_algebra.h
+include/mapnik/agg/agg_scanline_p.h
+include/mapnik/agg/agg_scanline_storage_aa.h
+include/mapnik/agg/agg_scanline_storage_bin.h
+include/mapnik/agg/agg_scanline_u.h
+include/mapnik/agg/agg_shorten_path.h
+include/mapnik/agg/agg_simul_eq.h
+include/mapnik/agg/agg_span_allocator.h
+include/mapnik/agg/agg_span_converter.h
+include/mapnik/agg/agg_span_gouraud.h
+include/mapnik/agg/agg_span_gouraud_gray.h
+include/mapnik/agg/agg_span_gouraud_rgba.h
+include/mapnik/agg/agg_span_gradient.h
+include/mapnik/agg/agg_span_gradient_alpha.h
+include/mapnik/agg/agg_span_image_filter.h
+include/mapnik/agg/agg_span_image_filter_gray.h
+include/mapnik/agg/agg_span_image_filter_rgb.h
+include/mapnik/agg/agg_span_image_filter_rgba.h
+include/mapnik/agg/agg_span_interpolator_adaptor.h
+include/mapnik/agg/agg_span_interpolator_linear.h
+include/mapnik/agg/agg_span_interpolator_persp.h
+include/mapnik/agg/agg_span_interpolator_trans.h
+include/mapnik/agg/agg_span_pattern_gray.h
+include/mapnik/agg/agg_span_pattern_rgb.h
+include/mapnik/agg/agg_span_pattern_rgba.h
+include/mapnik/agg/agg_span_solid.h
+include/mapnik/agg/agg_span_subdiv_adaptor.h
+include/mapnik/agg/agg_trans_affine.h
+include/mapnik/agg/agg_trans_bilinear.h
+include/mapnik/agg/agg_trans_double_path.h
+include/mapnik/agg/agg_trans_lens.h
+include/mapnik/agg/agg_trans_perspective.h
+include/mapnik/agg/agg_trans_single_path.h
+include/mapnik/agg/agg_trans_viewport.h
+include/mapnik/agg/agg_trans_warp_magnifier.h
+include/mapnik/agg/agg_vcgen_bspline.h
+include/mapnik/agg/agg_vcgen_contour.h
+include/mapnik/agg/agg_vcgen_dash.h
+include/mapnik/agg/agg_vcgen_markers_term.h
+include/mapnik/agg/agg_vcgen_smooth_poly1.h
+include/mapnik/agg/agg_vcgen_stroke.h
+include/mapnik/agg/agg_vcgen_vertex_sequence.h
+include/mapnik/agg/agg_vertex_sequence.h
+include/mapnik/agg/agg_vpgen_clip_polygon.h
+include/mapnik/agg/agg_vpgen_clip_polyline.h
+include/mapnik/agg/agg_vpgen_segmentator.h
+include/mapnik/agg_helpers.hpp
+include/mapnik/agg_pattern_source.hpp
+include/mapnik/agg_rasterizer.hpp
+include/mapnik/agg_render_marker.hpp
+include/mapnik/agg_renderer.hpp
+include/mapnik/attribute.hpp
+include/mapnik/attribute_collector.hpp
+include/mapnik/attribute_descriptor.hpp
+include/mapnik/boolean.hpp
+include/mapnik/box2d.hpp
+include/mapnik/box2d_impl.hpp
+include/mapnik/cairo/cairo_context.hpp
+include/mapnik/cairo/cairo_image_util.hpp
+include/mapnik/cairo/cairo_render_vector.hpp
+include/mapnik/cairo/cairo_renderer.hpp
+include/mapnik/cairo/render_polygon_pattern.hpp
+include/mapnik/cairo_io.hpp
+include/mapnik/color.hpp
+include/mapnik/color_factory.hpp
+include/mapnik/config.hpp
+include/mapnik/config_error.hpp
+include/mapnik/coord.hpp
+include/mapnik/css_color_grammar.hpp
+include/mapnik/css_color_grammar_impl.hpp
+include/mapnik/csv/csv_grammar.hpp
+include/mapnik/csv/csv_grammar_impl.hpp
+include/mapnik/csv/csv_types.hpp
+include/mapnik/cxx11_support.hpp
+include/mapnik/datasource.hpp
+include/mapnik/datasource_cache.hpp
+include/mapnik/datasource_geometry_type.hpp
+include/mapnik/debug.hpp
+include/mapnik/ellipsoid.hpp
+include/mapnik/enumeration.hpp
+include/mapnik/evaluate_global_attributes.hpp
+include/mapnik/expression.hpp
+include/mapnik/expression_evaluator.hpp
+include/mapnik/expression_grammar.hpp
+include/mapnik/expression_grammar_impl.hpp
+include/mapnik/expression_node.hpp
+include/mapnik/expression_node_types.hpp
+include/mapnik/expression_string.hpp
+include/mapnik/factory.hpp
+include/mapnik/feature.hpp
+include/mapnik/feature_factory.hpp
+include/mapnik/feature_kv_iterator.hpp
+include/mapnik/feature_layer_desc.hpp
+include/mapnik/feature_style_processor.hpp
+include/mapnik/feature_style_processor_context.hpp
+include/mapnik/feature_style_processor_impl.hpp
+include/mapnik/feature_type_style.hpp
+include/mapnik/featureset.hpp
+include/mapnik/filter_factory.hpp
+include/mapnik/filter_featureset.hpp
+include/mapnik/font_engine_freetype.hpp
+include/mapnik/font_set.hpp
+include/mapnik/function_call.hpp
+include/mapnik/geom_util.hpp
+include/mapnik/geometry.hpp
+include/mapnik/geometry_adapters.hpp
+include/mapnik/geometry_centroid.hpp
+include/mapnik/geometry_correct.hpp
+include/mapnik/geometry_envelope.hpp
+include/mapnik/geometry_envelope_impl.hpp
+include/mapnik/geometry_fusion_adapted.hpp
+include/mapnik/geometry_is_empty.hpp
+include/mapnik/geometry_is_simple.hpp
+include/mapnik/geometry_is_valid.hpp
+include/mapnik/geometry_remove_empty.hpp
+include/mapnik/geometry_reprojection.hpp
+include/mapnik/geometry_reprojection_impl.hpp
+include/mapnik/geometry_strategy.hpp
+include/mapnik/geometry_to_path.hpp
+include/mapnik/geometry_transform.hpp
+include/mapnik/geometry_type.hpp
+include/mapnik/geometry_types.hpp
+include/mapnik/global.hpp
+include/mapnik/gradient.hpp
+include/mapnik/grid/grid.hpp
+include/mapnik/grid/grid_pixel.hpp
+include/mapnik/grid/grid_pixfmt.hpp
+include/mapnik/grid/grid_rasterizer.hpp
+include/mapnik/grid/grid_render_marker.hpp
+include/mapnik/grid/grid_renderer.hpp
+include/mapnik/grid/grid_renderer_base.hpp
+include/mapnik/grid/grid_rendering_buffer.hpp
+include/mapnik/grid/grid_view.hpp
+include/mapnik/grid_vertex_converter.hpp
+include/mapnik/group/group_layout.hpp
+include/mapnik/group/group_layout_manager.hpp
+include/mapnik/group/group_rule.hpp
+include/mapnik/group/group_symbolizer_helper.hpp
+include/mapnik/group/group_symbolizer_properties.hpp
+include/mapnik/hextree.hpp
+include/mapnik/hit_test_filter.hpp
+include/mapnik/image.hpp
+include/mapnik/image_any.hpp
+include/mapnik/image_compositing.hpp
+include/mapnik/image_copy.hpp
+include/mapnik/image_filter.hpp
+include/mapnik/image_filter_grammar.hpp
+include/mapnik/image_filter_grammar_impl.hpp
+include/mapnik/image_filter_types.hpp
+include/mapnik/image_impl.hpp
+include/mapnik/image_null.hpp
+include/mapnik/image_options.hpp
+include/mapnik/image_reader.hpp
+include/mapnik/image_scaling.hpp
+include/mapnik/image_scaling_traits.hpp
+include/mapnik/image_util.hpp
+include/mapnik/image_util_jpeg.hpp
+include/mapnik/image_util_png.hpp
+include/mapnik/image_util_tiff.hpp
+include/mapnik/image_util_webp.hpp
+include/mapnik/image_view.hpp
+include/mapnik/image_view_any.hpp
+include/mapnik/image_view_impl.hpp
+include/mapnik/image_view_null.hpp
+include/mapnik/jpeg_io.hpp
+include/mapnik/json/attribute_value_visitor.hpp
+include/mapnik/json/error_handler.hpp
+include/mapnik/json/extract_bounding_box_grammar.hpp
+include/mapnik/json/extract_bounding_box_grammar_impl.hpp
+include/mapnik/json/feature_collection_grammar.hpp
+include/mapnik/json/feature_collection_grammar_impl.hpp
+include/mapnik/json/feature_generator.hpp
+include/mapnik/json/feature_generator_grammar.hpp
+include/mapnik/json/feature_generator_grammar_impl.hpp
+include/mapnik/json/feature_grammar.hpp
+include/mapnik/json/feature_grammar_impl.hpp
+include/mapnik/json/feature_parser.hpp
+include/mapnik/json/generic_json.hpp
+include/mapnik/json/geometry_generator_grammar.hpp
+include/mapnik/json/geometry_generator_grammar_impl.hpp
+include/mapnik/json/geometry_grammar.hpp
+include/mapnik/json/geometry_grammar_impl.hpp
+include/mapnik/json/geometry_parser.hpp
+include/mapnik/json/geometry_util.hpp
+include/mapnik/json/positions.hpp
+include/mapnik/json/positions_grammar.hpp
+include/mapnik/json/positions_grammar_impl.hpp
+include/mapnik/json/properties_generator_grammar.hpp
+include/mapnik/json/properties_generator_grammar_impl.hpp
+include/mapnik/json/stringifier.hpp
+include/mapnik/json/topojson_grammar.hpp
+include/mapnik/json/topojson_grammar_impl.hpp
+include/mapnik/json/topojson_utils.hpp
+include/mapnik/json/topology.hpp
+include/mapnik/json/value_converters.hpp
+include/mapnik/label_collision_detector.hpp
+include/mapnik/layer.hpp
+include/mapnik/load_map.hpp
+include/mapnik/make_unique.hpp
+include/mapnik/map.hpp
+include/mapnik/mapbox/optional.hpp
+include/mapnik/mapbox/recursive_wrapper.hpp
+include/mapnik/mapbox/variant.hpp
+include/mapnik/mapbox/variant_io.hpp
+include/mapnik/mapbox/variant_visitor.hpp
+include/mapnik/mapped_memory_cache.hpp
+include/mapnik/marker.hpp
+include/mapnik/marker_cache.hpp
+include/mapnik/marker_helpers.hpp
+include/mapnik/markers_placement.hpp
+include/mapnik/markers_placements/basic.hpp
+include/mapnik/markers_placements/interior.hpp
+include/mapnik/markers_placements/line.hpp
+include/mapnik/markers_placements/point.hpp
+include/mapnik/markers_placements/vertext_first.hpp
+include/mapnik/markers_placements/vertext_last.hpp
+include/mapnik/memory_datasource.hpp
+include/mapnik/memory_featureset.hpp
+include/mapnik/octree.hpp
+include/mapnik/offset_converter.hpp
+include/mapnik/palette.hpp
+include/mapnik/params.hpp
+include/mapnik/params_impl.hpp
+include/mapnik/parse_path.hpp
+include/mapnik/parse_transform.hpp
+include/mapnik/path.hpp
+include/mapnik/path_expression.hpp
+include/mapnik/path_expression_grammar.hpp
+include/mapnik/path_expression_grammar_impl.hpp
+include/mapnik/pixel_position.hpp
+include/mapnik/pixel_types.hpp
+include/mapnik/plugin.hpp
+include/mapnik/png_io.hpp
+include/mapnik/pool.hpp
+include/mapnik/proj_strategy.hpp
+include/mapnik/proj_transform.hpp
+include/mapnik/projection.hpp
+include/mapnik/ptree_helpers.hpp
+include/mapnik/quad_tree.hpp
+include/mapnik/query.hpp
+include/mapnik/raster.hpp
+include/mapnik/raster_colorizer.hpp
+include/mapnik/renderer_common.hpp
+include/mapnik/request.hpp
+include/mapnik/rule.hpp
+include/mapnik/rule_cache.hpp
+include/mapnik/safe_cast.hpp
+include/mapnik/save_map.hpp
+include/mapnik/scale_denominator.hpp
+include/mapnik/segment.hpp
+include/mapnik/simplify.hpp
+include/mapnik/simplify_converter.hpp
+include/mapnik/span_image_filter.hpp
+include/mapnik/sparsehash/dense_hash_map
+include/mapnik/sparsehash/internal/densehashtable.h
+include/mapnik/sparsehash/internal/hashtable-common.h
+include/mapnik/sparsehash/internal/libc_allocator_with_realloc.h
+include/mapnik/sparsehash/internal/sparseconfig.h
+include/mapnik/sparsehash/template_util.h
+include/mapnik/sparsehash/type_traits.h
+include/mapnik/sql_utils.hpp
+include/mapnik/sse.hpp
+include/mapnik/stringify_macro.hpp
+include/mapnik/svg/geometry_svg_generator.hpp
+include/mapnik/svg/geometry_svg_generator_impl.hpp
+include/mapnik/svg/svg_converter.hpp
+include/mapnik/svg/svg_parser.hpp
+include/mapnik/svg/svg_parser_exception.hpp
+include/mapnik/svg/svg_path_adapter.hpp
+include/mapnik/svg/svg_path_attributes.hpp
+include/mapnik/svg/svg_path_commands.hpp
+include/mapnik/svg/svg_path_grammar.hpp
+include/mapnik/svg/svg_path_grammar_impl.hpp
+include/mapnik/svg/svg_path_parser.hpp
+include/mapnik/svg/svg_points_grammar.hpp
+include/mapnik/svg/svg_points_grammar_impl.hpp
+include/mapnik/svg/svg_renderer_agg.hpp
+include/mapnik/svg/svg_storage.hpp
+include/mapnik/svg/svg_transform_grammar.hpp
+include/mapnik/svg/svg_transform_grammar_impl.hpp
+include/mapnik/symbolizer.hpp
+include/mapnik/symbolizer_base.hpp
+include/mapnik/symbolizer_default_values.hpp
+include/mapnik/symbolizer_dispatch.hpp
+include/mapnik/symbolizer_enumerations.hpp
+include/mapnik/symbolizer_hash.hpp
+include/mapnik/symbolizer_keys.hpp
+include/mapnik/symbolizer_utils.hpp
+include/mapnik/text/evaluated_format_properties_ptr.hpp
+include/mapnik/text/face.hpp
+include/mapnik/text/font_feature_settings.hpp
+include/mapnik/text/font_library.hpp
+include/mapnik/text/formatting/base.hpp
+include/mapnik/text/formatting/format.hpp
+include/mapnik/text/formatting/layout.hpp
+include/mapnik/text/formatting/list.hpp
+include/mapnik/text/formatting/registry.hpp
+include/mapnik/text/formatting/text.hpp
+include/mapnik/text/glyph_info.hpp
+include/mapnik/text/glyph_positions.hpp
+include/mapnik/text/harfbuzz_shaper.hpp
+include/mapnik/text/icu_shaper.hpp
+include/mapnik/text/itemizer.hpp
+include/mapnik/text/placement_finder.hpp
+include/mapnik/text/placement_finder_impl.hpp
+include/mapnik/text/placements/base.hpp
+include/mapnik/text/placements/dummy.hpp
+include/mapnik/text/placements/list.hpp
+include/mapnik/text/placements/registry.hpp
+include/mapnik/text/placements/simple.hpp
+include/mapnik/text/properties_util.hpp
+include/mapnik/text/renderer.hpp
+include/mapnik/text/rotation.hpp
+include/mapnik/text/scrptrun.hpp
+include/mapnik/text/symbolizer_helpers.hpp
+include/mapnik/text/text_layout.hpp
+include/mapnik/text/text_line.hpp
+include/mapnik/text/text_properties.hpp
+include/mapnik/tiff_io.hpp
+include/mapnik/timer.hpp
+include/mapnik/tolerance_iterator.hpp
+include/mapnik/transform_expression.hpp
+include/mapnik/transform_expression_grammar.hpp
+include/mapnik/transform_expression_grammar_impl.hpp
+include/mapnik/transform_path_adapter.hpp
+include/mapnik/transform_processor.hpp
+include/mapnik/unicode.hpp
+include/mapnik/util/char_array_buffer.hpp
+include/mapnik/util/const_rendering_buffer.hpp
+include/mapnik/util/container_adapter.hpp
+include/mapnik/util/conversions.hpp
+include/mapnik/util/dasharray_parser.hpp
+include/mapnik/util/feature_to_geojson.hpp
+include/mapnik/util/featureset_buffer.hpp
+include/mapnik/util/file_io.hpp
+include/mapnik/util/fs.hpp
+include/mapnik/util/geometry_to_ds_type.hpp
+include/mapnik/util/geometry_to_geojson.hpp
+include/mapnik/util/geometry_to_svg.hpp
+include/mapnik/util/geometry_to_wkb.hpp
+include/mapnik/util/geometry_to_wkt.hpp
+include/mapnik/util/hsl.hpp
+include/mapnik/util/is_clockwise.hpp
+include/mapnik/util/math.hpp
+include/mapnik/util/name_to_int.hpp
+include/mapnik/util/noncopyable.hpp
+include/mapnik/util/path_iterator.hpp
+include/mapnik/util/rounding_cast.hpp
+include/mapnik/util/singleton.hpp
+include/mapnik/util/spatial_index.hpp
+include/mapnik/util/timer.hpp
+include/mapnik/util/trim.hpp
+include/mapnik/util/utf_conv_win.hpp
+include/mapnik/util/variant.hpp
+include/mapnik/util/variant_io.hpp
+include/mapnik/value.hpp
+include/mapnik/value_error.hpp
+include/mapnik/value_hash.hpp
+include/mapnik/value_types.hpp
+include/mapnik/version.hpp
+include/mapnik/vertex.hpp
+include/mapnik/vertex_adapters.hpp
+include/mapnik/vertex_cache.hpp
+include/mapnik/vertex_converters.hpp
+include/mapnik/vertex_processor.hpp
+include/mapnik/vertex_vector.hpp
+include/mapnik/view_strategy.hpp
+include/mapnik/view_transform.hpp
+include/mapnik/warning_ignore.hpp
+include/mapnik/warning_ignore_agg.hpp
+include/mapnik/warp.hpp
+include/mapnik/webp_io.hpp
+include/mapnik/well_known_srs.hpp
+include/mapnik/wkb.hpp
+include/mapnik/wkt/wkt_factory.hpp
+include/mapnik/wkt/wkt_generator_grammar.hpp
+include/mapnik/wkt/wkt_generator_grammar_impl.hpp
+include/mapnik/wkt/wkt_grammar.hpp
+include/mapnik/wkt/wkt_grammar_impl.hpp
+include/mapnik/xml_attribute_cast.hpp
+include/mapnik/xml_loader.hpp
+include/mapnik/xml_node.hpp
+include/mapnik/xml_tree.hpp
+lib/libmapnik-json.a
+lib/libmapnik-wkt.a
+lib/libmapnik.so
+lib/libmapnik.so.3.1
+lib/libmapnik.so.3.1.0
+lib/mapnik/input/csv.input
+lib/mapnik/input/gdal.input
+lib/mapnik/input/geojson.input
+lib/mapnik/input/ogr.input
+lib/mapnik/input/pgraster.input
+lib/mapnik/input/postgis.input
+lib/mapnik/input/raster.input
+lib/mapnik/input/shape.input
+lib/mapnik/input/sqlite.input
+lib/mapnik/input/topojson.input