aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-03-22 02:08:44 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-03-22 03:37:16 +0000
commit84ef7bd8cf5068bd91a9b5ee9576d5df67de7af2 (patch)
tree0fa4be3d7b0f2770315468a6ef0b5c191f2a05a9
parent7dc1f58689cbeda8d93235fd5288af6acfb8a15c (diff)
downloadports-84ef7bd8cf5068bd91a9b5ee9576d5df67de7af2.tar.gz
ports-84ef7bd8cf5068bd91a9b5ee9576d5df67de7af2.zip
lang/mujs: Update 1.3.2 → 1.3.3
Reported by: portscout
-rw-r--r--lang/mujs/Makefile14
-rw-r--r--lang/mujs/distinfo6
-rw-r--r--lang/mujs/files/patch-Makefile32
3 files changed, 20 insertions, 32 deletions
diff --git a/lang/mujs/Makefile b/lang/mujs/Makefile
index 7d01a552d23f..df024e4ab89b 100644
--- a/lang/mujs/Makefile
+++ b/lang/mujs/Makefile
@@ -1,5 +1,5 @@
PORTNAME= mujs
-DISTVERSION= 1.3.2
+DISTVERSION= 1.3.3
CATEGORIES= lang devel
MAINTAINER= yuri@FreeBSD.org
@@ -18,8 +18,9 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= ccxvii
-ALL_TARGET= shared static
-
+ALL_TARGET= build/release/mujs \
+ build/release/libmujs.so \
+ build/release/libmujs.a
INSTALL_TARGET= install-shared install-static
.if defined(WITH_DEBUG) # this project manages its build options itself
@@ -27,6 +28,7 @@ MAKE_ARGS= build=debug
.endif
PLIST_FILES= bin/mujs \
+ bin/mujs-pp \
include/mujs.h \
lib/libmujs.so \
lib/libmujs.a \
@@ -41,6 +43,12 @@ OPTIONS_DEFAULT= 32BIT
SANITIZED_DESC= Sanitized build (only for debugging)
SANITIZED_MAKE_ARGS= build=sanitize
+post-install:
+ @${STRIP_CMD} \
+ ${STAGEDIR}${PREFIX}/bin/mujs \
+ ${STAGEDIR}${PREFIX}/bin/mujs-pp \
+ ${STAGEDIR}${PREFIX}/lib/libmujs.so
+
do-test: # Test-262 JavaScript testsuite is downloaded and run.
# Something is off with the test harness so too many tests fail: https://github.com/ccxvii/mujs/issues/147
${RM} -r ${WRKDIR}/testing && \
diff --git a/lang/mujs/distinfo b/lang/mujs/distinfo
index 820297f92ee4..1e89b59a1c55 100644
--- a/lang/mujs/distinfo
+++ b/lang/mujs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1667896146
-SHA256 (ccxvii-mujs-1.3.2_GH0.tar.gz) = 59763cc32776714b4f00a0efede83f4f56b381c9dbaced4756d665c214249dca
-SIZE (ccxvii-mujs-1.3.2_GH0.tar.gz) = 127899
+TIMESTAMP = 1679443995
+SHA256 (ccxvii-mujs-1.3.3_GH0.tar.gz) = e2c5ee5416dfda2230c7a0cb7895df9a9b2d5b2065bb18e7e64dec2a796abe1b
+SIZE (ccxvii-mujs-1.3.3_GH0.tar.gz) = 128097
diff --git a/lang/mujs/files/patch-Makefile b/lang/mujs/files/patch-Makefile
index d0e471837710..4a93632fa784 100644
--- a/lang/mujs/files/patch-Makefile
+++ b/lang/mujs/files/patch-Makefile
@@ -2,35 +2,15 @@ Patch contains 2 changes:
- enable readline on FreeBSD (upstream never accepted this PR)
- use -O3 on FreeBSD
---- Makefile.orig 2021-04-13 02:22:04 UTC
+--- Makefile.orig 2023-01-10 11:11:11 UTC
+++ Makefile
-@@ -17,7 +17,8 @@ endif
+@@ -4,7 +4,8 @@
- # Compiler flags for various configurations:
+ default: build/debug/mujs build/debug/mujs-pp
--CFLAGS := -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
+-CFLAGS = -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
+# change to c11 on FreeBSD because FreeBSD headers induce c11 through isnan(3), etc.
-+CFLAGS := -std=c11 -pedantic -Wall -Wextra -Wno-unused-parameter
++CFLAGS = -std=c11 -pedantic -Wall -Wextra -Wno-unused-parameter
- ifeq "$(CC)" "clang"
- CFLAGS += -Wunreachable-code
-@@ -27,13 +28,18 @@ ifeq "$(shell uname)" "Linux"
- HAVE_READLINE := yes
- endif
-
-+ifeq "$(shell uname)" "FreeBSD"
-+ HAVE_READLINE := yes
-+ CFLAGS += -I$(prefix)/include
-+endif
-+
- ifeq "$(build)" "debug"
- CFLAGS += -g
- else ifeq "$(build)" "sanitize"
- CFLAGS += -pipe -g -fsanitize=address -fno-omit-frame-pointer
- LDFLAGS += -fsanitize=address
- else ifeq "$(build)" "release"
-- CFLAGS += -O2
-+ CFLAGS += -O3
- LDFLAGS += -Wl,-s
- endif
+ OPTIM = -O3