aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBoudhayan Gupta <bgupta@kde.org>2022-10-09 20:09:15 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2022-10-09 20:14:52 +0000
commit851f5d0cf80aa7cd6f35ea46bdb408d76a45f9bd (patch)
tree1de20e0925f30743ae9a445aa61a222e73383d61
parenta93915c619dd91dd771dde3b7526cb44d93a3b7c (diff)
downloadports-851f5d0cf80aa7cd6f35ea46bdb408d76a45f9bd.tar.gz
ports-851f5d0cf80aa7cd6f35ea46bdb408d76a45f9bd.zip
security/py-certbot-dns-gandi: new port, certbot plugin
This plugin comes from https://github.com/obynio/certbot-plugin-gandi . Port file from Boudhayan, slightly modified for line length and portlint. PR: 266860
-rw-r--r--security/Makefile1
-rw-r--r--security/py-certbot-dns-gandi/Makefile30
-rw-r--r--security/py-certbot-dns-gandi/distinfo3
-rw-r--r--security/py-certbot-dns-gandi/pkg-descr1
4 files changed, 35 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 1fb61f99161f..8fecb015e301 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -845,6 +845,7 @@
SUBDIR += py-certbot-dns-digitalocean
SUBDIR += py-certbot-dns-dnsimple
SUBDIR += py-certbot-dns-dnsmadeeasy
+ SUBDIR += py-certbot-dns-gandi
SUBDIR += py-certbot-dns-gehirn
SUBDIR += py-certbot-dns-google
SUBDIR += py-certbot-dns-linode
diff --git a/security/py-certbot-dns-gandi/Makefile b/security/py-certbot-dns-gandi/Makefile
new file mode 100644
index 000000000000..f03b0833ce46
--- /dev/null
+++ b/security/py-certbot-dns-gandi/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= certbot-plugin-gandi
+PORTVERSION= 1.4.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= bgupta@kde.org
+COMMENT= Gandi LiveDNS plugin for Certbot
+WWW= https://github.com/obynio/certbot-plugin-gandi
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION},1:security/py-acme@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION},1:security/py-certbot@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+# Use GitHub to fetch the source, because PyPI apparently only contains
+# a wheel and not the source package.
+USE_GITHUB= yes
+GH_ACCOUNT= obynio
+
+NO_ARCH= yes
+
+.include "${.CURDIR}/../py-acme/version.mk"
+.include <bsd.port.mk>
diff --git a/security/py-certbot-dns-gandi/distinfo b/security/py-certbot-dns-gandi/distinfo
new file mode 100644
index 000000000000..546aab836c73
--- /dev/null
+++ b/security/py-certbot-dns-gandi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1664998616
+SHA256 (obynio-certbot-plugin-gandi-1.4.0_GH0.tar.gz) = c486e0f7788f3ac4cce9fe54666018dab65ab1550016727a99426c3359d64e55
+SIZE (obynio-certbot-plugin-gandi-1.4.0_GH0.tar.gz) = 6115
diff --git a/security/py-certbot-dns-gandi/pkg-descr b/security/py-certbot-dns-gandi/pkg-descr
new file mode 100644
index 000000000000..c9935af3705b
--- /dev/null
+++ b/security/py-certbot-dns-gandi/pkg-descr
@@ -0,0 +1 @@
+This is a Gandi LiveDNS Authenticator plugin for Certbot (security/py-certbot).