aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-04-03 16:06:10 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-04-03 16:06:10 +0000
commit8565528d224cee9177c25c8146efe9145ae49be0 (patch)
tree62cadd7e4e7941027062a2dafd01539db28f1d2a
parentb804b4aef7b410dd4236da20d2f9699f20771a40 (diff)
downloadports-8565528d224cee9177c25c8146efe9145ae49be0.tar.gz
ports-8565528d224cee9177c25c8146efe9145ae49be0.zip
Adding IML - Integer Matrix Library.
To be used by SageMath.
Notes
Notes: svn path=/head/; revision=530503
-rw-r--r--math/Makefile1
-rw-r--r--math/iml/Makefile24
-rw-r--r--math/iml/distinfo3
-rw-r--r--math/iml/pkg-descr20
-rw-r--r--math/iml/pkg-plist7
5 files changed, 55 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 9349a52d4411..eecdedf61173 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -317,6 +317,7 @@
SUBDIR += ideep
SUBDIR += ignition-math
SUBDIR += igraph
+ SUBDIR += iml
SUBDIR += intervaltree
SUBDIR += ipopt
SUBDIR += ised
diff --git a/math/iml/Makefile b/math/iml/Makefile
new file mode 100644
index 000000000000..b52d2dd7afb1
--- /dev/null
+++ b/math/iml/Makefile
@@ -0,0 +1,24 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= iml
+PORTVERSION= 1.0.5
+CATEGORIES= math
+MASTER_SITES= http://www.cs.uwaterloo.ca/~astorjoh/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Integer Matrix Library
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libgmp.so:math/gmp
+
+USES= blaslapack:openblas libtool localbase tar:bz2
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-cblas=${LAPACKLIB} --enable-shared
+USE_LDCONFIG= yes
+
+TEST_TARGET= check
+
+.include <bsd.port.mk>
diff --git a/math/iml/distinfo b/math/iml/distinfo
new file mode 100644
index 000000000000..1319e26a25c1
--- /dev/null
+++ b/math/iml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585924558
+SHA256 (iml-1.0.5.tar.bz2) = 1dad666850895a5709b00b97422e2273f293cfadea7697a9f90b90953e847c2a
+SIZE (iml-1.0.5.tar.bz2) = 391757
diff --git a/math/iml/pkg-descr b/math/iml/pkg-descr
new file mode 100644
index 000000000000..0e297a4cda91
--- /dev/null
+++ b/math/iml/pkg-descr
@@ -0,0 +1,20 @@
+IML is a free library of C source code which implements algorithms for computing
+exact solutions to dense systems of linear equations over the integers.
+
+Currently, IML provides the following functionalities:
+
+ - Nonsingular rational system solving: compute the unique rational solution X
+ to the system AX=B, where A and B are integer matrices, A nonsingular.
+ - Compute the right nullspace or kernel of an integer matrix.
+ - Certified linear system solving: compute a minimal denominator solution x to
+ a system Ax=b, where b is an integer vector and A is an integer matrix with
+ arbitrary shape and rank profile.
+
+In addition, IML provides some low level routines for a variety of mod p matrix
+operations: computing the row-echelon form, determinant, rank profile, and
+inverse of a mod p matrix. These mod p routines are not general purpose; they
+require that p satisfy some preconditions based on the dimension of the input
+matrix (usually p should be prime and should be no more than about 20 bits
+long).
+
+WWW: https://cs.uwaterloo.ca/~astorjoh/iml.html
diff --git a/math/iml/pkg-plist b/math/iml/pkg-plist
new file mode 100644
index 000000000000..2783024d77d9
--- /dev/null
+++ b/math/iml/pkg-plist
@@ -0,0 +1,7 @@
+include/iml.h
+lib/libiml.a
+lib/libiml.so
+lib/libiml.so.0
+lib/libiml.so.0.1.1
+%%DATADIR%%/liblink
+%%DATADIR%%/libroutines