aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-09-22 06:39:45 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-09-22 06:39:45 +0000
commit85682a8a79eb8e8f03f5518a4fc3a3ae8fdc3268 (patch)
tree8bffe932568336a838611bebdbda54cf13f53608
parentaae058b01652864758ee6e457a7e32dedce9ac29 (diff)
downloadports-85682a8a79eb8e8f03f5518a4fc3a3ae8fdc3268.tar.gz
ports-85682a8a79eb8e8f03f5518a4fc3a3ae8fdc3268.zip
Allow staging as a regular user
Notes
Notes: svn path=/head/; revision=368811
-rw-r--r--devel/ocaml-findlib/Makefile7
-rw-r--r--devel/ocaml-findlib/files/patch-src__bytes__Makefile15
-rw-r--r--devel/ocaml-findlib/files/patch-src_findlib-toolbox_Makefile2
3 files changed, 16 insertions, 8 deletions
diff --git a/devel/ocaml-findlib/Makefile b/devel/ocaml-findlib/Makefile
index d5cb14cf87bf..a8335f9ee26c 100644
--- a/devel/ocaml-findlib/Makefile
+++ b/devel/ocaml-findlib/Makefile
@@ -43,12 +43,5 @@ post-install:
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR} \
"! -regex .*ref-man.*"
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ocamlfind
- # Copied from Makefile; requires functional installation:
- cd ${WRKSRC}/src/bytes/_build && \
- ${SETENV} ${MAKE_ENV} \
- OCAMLFIND_CONF=${STAGEDIR}${PREFIX}/etc/findlib.conf \
- ${STAGEDIR}${PREFIX}/bin/ocamlfind install bytes ../META \
- bytes.cmi bytes.cma -optional \
- bytes.cmx bytes.cmxa bytes.a bytes.cmxs
.include <bsd.port.mk>
diff --git a/devel/ocaml-findlib/files/patch-src__bytes__Makefile b/devel/ocaml-findlib/files/patch-src__bytes__Makefile
new file mode 100644
index 000000000000..b4717ccb98cd
--- /dev/null
+++ b/devel/ocaml-findlib/files/patch-src__bytes__Makefile
@@ -0,0 +1,15 @@
+--- src/bytes/Makefile.orig 2014-09-16 11:21:46 UTC
++++ src/bytes/Makefile
+@@ -19,9 +19,9 @@
+ $(OCAMLBUILD) $$files
+
+ install: all
+- mkdir -p "$(prefix)$(OCAML_SITELIB)/bytes"
+- cd _build/ && cp ../META $(BYTE_FILES) "$(prefix)$(OCAML_SITELIB)/bytes"
+- cd _build/ && for f in $(NATIVE_FILES) $(NATIVE_FILES_DYNLINK); do if [ -f "$$f" ]; then cp $$f "$(prefix)$(OCAML_SITELIB)/bytes"; fi; done
++ mkdir -p "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/bytes"
++ cd _build/ && cp ../META $(BYTE_FILES) "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/bytes"
++ cd _build/ && for f in $(NATIVE_FILES) $(NATIVE_FILES_DYNLINK); do if [ -f "$$f" ]; then cp $$f "$(DESTDIR)$(prefix)$(OCAML_SITELIB)/bytes"; fi; done
+
+ uninstall:
+ rm -rf "$(prefix)$(OCAML_SITELIB)/bytes"
diff --git a/devel/ocaml-findlib/files/patch-src_findlib-toolbox_Makefile b/devel/ocaml-findlib/files/patch-src_findlib-toolbox_Makefile
index f4c94245afde..3ddbbcd13fd5 100644
--- a/devel/ocaml-findlib/files/patch-src_findlib-toolbox_Makefile
+++ b/devel/ocaml-findlib/files/patch-src_findlib-toolbox_Makefile
@@ -5,7 +5,7 @@
install:
- cp make_wizard$(EXEC_SUFFIX) make_wizard.pattern $(prefix)$(OCAML_SITELIB)/findlib
-+ ${MKDIR} -p $(DESTDIR)$(prefix)$(OCAML_SITELIB)/findlib
++ mkdir -p $(DESTDIR)$(prefix)$(OCAML_SITELIB)/findlib
+ ${BSD_INSTALL_DATA} make_wizard$(EXEC_SUFFIX) make_wizard.pattern $(DESTDIR)$(prefix)$(OCAML_SITELIB)/findlib
# uninstall: Nothing to do, because the removal of the findlib core also