aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew "RhodiumToad" Gierth <andrew@tao11.riddles.org.uk>2023-08-06 22:00:30 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-08-09 13:01:14 +0000
commit85fe592a0ce9c0d22d19696b0cc915f55f6203d8 (patch)
tree7ca666d7dc62b3f5a858fd88827d5ea4b2e82f7b
parent8c48a83684b3993c6c7d466edbd816602ee2bb4e (diff)
downloadports-85fe592a0ce9c0d22d19696b0cc915f55f6203d8.tar.gz
ports-85fe592a0ce9c0d22d19696b0cc915f55f6203d8.zip
lang/guile[23]: prefer long over long long for scm_off_t
When long and long long are both the same size as off_t, prefer long for scm_off_t even though it should make no difference, because llvm16 seems to consider them distinct types as arguments in function pointer types. Also it seems cleaner. fixes mailutils with GUILE=on on llvm16 on amd64. Fixes: 94218d3a91189c7afea956e8905d5e5ecf879a2c PR: 260960
-rw-r--r--lang/guile2/Makefile2
-rw-r--r--lang/guile2/files/patch-libguile_gen-scmconfig.c2
-rw-r--r--lang/guile3/Makefile1
-rw-r--r--lang/guile3/files/patch-libguile_gen-scmconfig.c6
4 files changed, 6 insertions, 5 deletions
diff --git a/lang/guile2/Makefile b/lang/guile2/Makefile
index 7236fa11e2c1..37694221837c 100644
--- a/lang/guile2/Makefile
+++ b/lang/guile2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= guile
DISTVERSION= 2.2.7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang scheme
MASTER_SITES= GNU
PKGNAMESUFFIX= 2
diff --git a/lang/guile2/files/patch-libguile_gen-scmconfig.c b/lang/guile2/files/patch-libguile_gen-scmconfig.c
index db1dd3fc9113..b72e32681a5d 100644
--- a/lang/guile2/files/patch-libguile_gen-scmconfig.c
+++ b/lang/guile2/files/patch-libguile_gen-scmconfig.c
@@ -12,7 +12,7 @@
pf ("typedef int scm_t_off;\n");
pf ("#define SCM_T_OFF_MAX INT_MAX\n");
pf ("#define SCM_T_OFF_MIN INT_MIN\n");
-+#elif SIZEOF_OFF_T == SIZEOF_LONG_LONG
++#elif SIZEOF_OFF_T == SIZEOF_LONG_LONG && SIZEOF_OFF_T != SIZEOF_LONG
+ pf ("typedef long long int scm_t_off;\n");
+ pf ("#define SCM_T_OFF_MAX LLONG_MAX\n");
+ pf ("#define SCM_T_OFF_MIN LLONG_MIN\n");
diff --git a/lang/guile3/Makefile b/lang/guile3/Makefile
index b1ec1c837217..d2021c03c8bd 100644
--- a/lang/guile3/Makefile
+++ b/lang/guile3/Makefile
@@ -1,5 +1,6 @@
PORTNAME?= guile
PORTVERSION= 3.0.9
+PORTREVISION= 1
CATEGORIES= lang scheme
MASTER_SITES= GNU
PKGNAMESUFFIX?= 3
diff --git a/lang/guile3/files/patch-libguile_gen-scmconfig.c b/lang/guile3/files/patch-libguile_gen-scmconfig.c
index 88080e540e4f..ba32f1ab317d 100644
--- a/lang/guile3/files/patch-libguile_gen-scmconfig.c
+++ b/lang/guile3/files/patch-libguile_gen-scmconfig.c
@@ -1,10 +1,10 @@
---- libguile/gen-scmconfig.c.orig 2021-03-09 19:24:59 UTC
+--- libguile/gen-scmconfig.c.orig 2022-10-21 15:39:38 UTC
+++ libguile/gen-scmconfig.c
-@@ -343,6 +343,10 @@ main (int argc, char *argv[])
+@@ -329,6 +329,10 @@ main (int argc, char *argv[])
pf ("typedef int scm_t_off;\n");
pf ("#define SCM_T_OFF_MAX INT_MAX\n");
pf ("#define SCM_T_OFF_MIN INT_MIN\n");
-+#elif SIZEOF_OFF_T == SIZEOF_LONG_LONG
++#elif SIZEOF_OFF_T == SIZEOF_LONG_LONG && SIZEOF_OFF_T != SIZEOF_LONG
+ pf ("typedef long long int scm_t_off;\n");
+ pf ("#define SCM_T_OFF_MAX LLONG_MAX\n");
+ pf ("#define SCM_T_OFF_MIN LLONG_MIN\n");