aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-09-02 19:11:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-09-02 19:11:55 +0000
commit865909617a250564cf62b08f6034fe2e6e15d451 (patch)
treea052d1d20fd1c787cf4adc2e09bec25df745421c
parent87dcdf0c6fa0c95d1c40b29c671c1d53f219bc51 (diff)
downloadports-865909617a250564cf62b08f6034fe2e6e15d451.tar.gz
ports-865909617a250564cf62b08f6034fe2e6e15d451.zip
audio/sonivox-eas: New port: Sonivox EAS for Qt
-rw-r--r--audio/Makefile1
-rw-r--r--audio/sonivox-eas/Makefile27
-rw-r--r--audio/sonivox-eas/distinfo3
-rw-r--r--audio/sonivox-eas/files/patch-cmdlnsynth_CMakeLists.txt11
-rw-r--r--audio/sonivox-eas/files/patch-guisynth_CMakeLists.txt11
-rw-r--r--audio/sonivox-eas/files/patch-libsvoxeas_CMakeLists.txt11
-rw-r--r--audio/sonivox-eas/pkg-descr7
-rw-r--r--audio/sonivox-eas/pkg-plist10
8 files changed, 81 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 72a2f50c8e0b..66c10288eb84 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -735,6 +735,7 @@
SUBDIR += sonata
SUBDIR += sonic-visualiser
SUBDIR += sonivox
+ SUBDIR += sonivox-eas
SUBDIR += sorcer-lv2
SUBDIR += sound-juicer
SUBDIR += soundgrab
diff --git a/audio/sonivox-eas/Makefile b/audio/sonivox-eas/Makefile
new file mode 100644
index 000000000000..7e0c3f7ca958
--- /dev/null
+++ b/audio/sonivox-eas/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= sonivox-eas
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.4.0
+CATEGORIES= audio
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Sonivox EAS for Qt
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libdrumstick-alsa.so:audio/drumstick \
+ libGLX.so:graphics/libglvnd \
+ libpulse.so:audio/pulseaudio \
+ libsonivox.so:audio/sonivox
+
+USES= cmake compiler:c++17-lang desktop-file-utils pkgconfig qt:6
+USE_QT= base
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= pedrolcl
+GH_PROJECT= Linux-SonivoxEas
+
+CMAKE_ARGS= -DUSE_QT=6
+
+.include <bsd.port.mk>
diff --git a/audio/sonivox-eas/distinfo b/audio/sonivox-eas/distinfo
new file mode 100644
index 000000000000..5e03c1a5e602
--- /dev/null
+++ b/audio/sonivox-eas/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1662137307
+SHA256 (pedrolcl-Linux-SonivoxEas-v1.4.0_GH0.tar.gz) = bd21d2caf603998bc526e623128968e31c0ba515c7d90b9998b5c74f8685907f
+SIZE (pedrolcl-Linux-SonivoxEas-v1.4.0_GH0.tar.gz) = 59724
diff --git a/audio/sonivox-eas/files/patch-cmdlnsynth_CMakeLists.txt b/audio/sonivox-eas/files/patch-cmdlnsynth_CMakeLists.txt
new file mode 100644
index 000000000000..28327def7603
--- /dev/null
+++ b/audio/sonivox-eas/files/patch-cmdlnsynth_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- cmdlnsynth/CMakeLists.txt.orig 2022-09-02 17:38:38 UTC
++++ cmdlnsynth/CMakeLists.txt
+@@ -5,7 +5,7 @@ get_target_property( SONIVOX_HEADERS sonivox::sonivox
+ target_include_directories( cmdlnsynth PRIVATE ${SONIVOX_HEADERS} )
+
+ target_link_libraries( cmdlnsynth
+- Qt5::Core
++ Qt6::Core
+ Drumstick::ALSA
+ svoxeas
+ )
diff --git a/audio/sonivox-eas/files/patch-guisynth_CMakeLists.txt b/audio/sonivox-eas/files/patch-guisynth_CMakeLists.txt
new file mode 100644
index 000000000000..75ffd12302a6
--- /dev/null
+++ b/audio/sonivox-eas/files/patch-guisynth_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- guisynth/CMakeLists.txt.orig 2022-09-02 17:39:16 UTC
++++ guisynth/CMakeLists.txt
+@@ -20,7 +20,7 @@ get_target_property( SONIVOX_HEADERS sonivox::sonivox
+ target_include_directories( guisynth PRIVATE ${SONIVOX_HEADERS} )
+
+ target_link_libraries( guisynth
+- Qt5::Widgets
++ Qt6::Widgets
+ Drumstick::ALSA
+ svoxeas
+ )
diff --git a/audio/sonivox-eas/files/patch-libsvoxeas_CMakeLists.txt b/audio/sonivox-eas/files/patch-libsvoxeas_CMakeLists.txt
new file mode 100644
index 000000000000..40a3cedc1376
--- /dev/null
+++ b/audio/sonivox-eas/files/patch-libsvoxeas_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- libsvoxeas/CMakeLists.txt.orig 2022-09-02 17:37:31 UTC
++++ libsvoxeas/CMakeLists.txt
+@@ -25,7 +25,7 @@ set_target_properties( svoxeas PROPERTIES
+
+ target_link_libraries( svoxeas PRIVATE
+ sonivox::sonivox-static
+- Qt5::Core
++ Qt6::Core
+ Drumstick::ALSA
+ PkgConfig::PULSE
+ )
diff --git a/audio/sonivox-eas/pkg-descr b/audio/sonivox-eas/pkg-descr
new file mode 100644
index 000000000000..4ae0e33ff633
--- /dev/null
+++ b/audio/sonivox-eas/pkg-descr
@@ -0,0 +1,7 @@
+The Sonivox EAS project is a MIDI Synth library based on the Sonivox EAS
+Synthesizer published by Google on the Android Open Source Project. It is a
+real time GM synthesizer without needing external soundfonts, using embedded
+samples instead. It consumes very little resources, so it may be indicated in
+Linux projects for small embedded devices.
+
+WWW: https://github.com/pedrolcl/Linux-SonivoxEas
diff --git a/audio/sonivox-eas/pkg-plist b/audio/sonivox-eas/pkg-plist
new file mode 100644
index 000000000000..b586c34a1132
--- /dev/null
+++ b/audio/sonivox-eas/pkg-plist
@@ -0,0 +1,10 @@
+bin/cmdlnsynth
+bin/guisynth
+include/programsettings.h
+include/synthcontroller.h
+include/synthrenderer.h
+lib/libsvoxeas.so
+lib/libsvoxeas.so.1
+lib/libsvoxeas.so.1.4.0
+share/applications/sonivoxeas.desktop
+share/icons/hicolor/128x128/sonivoxeas.png