aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2021-10-05 13:51:52 +0000
committerMathieu Arnold <mat@FreeBSD.org>2021-10-05 13:51:52 +0000
commit865ea2fb35e36645d899b65c7701758f3c1bcc16 (patch)
tree328b753ca966f10d1796df01e635a9f742c99099
parent84029f184f27ec93364bbb4d04ddcf1bfc869d70 (diff)
downloadports-865ea2fb35e36645d899b65c7701758f3c1bcc16.tar.gz
ports-865ea2fb35e36645d899b65c7701758f3c1bcc16.zip
math/fftw3: fix after sweep
COMPILER_TYPE needs to be defined in all cases make: "/usr/ports/math/fftw3-float/../../math/fftw3/Makefile" line 130: Malformed conditional (${ARCH} == "i386" && (${COMPILER_TYPE} == "gcc" || !empty(USE_GCC)) && !${PORT_OPTIONS:MOPENMPI})
-rw-r--r--math/fftw3/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index b314c7ac222f..5c1f93409379 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -48,6 +48,7 @@ OPTIONS_SUB= yes
G77_WRAPPERS_DESC= Alter Fortran wrappers for use with g77
OPENMP_DESC= Build OpenMP multithreaded libraries
+OPENMP_USES= compiler:env
OPENMP_USES_OFF= compiler:env
OPENMP_CONFIGURE_ENABLE= openmp
OPENMP_EXTRA_PATCHES= ${FILESDIR}/extrapatch-tests_fftw-bench.c