aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Osipov <michael.osipov@siemens.com>2023-03-27 19:24:25 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-03-27 19:31:42 +0000
commit866380c886c03989de1650b5f3ef028d7f26f1d0 (patch)
tree833b4c9032066bd5cb231913c3cd3eee7e593404
parentafde4ee9e65f55de748db646acf7ea42affeeb70 (diff)
downloadports-866380c886c03989de1650b5f3ef028d7f26f1d0.tar.gz
ports-866380c886c03989de1650b5f3ef028d7f26f1d0.zip
devel/py-gitlab-webhook-handler: New port: Webhook Handler for GitLab
- Submitter becomes maintainer Webhook Handler for GitLab written in Python with Flask deployed as WSGI application. WWW: https://github.com/ahebrank/gitlab-webhook-handler PR: 269047
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-gitlab-webhook-handler/Makefile29
-rw-r--r--devel/py-gitlab-webhook-handler/distinfo3
-rw-r--r--devel/py-gitlab-webhook-handler/pkg-descr2
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b1e09116d0b6..06e6dae40b7f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4651,6 +4651,7 @@
SUBDIR += py-git-up
SUBDIR += py-git-url-parse
SUBDIR += py-gitdb
+ SUBDIR += py-gitlab-webhook-handler
SUBDIR += py-gitless
SUBDIR += py-gitpython
SUBDIR += py-giturlparse
diff --git a/devel/py-gitlab-webhook-handler/Makefile b/devel/py-gitlab-webhook-handler/Makefile
new file mode 100644
index 000000000000..709b02d96206
--- /dev/null
+++ b/devel/py-gitlab-webhook-handler/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= gitlab-webhook-handler
+DISTVERSION= 1.0.2
+CATEGORIES= devel www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= gwh-${DISTVERSION}
+
+MAINTAINER= michael.osipov@siemens.com
+COMMENT= Webhook Handler for GitLab
+WWW= https://github.com/ahebrank/gitlab-webhook-handler
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>=1.0:www/py-flask@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.19.0:www/py-requests@${PY_FLAVOR}
+
+USES= cpe python
+CPE_VENDOR= python
+USE_PYTHON= autoplist concurrent distutils
+PYDISTUTILS_PKGNAME= gwh
+
+NO_ARCH= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|python -m gwh|${PYTHON_VERSION} -m gwh|' \
+ ${WRKSRC}/gwh/__main__.py
+
+.include <bsd.port.mk>
diff --git a/devel/py-gitlab-webhook-handler/distinfo b/devel/py-gitlab-webhook-handler/distinfo
new file mode 100644
index 000000000000..a88ab34a2220
--- /dev/null
+++ b/devel/py-gitlab-webhook-handler/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674077353
+SHA256 (gwh-1.0.2.tar.gz) = 69c2f151289a6b8015adacff34c64a984c5c8e6abf6cb22cb61f2e08611fed9c
+SIZE (gwh-1.0.2.tar.gz) = 6312
diff --git a/devel/py-gitlab-webhook-handler/pkg-descr b/devel/py-gitlab-webhook-handler/pkg-descr
new file mode 100644
index 000000000000..03a57274735e
--- /dev/null
+++ b/devel/py-gitlab-webhook-handler/pkg-descr
@@ -0,0 +1,2 @@
+Webhook Handler for GitLab written in Python with Flask deployed as WSGI
+application.