aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2022-12-17 21:23:52 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2022-12-17 21:25:18 +0000
commit8690d2d27c7d41f2039c7d643a0e68059f406085 (patch)
treedc3c7efb4d8a677eaecaa3d4568266875ba19440
parent03a2c8684d388547205c47254cefd9ed9daa5152 (diff)
downloadports-8690d2d27c7d41f2039c7d643a0e68059f406085.tar.gz
ports-8690d2d27c7d41f2039c7d643a0e68059f406085.zip
deskutils/growl-for-linux: Drop special casing of GCC 4.2
Remove code specific to GCC 4.2 (as system compiler) which is not necessary any longer: USES=compiler never pulls that in any more. This reverts most of commits 401f96f227521c4527ea9c3887b10fb4bd7ff24b and 92e22122e819280ea0c18de3ddd7a8b8a25a3ead from 2018/2019. Approved by: nivit (maintainer)
-rw-r--r--deskutils/growl-for-linux/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/deskutils/growl-for-linux/Makefile b/deskutils/growl-for-linux/Makefile
index 8ba266d664d2..5904157d1da2 100644
--- a/deskutils/growl-for-linux/Makefile
+++ b/deskutils/growl-for-linux/Makefile
@@ -40,12 +40,6 @@ USE_GNOME= cairo gdkpixbuf2 gtk20 libxml2
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}/display \
${PREFIX}/lib/${PORTNAME}/subscribe
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
-CFLAGS+= -fnested-functions
-.endif
-
post-patch:
@${REINPLACE_CMD} '/^gol_LDADD =/s/$$/ -lgmodule-2.0/' \
${WRKSRC}/Makefile.am
@@ -53,4 +47,4 @@ post-patch:
post-install:
${RM} ${STAGEDIR}${PREFIX}/lib/libgolplug.a
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>