aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-07 10:30:56 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-07 11:10:19 +0000
commit87a690f021d23b3ea2a76e537d1733b49bdff3b1 (patch)
treeb9b93edcb12475e0c16873f2345408ffef4ae6a6
parente3cc4fcd333043bfb76e810b7bef64977122288e (diff)
downloadports-87a690f021d23b3ea2a76e537d1733b49bdff3b1.tar.gz
ports-87a690f021d23b3ea2a76e537d1733b49bdff3b1.zip
x11-toolkits/fox17: prepare for freetype2 update
- freetype2 will no longer ship freetype-config (which was a pkg-config wrapper) in the near future -- use pkg-config to gather the required flags. PR: 251512
-rw-r--r--x11-toolkits/fox17/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index 3c3690f5789b..0824671fcf46 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -20,14 +20,14 @@ LIB_DEPENDS= libpng.so:graphics/png \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-USES= compiler:c++11-lib gl libtool localbase pathfix xorg
+USES= compiler:c++11-lib gl libtool localbase pathfix pkgconfig xorg
USE_GL= gl glu
USE_XORG= ice sm x11 xcursor xext xfixes xft xi xrandr xrender
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-freetype-include="`freetype-config --cflags | sed -e 's|^-I||'`" \
- --with-freetype-library="`freetype-config --libs | sed -e 's|^-L||'`" \
+CONFIGURE_ARGS= --with-freetype-include="`pkg-config freetype2 --cflags | sed -e 's|^-I||'`" \
+ --with-freetype-library="`pkg-config freetype2 --libs | sed -e 's|^-L||'`" \
--with-opengl=yes \
--with-xim \
--enable-png \