aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-05-19 13:01:33 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-05-19 13:01:33 +0000
commit888ad81c31d8a754e1bd1f081962215895a116b3 (patch)
treecbddc21e8fbc8213bcb86258a7f0be1cf54ee089
parent435e7d5782dabbde1d270efc0235496e7914d0d7 (diff)
downloadports-888ad81c31d8a754e1bd1f081962215895a116b3.tar.gz
ports-888ad81c31d8a754e1bd1f081962215895a116b3.zip
Update patch to properly display direction of filtering rules.
Bump PORTREVISION. PR: ports/123670 Submitted by: Andrey Groshev <greenx@yandex.ru> Reviewed by: mlaier (maintainer) Approved by: garga (mentor), mlaier (maintainer)
Notes
Notes: svn path=/head/; revision=213330
-rw-r--r--sysutils/pftop/Makefile1
-rw-r--r--sysutils/pftop/files/patch-pftop.c23
2 files changed, 20 insertions, 4 deletions
diff --git a/sysutils/pftop/Makefile b/sysutils/pftop/Makefile
index 0addf7cd8ca0..90148d1aa017 100644
--- a/sysutils/pftop/Makefile
+++ b/sysutils/pftop/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pftop
PORTVERSION= 0.7
+PORTREVISION= 1
CATEGORIES= sysutils net
MASTER_SITES= http://www.eee.metu.edu.tr/~canacar/
DISTNAME= ${PORTNAME}-${PORTVERSION}
diff --git a/sysutils/pftop/files/patch-pftop.c b/sysutils/pftop/files/patch-pftop.c
index 34f8fc455a79..537c1daa3d06 100644
--- a/sysutils/pftop/files/patch-pftop.c
+++ b/sysutils/pftop/files/patch-pftop.c
@@ -1,6 +1,21 @@
---- pftop.c.orig 2007-11-07 07:36:46.000000000 +0100
-+++ pftop.c 2008-04-01 17:03:25.847268996 +0200
-@@ -1570,10 +1570,10 @@
+--- pftop.c.orig 2007-11-07 01:36:46.000000000 -0500
++++ pftop.c 2008-05-16 15:57:12.000000000 -0400
+@@ -1486,7 +1486,13 @@
+ print_fld_size(FLD_BYTES, pr->bytes);
+ #endif
+ print_fld_uint(FLD_RULE, pr->nr);
+- print_fld_str(FLD_DIR, pr->direction == PF_OUT ? "Out" : "In");
++ if (pr->direction == PF_IN)
++ print_fld_str(FLD_DIR, "In");
++ else if (pr->direction == PF_OUT)
++ print_fld_str(FLD_DIR, "Out");
++ else
++ print_fld_str(FLD_DIR, "Any");
++
+ if (pr->quick)
+ print_fld_str(FLD_QUICK, "Quick");
+
+@@ -1570,10 +1576,10 @@
#ifdef HAVE_RULE_UGID
if (pr->uid.op)
tb_print_ugid(pr->uid.op, pr->uid.uid[0], pr->uid.uid[1],
@@ -13,7 +28,7 @@
#endif
if (pr->flags || pr->flagset) {
-@@ -1765,7 +1765,12 @@
+@@ -1765,7 +1771,12 @@
strerror(errno));
return (-1);
}