aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2024-03-28 18:56:53 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2024-04-09 01:37:47 +0000
commit897a8b467e7d4374eb30019f0e7db14af6d5d863 (patch)
tree11719ef62edc2e46939b93f5d189b100dde95a35
parent095e86965f6a88f164404c27bc19dddf5fb54fe1 (diff)
downloadports-897a8b467e7d4374eb30019f0e7db14af6d5d863.tar.gz
ports-897a8b467e7d4374eb30019f0e7db14af6d5d863.zip
graphics/mandelbulber: update 2.30 → 2.31-1
-rw-r--r--graphics/mandelbulber/Makefile8
-rw-r--r--graphics/mandelbulber/distinfo6
-rw-r--r--graphics/mandelbulber/files/patch-mandelbulber2_cmake_CMakeLists.txt19
-rw-r--r--graphics/mandelbulber/files/patch-mandelbulber2_deploy_linux_mandelbulber2.desktop11
4 files changed, 26 insertions, 18 deletions
diff --git a/graphics/mandelbulber/Makefile b/graphics/mandelbulber/Makefile
index 1c49a6c63f18..0852b4bb2a3c 100644
--- a/graphics/mandelbulber/Makefile
+++ b/graphics/mandelbulber/Makefile
@@ -1,11 +1,11 @@
PORTNAME= mandelbulber
-PORTVERSION= 2.30
-PORTREVISION= 2
+DISTVERSION= 2.31-1
CATEGORIES= graphics
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= 3D Mandelbrot fractal renderer
-WWW= https://mandelbulber.com/
+WWW= https://mandelbulber.com/ \
+ https://github.com/buddhi1980/mandelbulber2
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -24,7 +24,7 @@ GH_PROJECT= ${PORTNAME}2
USES= cmake compiler:c++11-lang gnome jpeg localbase:ldflags \
pkgconfig qt:5
USE_QT= core widgets network gui multimedia testlib concurrent \
- qmake:build buildtools:build uitools:build
+ declarative qmake:build buildtools:build uitools:build
CMAKE_SOURCE_PATH= ${WRKSRC}/mandelbulber2/cmake
diff --git a/graphics/mandelbulber/distinfo b/graphics/mandelbulber/distinfo
index 374de7b7c5d1..668ffc95dfb2 100644
--- a/graphics/mandelbulber/distinfo
+++ b/graphics/mandelbulber/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1689621789
-SHA256 (buddhi1980-mandelbulber2-2.30_GH0.tar.gz) = ecbe7dfbefcc2d9e1fbc2af348b784fafbc224850dc596d3717bdf2700eb514d
-SIZE (buddhi1980-mandelbulber2-2.30_GH0.tar.gz) = 128881431
+TIMESTAMP = 1711646484
+SHA256 (buddhi1980-mandelbulber2-2.31-1_GH0.tar.gz) = 3cb06009c1dd909b6237383ecefc3ef35fb2e7f3b86f9ce93e806055cf8c3a96
+SIZE (buddhi1980-mandelbulber2-2.31-1_GH0.tar.gz) = 131708670
diff --git a/graphics/mandelbulber/files/patch-mandelbulber2_cmake_CMakeLists.txt b/graphics/mandelbulber/files/patch-mandelbulber2_cmake_CMakeLists.txt
new file mode 100644
index 000000000000..a8eb70476056
--- /dev/null
+++ b/graphics/mandelbulber/files/patch-mandelbulber2_cmake_CMakeLists.txt
@@ -0,0 +1,19 @@
+--- mandelbulber2/cmake/CMakeLists.txt.orig 2024-02-11 08:21:17 UTC
++++ mandelbulber2/cmake/CMakeLists.txt
+@@ -41,6 +41,7 @@ find_package(Qt5Concurrent REQUIRED)
+ find_package(Qt5Test REQUIRED)
+ find_package(Qt5Multimedia REQUIRED)
+ find_package(Qt5Concurrent REQUIRED)
++find_package(Qt5Qml REQUIRED)
+
+ # Find other required libraries.
+ find_package(PNG REQUIRED)
+@@ -90,7 +90,7 @@ add_executable(mandelbulber2 WIN32
+ ${SOURCE_FILES} ${ADDITIONAL_EXECUTABLE} ${qt_UI_H})
+
+ # Link qt libraries.
+-qt5_use_modules(mandelbulber2 Core Widgets Network Gui UiTools Test Multimedia)
++qt5_use_modules(mandelbulber2 Core Widgets Network Gui UiTools Test Multimedia Concurrent Qml)
+
+ # Link other required libraries.
+ include_directories(${PNG_INCLUDE_DIR} ${GSL_INCLUDE_DIRS} ${LZO_INCLUDE_DIR})
diff --git a/graphics/mandelbulber/files/patch-mandelbulber2_deploy_linux_mandelbulber2.desktop b/graphics/mandelbulber/files/patch-mandelbulber2_deploy_linux_mandelbulber2.desktop
deleted file mode 100644
index 2130b151fd58..000000000000
--- a/graphics/mandelbulber/files/patch-mandelbulber2_deploy_linux_mandelbulber2.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
---- mandelbulber2/deploy/linux/mandelbulber2.desktop.orig 2023-07-09 14:19:06 UTC
-+++ mandelbulber2/deploy/linux/mandelbulber2.desktop
-@@ -3,7 +3,7 @@ Categories=Graphics;3DGraphics;Math;Science;
- Comment=Visit 3D Fractal World
- Exec=mandelbulber2
- GenericName=Mandelbulber v2 - Advanced 3D fractal generator
--Icon=mandelbulber
-+Icon=mandelbulber2
- Name=Mandelbulber v2
- StartupNotify=true
- Terminal=false