aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2022-01-26 09:16:13 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2022-01-26 10:08:44 +0000
commit89d8165393248354e9b28987dd57f34fd5d4464c (patch)
tree6d68fab65ec9dc651aa595582ad6ae7b8e7819ed
parente96bfcf30a5e5d497597337169f5ad92c1b12161 (diff)
downloadports-89d8165393248354e9b28987dd57f34fd5d4464c.tar.gz
ports-89d8165393248354e9b28987dd57f34fd5d4464c.zip
sysutils/py-ansible-core211: Repocopy sysutils/py-ansible-core
The future port of sysutils/ansible4 requires version 2.11.
-rw-r--r--sysutils/py-ansible-core211/Makefile102
-rw-r--r--sysutils/py-ansible-core211/distinfo3
-rw-r--r--sysutils/py-ansible-core211/pkg-descr7
3 files changed, 112 insertions, 0 deletions
diff --git a/sysutils/py-ansible-core211/Makefile b/sysutils/py-ansible-core211/Makefile
new file mode 100644
index 000000000000..71fe22605691
--- /dev/null
+++ b/sysutils/py-ansible-core211/Makefile
@@ -0,0 +1,102 @@
+PORTNAME= ansible-core
+DISTVERSION= 2.11.7
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Radically simple IT automation
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}resolvelib05>=0.5.3<0.6:devel/py-resolvelib05@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bcrypt>=0:security/py-bcrypt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}boto3>0:www/py-boto3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}passlib>0:security/py-passlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>=0:security/py-pycrypto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-mock>0:devel/py-pytest-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
+
+USES= ansible:env cpe gmake python:3.6+ shebangfix
+CPE_VENDOR= redhat
+CPE_PRODUCT= ansible
+USE_PYTHON= autoplist concurrent distutils
+
+SHEBANG_REGEX= [.]/test/.*[.]py
+
+TEST_ARGS= VERSION=${DISTVERSION} \
+ PYTHON=${PYTHON_CMD} \
+ DATE=
+TEST_ENV= PYTHON_VERSION=${PYTHON_VER}
+TEST_TARGET= tests
+
+CONFLICTS= py*-ansible-base py*-ansible2
+
+NO_ARCH= yes
+
+PLIST_FILES= share/man/man1/ansible-config.1.gz \
+ share/man/man1/ansible-console.1.gz \
+ share/man/man1/ansible-doc.1.gz \
+ share/man/man1/ansible-galaxy.1.gz \
+ share/man/man1/ansible-inventory.1.gz \
+ share/man/man1/ansible-playbook.1.gz \
+ share/man/man1/ansible-pull.1.gz \
+ share/man/man1/ansible-vault.1.gz \
+ share/man/man1/ansible.1.gz
+PORTEXAMPLES= ansible.cfg hosts
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-patch:
+# Preserve the original paths in
+# test/units/cli/galaxy/test_execute_list_collection.py.
+# Replacing /usr/share/ansible breaks tests.
+ ${FIND} ${WRKSRC} -not -regex '${WRKSRC}/test/units/cli/galaxy/test_execute_list_collection.py' -type f -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} \
+ -e 's|/etc/ansible|${ETCDIR}|g' \
+ -e 's|/usr/share/ansible|${DATADIR}|g'
+ ${FIND} ${WRKSRC} -type f -name "*.bak" -delete
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/docs/man/man1/*.1 \
+ ${STAGEDIR}${MAN1PREFIX}/share/man/man1
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/ansible.cfg ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/hosts ${STAGEDIR}${EXAMPLESDIR}
+
+post-stage:
+ ${FIND} ${STAGEDIR}${PREFIX}/bin -type l -name ansible-\* -lname ansible \
+ -execdir ${RLN} ansible-${PYTHON_VER} {} \;
+# USE_PYTHON=autoplist doesn't add this file to pkg-plist.
+ ${RM} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/ansible_test/_data/injector/ansible-inventory
+
+pre-test:
+# This one file does not get its paths replaced correctly in post-patch.
+ ${REINPLACE_CMD} 's|"/etc"|"${ETCDIR:H}"|g' \
+ ${WRKSRC}/test/units/playbook/test_helpers.py
+# This test constructs a Python script inline and uses an invalid path to it.
+ ${REINPLACE_CMD} 's|/usr/bin/python|${PYTHON_CMD}|' \
+ ${WRKSRC}/test/units/modules/test_async_wrapper.py
+# Skip the SELinux tests, it's not present on FreeBSD.
+ ${RM} ${WRKSRC}/test/units/module_utils/basic/test_selinux.py
+# Disable some failing tests. They fail to detect that emoji are of width 2 istead of 1.
+ ${RM} ${WRKSRC}/test/units/utils/test_display.py
+
+.include <bsd.port.mk>
+
+# Make sure that we override the unique DATADIR and ETCDIR set
+# by the implicit USES=uniquefiles.
+DATADIR= ${ANSIBLE_DATADIR}
+ETCDIR= ${ANSIBLE_ETCDIR}
diff --git a/sysutils/py-ansible-core211/distinfo b/sysutils/py-ansible-core211/distinfo
new file mode 100644
index 000000000000..232cbe551d21
--- /dev/null
+++ b/sysutils/py-ansible-core211/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1643125412
+SHA256 (ansible-core-2.11.7.tar.gz) = b87188beacfac1bb6dc5cf65663f3c52e66e0f9990742db00a3dca71ebae2eee
+SIZE (ansible-core-2.11.7.tar.gz) = 7108269
diff --git a/sysutils/py-ansible-core211/pkg-descr b/sysutils/py-ansible-core211/pkg-descr
new file mode 100644
index 000000000000..85bd98c0077f
--- /dev/null
+++ b/sysutils/py-ansible-core211/pkg-descr
@@ -0,0 +1,7 @@
+Ansible is a radically simple configuration-management, deployment,
+task-execution, and multinode orchestration framework.
+
+ansible-core contains the core engine, modules and plugins. It does not contain
+community and partner supported Ansible Collections of modules and plugins.
+
+WWW: https://www.ansible.com/