aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-29 11:26:07 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-29 22:53:31 +0000
commit8a6eea18276c7b12fe62a87013a361514c7ae7e5 (patch)
tree223ccd2b5c33a8f752d13cac250853819c616fbd
parent339c2277cfc84002238b7529866ae96971124b90 (diff)
downloadports-8a6eea18276c7b12fe62a87013a361514c7ae7e5.tar.gz
ports-8a6eea18276c7b12fe62a87013a361514c7ae7e5.zip
security/webfwlog: Change OPTIONS_DEFAULT to PGSQL
- As MySQL57 is reaching EOL on 2023-12-31 and this port do not support MySQL80 so switch to other possible DEFAULT option - Pet portclippy - Unmark DEPRECATION Approved by: portmgr (blanket)
-rw-r--r--security/webfwlog/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/security/webfwlog/Makefile b/security/webfwlog/Makefile
index f76393163bc9..f3206577aeb3 100644
--- a/security/webfwlog/Makefile
+++ b/security/webfwlog/Makefile
@@ -1,5 +1,6 @@
PORTNAME= webfwlog
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/ \
http://devel.webfwlog.net/download/v1.1.x/
@@ -10,17 +11,20 @@ WWW= http://www.webfwlog.net/
LICENSE= GPLv2
-DEPRECATED= Depends on EOL MySQL 5.7
-EXPIRATION_DATE= 2023-11-28
-
USES= cpe php:web
+USE_PHP= session
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-syslog \
--sysconfdir=${ETCDIR} \
--disable-dependency-tracking
-USE_PHP= session
+SUB_FILES= pkg-message
+SUB_LIST+= VERSION=${PORTVERSION}
+
+PLIST_SUB+= WWWGRP=${WWWGRP}
+PORTDOCS= AUTHORS COPYING CREDITS ChangeLog INSTALL \
+ README README.geoip README.pdf ReleaseNotes
OPTIONS_DEFINE= DOCS
@@ -32,7 +36,7 @@ OPTIONS_GROUP= GEOIPV2
OPTIONS_GROUP_GEOIPV2= LIBMAXMINDDB MAXMINDDB BDB
GEOIPV2_DESC= GEOIPv2 support
-OPTIONS_DEFAULT= MYSQLIPV6 MYSQL
+OPTIONS_DEFAULT= PGSQL
MYSQL_CONFIGURE_WITH= mysql
MYSQL_USE= php=mysqli
@@ -70,14 +74,6 @@ BDB_CPPFLAGS= -I${BDB_INCLUDE_DIR}
BDB_LDFLAGS= -L${BDB_LIB_DIR}
BDB_USES= bdb
-PORTDOCS= AUTHORS COPYING CREDITS ChangeLog INSTALL \
- README README.geoip README.pdf ReleaseNotes
-
-SUB_FILES= pkg-message
-SUB_LIST+= VERSION=${PORTVERSION}
-
-PLIST_SUB+= WWWGRP=${WWWGRP}
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQLIPV6}