aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-14 04:27:10 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-14 04:27:10 +0000
commit8aaa99e52e3bbf975886ae7ec10e02a9fbee902d (patch)
tree550e5734ec7b2a23cd32acf690e780b2f4a7844f
parent55ccadad19350222a1fb026614660fe336d877c5 (diff)
downloadports-8aaa99e52e3bbf975886ae7ec10e02a9fbee902d.tar.gz
ports-8aaa99e52e3bbf975886ae7ec10e02a9fbee902d.zip
Tumble is a utility to construct PDF files from one or more image
files. Supported input image file formats are JPEG, and black and white TIFF (single- or multi-page). Black and white images will be encoded in the PDF output using lossless Group 4 fax compression (ITU-T recommendation T.6). This provides a very good compression ratio for text and line art. JPEG images will be preserved with the original coding. The current version of Tumble will only work on little-endian systems, such as x86, VAX, and Alpha. The byte order dependencies will be fixed in a later release. PR: ports/142765 Submitted by: Rob Farmer <rfarmer at predatorlabs.net>
Notes
Notes: svn path=/head/; revision=247845
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/tumble/Makefile45
-rw-r--r--graphics/tumble/distinfo3
-rw-r--r--graphics/tumble/pkg-descr11
4 files changed, 60 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 960e9ebac0b5..8d7673f4b7e1 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -895,6 +895,7 @@
SUBDIR += tonicpoint-viewer
SUBDIR += truevision
SUBDIR += tulip
+ SUBDIR += tumble
SUBDIR += uDrawGraph
SUBDIR += ufraw
SUBDIR += uniconvertor
diff --git a/graphics/tumble/Makefile b/graphics/tumble/Makefile
new file mode 100644
index 000000000000..1c11d5d1edeb
--- /dev/null
+++ b/graphics/tumble/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: lcdtest
+# Date created: 12 Jan 2010
+# Whom: Rob Farmer <rfarmer@predatorlabs.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tumble
+PORTVERSION= 0.33
+CATEGORIES= graphics print
+MASTER_SITES= http://tumble.brouhaha.com/download/ \
+ http://www.predatorlabs.net/dl/
+
+MAINTAINER= rfarmer@predatorlabs.net
+COMMENT= Creates a PDF file from image files
+
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
+ netpbm.1:${PORTSDIR}/graphics/netpbm
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+
+USE_GMAKE= yes
+USE_BISON= build
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+ONLY_FOR_ARCHS= amd64 arm i386 ia64 pc98
+ONLY_FOR_ARCHS_REASON= Only works on little endian systems
+
+PLIST_FILES= bin/tumble
+PORTDOCS= README
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|LDFLAGS =|LDFLAGS= ${LDFLAGS}|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|-lpbm|-lnetpbm|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tumble ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/tumble/distinfo b/graphics/tumble/distinfo
new file mode 100644
index 000000000000..ba179bcd8830
--- /dev/null
+++ b/graphics/tumble/distinfo
@@ -0,0 +1,3 @@
+MD5 (tumble-0.33.tar.gz) = caf7d189c4c5f2f4ba004bcc8912669e
+SHA256 (tumble-0.33.tar.gz) = d579d572b4335d8c4008695fee9f32051194499987c340b14f17b294ece7643e
+SIZE (tumble-0.33.tar.gz) = 42983
diff --git a/graphics/tumble/pkg-descr b/graphics/tumble/pkg-descr
new file mode 100644
index 000000000000..05ddd463ff15
--- /dev/null
+++ b/graphics/tumble/pkg-descr
@@ -0,0 +1,11 @@
+Tumble is a utility to construct PDF files from one or more image
+files. Supported input image file formats are JPEG, and black and
+white TIFF (single- or multi-page). Black and white images will be
+encoded in the PDF output using lossless Group 4 fax compression
+(ITU-T recommendation T.6). This provides a very good compression
+ratio for text and line art. JPEG images will be preserved with the
+original coding.
+
+The current version of Tumble will only work on little-endian systems,
+such as x86, VAX, and Alpha. The byte order dependencies will be fixed
+in a later release.