aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-10-04 16:57:49 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-10-04 16:57:49 +0000
commit8abb75929679a8cd4ef6f6dd5117496aaefe900d (patch)
treeac364a66171420bbabba82046952f5a9f2db2cf7
parent54b634c84e97140073e611d72052443ff2304c30 (diff)
downloadports-8abb75929679a8cd4ef6f6dd5117496aaefe900d.tar.gz
ports-8abb75929679a8cd4ef6f6dd5117496aaefe900d.zip
add new port: games/castlevox
Castle Vox is a next generation computer strategy board game. Capture all the enemy Castles to win! Features: - Fast world domination. - Plan attacks simultaneously. - Collaborate with teammates. - Maps from history and fantasy. - Giant maps with many players. - Map editor included. - Hard AI will push your brain in single-player matches. - Online multi-player modes: relaxed and speed variants. - Achievements. - Easy to learn, hard to master. - Mixes elements from Diplomacy and Axis & Allies board games. - Available for Mac OS X, Linux, and Windows. WWW: http://sillysoft.net/vox/ PR: 155070 Submitted by: gamato@users.sf.net
Notes
Notes: svn path=/head/; revision=305268
-rw-r--r--games/Makefile1
-rw-r--r--games/castlevox/Makefile32
-rw-r--r--games/castlevox/distinfo2
-rw-r--r--games/castlevox/files/CastleVox.in8
-rw-r--r--games/castlevox/pkg-descr22
-rw-r--r--games/castlevox/pkg-plist75
6 files changed, 140 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 901f541fcba2..7c6d8a9f3d9b 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -118,6 +118,7 @@
SUBDIR += cake
SUBDIR += caph
SUBDIR += cardpics
+ SUBDIR += castlevox
SUBDIR += cave9
SUBDIR += cavezofphear
SUBDIR += ceferino
diff --git a/games/castlevox/Makefile b/games/castlevox/Makefile
new file mode 100644
index 000000000000..3ad7ffb96053
--- /dev/null
+++ b/games/castlevox/Makefile
@@ -0,0 +1,32 @@
+# Created by: Martin Otto
+#
+# $FreeBSD$
+
+PORTNAME= CastleVox
+PORTVERSION= 1.2
+CATEGORIES= games java
+MASTER_SITES= http://sillysoft.net/download/
+DISTNAME= CastleVox-linux
+
+MAINTAINER= gamato@users.sf.net
+COMMENT= A fast world domination game
+
+FETCH_ARGS= -Fpr
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+
+WRKSRC= ${WRKDIR}/CastleVoxPC
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+NO_BUILD= yes
+
+SUB_FILES= CastleVox
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} \*.jar ${DATADIR})
+ ${INSTALL_DATA} ${WRKSRC}/VoxIcon.png ${DATADIR}
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} Support ${DATADIR})
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} docs ${DATADIR})
+ ${INSTALL_SCRIPT} ${WRKDIR}/CastleVox ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/castlevox/distinfo b/games/castlevox/distinfo
new file mode 100644
index 000000000000..3a5151f39504
--- /dev/null
+++ b/games/castlevox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CastleVox-linux.tar.gz) = 9fb7fffc3b8e15ca947f056f494cffc612d092e53a073538f382ca7b84132880
+SIZE (CastleVox-linux.tar.gz) = 27979326
diff --git a/games/castlevox/files/CastleVox.in b/games/castlevox/files/CastleVox.in
new file mode 100644
index 000000000000..0fa42a640750
--- /dev/null
+++ b/games/castlevox/files/CastleVox.in
@@ -0,0 +1,8 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+echo "Castle Vox: Starting up..."
+cd "%%DATADIR%%"
+JAVA_VERSION="%%JAVA_VERSION%%" exec "%%LOCALBASE%%/bin/java" \
+-Djava.ext.dirs="%%DATADIR%%" -jar "%%DATADIR%%/VoxCore.jar" "$@"
diff --git a/games/castlevox/pkg-descr b/games/castlevox/pkg-descr
new file mode 100644
index 000000000000..47a3438a3068
--- /dev/null
+++ b/games/castlevox/pkg-descr
@@ -0,0 +1,22 @@
+Castle Vox is a next generation computer strategy board game.
+Capture all the enemy Castles to win!
+
+Features:
+
+ - Fast world domination.
+ - Plan attacks simultaneously.
+ - Collaborate with teammates.
+
+ - Maps from history and fantasy.
+ - Giant maps with many players.
+ - Map editor included.
+
+ - Hard AI will push your brain in single-player matches.
+ - Online multi-player modes: relaxed and speed variants.
+ - Achievements.
+
+ - Easy to learn, hard to master.
+ - Mixes elements from Diplomacy and Axis & Allies board games.
+ - Available for Mac OS X, Linux, and Windows.
+
+WWW: http://sillysoft.net/vox/
diff --git a/games/castlevox/pkg-plist b/games/castlevox/pkg-plist
new file mode 100644
index 000000000000..05f8095618a6
--- /dev/null
+++ b/games/castlevox/pkg-plist
@@ -0,0 +1,75 @@
+bin/CastleVox
+%%DATADIR%%/VoxCore.jar
+%%DATADIR%%/VoxIcon.png
+%%DATADIR%%/jide-charts.jar
+%%DATADIR%%/jide-common.jar
+%%DATADIR%%/jogg-0.0.7.jar
+%%DATADIR%%/jorbis-0.0.15.jar
+%%DATADIR%%/tritonus_share.jar
+%%DATADIR%%/vorbisspi1.0.3.jar
+%%DATADIR%%/Support/Maps/Hex Barons.voxb
+%%DATADIR%%/Support/Maps/Tutorial Map.voxb
+%%DATADIR%%/Support/Maps/World War II.voxb
+%%DATADIR%%/Support/Music/CV_Civil War.ogg
+%%DATADIR%%/Support/Music/CV_Main Theme.ogg
+%%DATADIR%%/Support/Music/CV_Medieval.ogg
+%%DATADIR%%/Support/Music/CV_Modern Military.ogg
+%%DATADIR%%/Support/Music/CV_Roman.ogg
+%%DATADIR%%/Support/Music/CV_Victory.ogg
+%%DATADIR%%/Support/Themes/MB Hex Barons/overground.png
+%%DATADIR%%/Support/Themes/MB Hex Barons/updater1.txt
+%%DATADIR%%/Support/Themes/MB Hex Barons/updater2.txt
+%%DATADIR%%/Support/Themes/MB Hex Barons/updater3.txt
+%%DATADIR%%/Support/Themes/MB Hex Barons/updater4.txt
+%%DATADIR%%/Support/Themes/MB Hex Barons/updater5.txt
+%%DATADIR%%/Support/Themes/MB WW2 World/foreground.jpg
+%%DATADIR%%/Support/Themes/MB WW2 World/overground.png
+%%DATADIR%%/Support/Themes/MB WW2 World/unit_castle.png
+%%DATADIR%%/Support/Themes/MB WW2 World/unit_knight.png
+%%DATADIR%%/Support/Themes/MB WW2 World/unit_pawn.png
+%%DATADIR%%/Support/Themes/MB WW2 World/updater1.txt
+%%DATADIR%%/Support/Themes/MB WW2 World/updater2.txt
+%%DATADIR%%/Support/Themes/MB WW2 World/updater3.txt
+%%DATADIR%%/Support/Themes/MB WW2 World/updater4.txt
+%%DATADIR%%/Support/Themes/MB WW2 World/updater5.txt
+%%DATADIR%%/Support/Themes/MB WW2 World/updater6.txt
+%%DATADIR%%/Support/Themes/MB WW2 World/updater7.txt
+%%DATADIR%%/Support/Themes/MB WW2 World/updater8.txt
+%%DATADIR%%/Support/Themes/MB WW2 World/updater9.txt
+%%DATADIR%%/Support/Themes/Tutorial Map/foreground.jpg
+%%DATADIR%%/Support/Themes/Tutorial Map/overground.png
+%%DATADIR%%/Support/Themes/Tutorial Map/updater1.txt
+%%DATADIR%%/Support/Themes/Tutorial Map/updater2.txt
+%%DATADIR%%/Support/Themes/Tutorial Map/updater3.txt
+%%DATADIR%%/Support/Themes/Tutorial Map/updater4.txt
+%%DATADIR%%/Support/Themes/Tutorial Map/updater5.txt
+%%DATADIR%%/docs/Castle_Vox_Instructions.html
+%%DATADIR%%/docs/Castle_Vox_Shortcuts.html
+%%DATADIR%%/docs/Castle_Vox_Version_History.html
+%%DATADIR%%/docs/docs_files/Bonus.png
+%%DATADIR%%/docs/docs_files/Chat.png
+%%DATADIR%%/docs/docs_files/Conflict.png
+%%DATADIR%%/docs/docs_files/Main_Interface.png
+%%DATADIR%%/docs/docs_files/Network.png
+%%DATADIR%%/docs/docs_files/PIwindow.png
+%%DATADIR%%/docs/docs_files/Plugins.png
+%%DATADIR%%/docs/docs_files/Units_castle.png
+%%DATADIR%%/docs/docs_files/Units_knight.png
+%%DATADIR%%/docs/docs_files/Units_pawn.png
+%%DATADIR%%/docs/docs_files/bg.jpg
+%%DATADIR%%/docs/docs_files/footer.jpg
+%%DATADIR%%/docs/docs_files/header.jpg
+%%DATADIR%%/docs/docs_files/moving.png
+%%DATADIR%%/docs/docs_files/prefs.png
+%%DATADIR%%/docs/docs_files/recruit.png
+%%DATADIR%%/docs/docs_files/teammate.png
+@dirrm %%DATADIR%%/docs/docs_files
+@dirrm %%DATADIR%%/docs
+@dirrm %%DATADIR%%/Support/Themes/Tutorial Map
+@dirrm %%DATADIR%%/Support/Themes/MB WW2 World
+@dirrm %%DATADIR%%/Support/Themes/MB Hex Barons
+@dirrm %%DATADIR%%/Support/Themes
+@dirrm %%DATADIR%%/Support/Music
+@dirrm %%DATADIR%%/Support/Maps
+@dirrm %%DATADIR%%/Support
+@dirrm %%DATADIR%%