aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-08-22 17:20:56 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-08-22 17:20:56 +0000
commit8b28d359ca7e54bccf0942afe5d568a9bc7918d8 (patch)
tree83aa32f190c0af13154f99bc15f23e9a148bffbd
parente06cc9c05a838fd6363fb30f32957733115261cb (diff)
downloadports-8b28d359ca7e54bccf0942afe5d568a9bc7918d8.tar.gz
ports-8b28d359ca7e54bccf0942afe5d568a9bc7918d8.zip
- Modernize and simplify the port
- Disable ALSA by default, as judging by demos it leads to instant crash at startup. OSS sound work just fine - Update WWW
Notes
Notes: svn path=/head/; revision=509618
-rw-r--r--devel/allegro-devel/Makefile90
-rw-r--r--devel/allegro-devel/pkg-descr2
2 files changed, 38 insertions, 54 deletions
diff --git a/devel/allegro-devel/Makefile b/devel/allegro-devel/Makefile
index f87d1f6835c6..ee9c2104d53a 100644
--- a/devel/allegro-devel/Makefile
+++ b/devel/allegro-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= allegro
DISTVERSION= 5.0.9
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel
MASTER_SITES= SF/alleg/allegro/${PORTVERSION}
PKGNAMESUFFIX= -devel
@@ -17,74 +17,61 @@ COMMENT= Cross-platform library for games and multimedia programming
LICENSE= ZLIB BSD3CLAUSE
LICENSE_COMB= dual
-LIB_DEPENDS+= libjack.so:audio/jack \
+LIB_DEPENDS= libjack.so:audio/jack \
libpng.so:graphics/png \
libvorbis.so:audio/libvorbis \
libFLAC.so:audio/flac \
libphysfs.so:devel/physfs
-USES= cmake:insource compiler:c++11-lang jpeg openal:soft pkgconfig
+USES= cmake:insource compiler:c++11-lang gl gnome jpeg \
+ openal:soft pkgconfig
USE_XORG= x11 xpm xext xcursor xxf86vm xxf86dga
USE_GL= glu
USE_GNOME= gtk20
USE_LDCONFIG= yes
-PLIST_SUB+= SHLIB_VER="${SHLIB_VER}"
-PLIST_SUB+= SHLIB_VER1="${SHLIB_VER1}"
+CFLAGS+= -isystem${LOCALBASE}/include -L${LOCALBASE}/lib
-SHLIB_VER= ${PORTVERSION}
-SHLIB_VER1= ${PORTVERSION:R}
-
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+PLIST_SUB= SHLIB_VER="${PORTVERSION}" SHLIB_VER1="${PORTVERSION:R}"
# Wrong versioning upstream
PORTSCOUT= limitw:1,even skipv:5.0.10
-OPTIONS_DEFINE= ALSA DOCS PULSEAUDIO
-OPTIONS_GROUP= DEMOS_EXAMPLES
-OPTIONS_GROUP_DEMOS_EXAMPLES= DEMOS EXAMPLES
-OPTIONS_DEFAULT= ALSA DEMOS
-DEMOS_DESC= Install Demos programs, requires EXAMPLES
-
PORTDOCS= *
PORTEXAMPLES= *
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}${PKGNAMESUFFIX}
-DOCSRCDIR1= ${WRKSRC}
-DOC_FILES1= README.txt
-
-DOCSRCDIR2= ${WRKSRC}/docs
-DOCSDIR2= ${DOCSDIR}/docs
-
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= ALSA DOCS EXAMPLES PULSEAUDIO DEMOS
+OPTIONS_DEFAULT= DEMOS
+OPTIONS_SUB= yes
DOCS_BUILD_DEPENDS= ${LOCALBASE}/bin/pandoc:textproc/hs-pandoc
ALSA_LIB_DEPENDS= libasound.so.2:audio/alsa-lib
-ALSA_CMAKE_ON= -DWANT_ALSA=on
-ALSA_CMAKE_OFF= -DWANT_ALSA=off
-DEMOS_IMPLIES= EXAMPLES
+ALSA_CMAKE_BOOL= WANT_ALSA
+ALSA_BROKEN= ALSA support is broken # confirmed by running demos, leads to assertion at startup
+DEMOS_IMPLIES= EXAMPLES
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
-PULSEAUDIO_CMAKE_ON= -DWANT_PULSEAUDIO=on
-PULSEAUDIO_CMAKE_OFF= -DWANT_PULSEAUDIO=off
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDEMOS} && ${PORT_OPTIONS:MEXAMPLES}
-CMAKE_ARGS+=-DWANT_DEMO=on
-SUB_FILES+= cosmic_protector speed \
- pkg-message
-MASTER_SITES+= SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/:icons
-DISTFILES+= cosmic_protector.png:icons \
- speed.png:icons
-DESKTOP_ENTRIES+="Cosmic Protector" "Protect the earth from a deadly meteor shower" \
- "cosmic_protector" "cosmic_protector" "Game;ArcadeGame;" ""
-DESKTOP_ENTRIES+="SPEED" "Simultaneous Projections Employing an Ensemble of Displays" \
- "speed" "speed" "Game;ArcadeGame;" ""
-.else
-CMAKE_ARGS+=-DWANT_DEMO=off
-.endif
+PULSEAUDIO_CMAKE_BOOL= WANT_PULSEAUDIO
+
+DEMOS_DESC= Install demo programs
+DEMOS_CMAKE_BOOL= WANT_DEMO
+DEMOS_SUB_FILES= cosmic_protector speed pkg-message
+DEMOS_MASTER_SITES= SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/:icons
+DEMOS_DISTFILES= cosmic_protector.png:icons speed.png:icons
+DEMOS_DESKTOP_ENTRIES= "Cosmic Protector" \
+ "Protect the earth from a deadly meteor shower" \
+ "cosmic_protector" \
+ "cosmic_protector" \
+ "Game;ArcadeGame;" \
+ "" \
+ "SPEED" \
+ "Simultaneous Projections Employing an Ensemble of Displays" \
+ "speed" \
+ "speed" \
+ "Game;ArcadeGame;" \
+ ""
post-patch:
@${REINPLACE_CMD} -e 's|lib$${LIB_SUFFIX}/pkgconfig|libdata/pkgconfig|' \
@@ -95,13 +82,12 @@ post-patch:
post-install:
${INSTALL_MAN} ${WRKSRC}/docs/man/* ${STAGEDIR}${MAN3PREFIX}/man/man3/
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
- @(cd ${DOCSRCDIR2} && ${COPYTREE_SHARE} "src html" ${STAGEDIR}${DOCSDIR2})
+post-install-DOCS-on:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} "README.txt docs/src docs/html" ${STAGEDIR}${DOCSDIR}
-.if ${PORT_OPTIONS:MEXAMPLES}
+post-install-EXAMPLES-on:
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
-. for l in ex_acodec ex_acodec_multi ex_audio_chain ex_audio_props ex_audio_simple \
+.for l in ex_acodec ex_acodec_multi ex_audio_chain ex_audio_props ex_audio_simple \
ex_bitmap ex_bitmap_flip ex_bitmap_target ex_blend ex_blend2 \
ex_blend_bench ex_blend_test ex_blit ex_clip ex_color ex_config ex_convert \
ex_dir ex_disable_screensaver ex_display_events ex_display_options \
@@ -118,10 +104,9 @@ post-install:
ex_synth ex_threads ex_threads2 ex_timedwait ex_timer ex_transform ex_ttf \
ex_user_events ex_utf8 ex_vsync ex_warp_mouse ex_windows ex_winfull
${STRIP_CMD} ${STAGEDIR}${EXAMPLESDIR}/${l}
-. endfor
-.endif
+.endfor
-.if ${PORT_OPTIONS:MDEMOS} && ${PORT_OPTIONS:MEXAMPLES}
+post-install-DEMOS-on:
@(cd ${WRKSRC} && ${COPYTREE_SHARE} demos ${STAGEDIR}${EXAMPLESDIR})
${INSTALL_SCRIPT} ${WRKDIR}/cosmic_protector ${STAGEDIR}${PREFIX}/bin/
${INSTALL_DATA} ${_DISTDIR}/cosmic_protector.png ${STAGEDIR}${PREFIX}/share/pixmaps/
@@ -131,6 +116,5 @@ post-install:
@(cd ${STAGEDIR}${EXAMPLESDIR}/demos/speed && ${CHMOD} 755 speed)
${STRIP_CMD} ${STAGEDIR}${EXAMPLESDIR}/demos/cosmic_protector/cosmic_protector
${STRIP_CMD} ${STAGEDIR}${EXAMPLESDIR}/demos/speed/speed
-.endif
.include <bsd.port.mk>
diff --git a/devel/allegro-devel/pkg-descr b/devel/allegro-devel/pkg-descr
index 19796d656ccd..9a0421b6bdaa 100644
--- a/devel/allegro-devel/pkg-descr
+++ b/devel/allegro-devel/pkg-descr
@@ -4,4 +4,4 @@ other types of multimedia programming.
A wide range of extension packages and add-on modules are also available, which
can be found in the "Library Extensions" section of the Allegro website.
-WWW: http://www.talula.demon.co.uk/allegro/
+WWW: https://liballeg.org/