aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-04-11 04:42:12 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-04-12 00:33:45 +0000
commit8b4cc116f677d518a48582aea8739bb06e078675 (patch)
tree9e093b594dc39dc6caca74dec03d468644096500
parent9afced56643d76c48d9fac24ede0e1e39f3478cd (diff)
graphics/gstreamer1-plugins-openexr: make compatible with OpenEXR/Imath 3.0
-rw-r--r--graphics/gstreamer1-plugins-openexr/Makefile4
-rw-r--r--multimedia/gstreamer1-plugins/Makefile.common3
2 files changed, 4 insertions, 3 deletions
diff --git a/graphics/gstreamer1-plugins-openexr/Makefile b/graphics/gstreamer1-plugins-openexr/Makefile
index cd4b6d84318c..affa28569cc3 100644
--- a/graphics/gstreamer1-plugins-openexr/Makefile
+++ b/graphics/gstreamer1-plugins-openexr/Makefile
@@ -1,4 +1,4 @@
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics
COMMENT= GStreamer OpenExr codec plugin
@@ -7,6 +7,8 @@ USES+= compiler:c++11-lang
GST_PLUGIN= openexr
DIST= bad
+CPPFLAGS+= -DInt64=uint64_t
+
pre-configure:
${REINPLACE_CMD} -e 's/c++98/c++11/' ${WRKSRC}/ext/openexr/Makefile.in
diff --git a/multimedia/gstreamer1-plugins/Makefile.common b/multimedia/gstreamer1-plugins/Makefile.common
index 0e7d463db6d4..0eeb8a80deba 100644
--- a/multimedia/gstreamer1-plugins/Makefile.common
+++ b/multimedia/gstreamer1-plugins/Makefile.common
@@ -384,8 +384,7 @@ gst_opencv_PLIST_FILES= #
gst_opencv_USES= compiler:c++11-lib
# openexr
-gst_openexr_LIB_DEPENDS=libImath.so:graphics/ilmbase \
- libIlmImf.so:graphics/openexr
+gst_openexr_LIB_DEPENDS= libOpenEXR.so:graphics/openexr
# openjpeg
gst_openjpeg_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg