aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-07-13 06:57:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-07-13 06:58:39 +0000
commit8b9048e625df095caf4410094c1650c356952fce (patch)
tree46ac24ace87fcdb8f9fef93f8115ea86e0ff8eb5
parent6311bd78f28309d77cb0578e4c31d72d74b4d809 (diff)
downloadports-8b9048e625df095caf4410094c1650c356952fce.tar.gz
ports-8b9048e625df095caf4410094c1650c356952fce.zip
misc/py-numcodecs: Attempt to fix build on i386
sse2 isn't enabled by default on i386 so add the corresponding flag. Reported by: fallout
-rw-r--r--misc/py-numcodecs/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/misc/py-numcodecs/Makefile b/misc/py-numcodecs/Makefile
index 7ba24dcfcaca..7106b8fbcb0c 100644
--- a/misc/py-numcodecs/Makefile
+++ b/misc/py-numcodecs/Makefile
@@ -21,6 +21,8 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}msgpack>0:devel/py-msgpack@${PY_FLAVOR} \
USES= python
USE_PYTHON= distutils cython autoplist pytest # tests fail to find the library in the staged directory for some reason
+CXXFLAGS_i386= -msse2 # otherwise it fails to compile: #error SSE2 is not supported by the target architecture/platform and/or this compiler.
+
TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
TEST_WRKSRC= ${WRKSRC}/numcodecs/tests