aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2023-12-10 08:38:31 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2023-12-10 08:38:31 +0000
commit8b9b8aae81be653e37160b9f23ca4a18b99f4b51 (patch)
tree4b182ea678526392813fe38da28581eea24d7d13
parenta7e4468b0854d2f6108c7a7868bd3a5bfe4472cb (diff)
downloadports-8b9b8aae81be653e37160b9f23ca4a18b99f4b51.tar.gz
ports-8b9b8aae81be653e37160b9f23ca4a18b99f4b51.zip
sysutils/u-boot-rpi*: Fix sd boot after v2023.10 update
U-Boot update broke sd boot for rpi* models, use upstream patch that fixes it. PR: 275655 Sponsored by: Beckhoff Automation GmbH & Co.KG
-rw-r--r--sysutils/u-boot-master/distinfo4
-rw-r--r--sysutils/u-boot-rpi-0-w/Makefile4
-rw-r--r--sysutils/u-boot-rpi-arm64/Makefile3
-rw-r--r--sysutils/u-boot-rpi/Makefile4
-rw-r--r--sysutils/u-boot-rpi2/Makefile4
-rw-r--r--sysutils/u-boot-rpi3/Makefile3
-rw-r--r--sysutils/u-boot-rpi4/Makefile3
7 files changed, 24 insertions, 1 deletions
diff --git a/sysutils/u-boot-master/distinfo b/sysutils/u-boot-master/distinfo
index 29e8ed6636fd..f0978abb36ae 100644
--- a/sysutils/u-boot-master/distinfo
+++ b/sysutils/u-boot-master/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1702140241
+TIMESTAMP = 1702197339
SHA256 (u-boot/u-boot-2023.10.tar.bz2) = e00e6c6f014e046101739d08d06f328811cebcf5ae101348f409cbbd55ce6900
SIZE (u-boot/u-boot-2023.10.tar.bz2) = 19645392
SHA256 (u-boot/1036621/raw) = 28dbd66d14fab9dc782ce091d3c132a226b8425f6503c329ee8a7031b79b52f7
@@ -21,3 +21,5 @@ SHA256 (u-boot/1810053/raw) = b67fc8833e226a1a6279a098554f43465170805ce8db5a4074
SIZE (u-boot/1810053/raw) = 1062
SHA256 (u-boot/1810054/raw) = 21418aecaa879caaceaa6acdc07869f5407253bb4fa82044a9771a5222eb5958
SIZE (u-boot/1810054/raw) = 468
+SHA256 (u-boot/1838641/raw) = 953924a8e1df590f64931a3a4b9b55422f2a2f97cd51a42d5caef2c5bb565c4f
+SIZE (u-boot/1838641/raw) = 2523
diff --git a/sysutils/u-boot-rpi-0-w/Makefile b/sysutils/u-boot-rpi-0-w/Makefile
index 125c9584ace2..a00d2ca8330d 100644
--- a/sysutils/u-boot-rpi-0-w/Makefile
+++ b/sysutils/u-boot-rpi-0-w/Makefile
@@ -1,5 +1,9 @@
MASTERDIR= ${.CURDIR}/../u-boot-master
+U_BOOT_SLAVE_PORTREVISION_2023.10= 1
+
+PATCHFILES+= 1838641/raw
+
MODEL= rpi-0-w
BOARD_CONFIG= rpi_0_w_defconfig
FAMILY= rpi
diff --git a/sysutils/u-boot-rpi-arm64/Makefile b/sysutils/u-boot-rpi-arm64/Makefile
index 26be706afbae..25c442df55bf 100644
--- a/sysutils/u-boot-rpi-arm64/Makefile
+++ b/sysutils/u-boot-rpi-arm64/Makefile
@@ -1,6 +1,9 @@
MASTERDIR= ${.CURDIR}/../u-boot-master
+U_BOOT_SLAVE_PORTREVISION_2023.10= 1
+
EXTRA_PATCHES= ${.CURDIR}/files/
+PATCHFILES+= 1838641/raw
MODEL= rpi-arm64
BOARD_CONFIG= rpi_arm64_defconfig
diff --git a/sysutils/u-boot-rpi/Makefile b/sysutils/u-boot-rpi/Makefile
index c92c9c17963a..7958e0d84c99 100644
--- a/sysutils/u-boot-rpi/Makefile
+++ b/sysutils/u-boot-rpi/Makefile
@@ -1,7 +1,11 @@
MASTERDIR= ${.CURDIR}/../u-boot-master
+U_BOOT_SLAVE_PORTREVISION_2023.10= 1
+
WWW= https://wiki.freebsd.org/FreeBSD/arm/Raspberry%20Pi
+PATCHFILES+= 1838641/raw
+
MODEL= rpi
BOARD_CONFIG= rpi_defconfig
FAMILY= rpi
diff --git a/sysutils/u-boot-rpi2/Makefile b/sysutils/u-boot-rpi2/Makefile
index 054ab962dd6e..46309bd46fc8 100644
--- a/sysutils/u-boot-rpi2/Makefile
+++ b/sysutils/u-boot-rpi2/Makefile
@@ -1,7 +1,11 @@
MASTERDIR= ${.CURDIR}/../u-boot-master
+U_BOOT_SLAVE_PORTREVISION_2023.10= 1
+
WWW= https://wiki.freebsd.org/FreeBSD/arm/Raspberry%20Pi
+PATCHFILES+= 1838641/raw
+
MODEL= rpi2
BOARD_CONFIG= rpi_2_defconfig
FAMILY= rpi
diff --git a/sysutils/u-boot-rpi3/Makefile b/sysutils/u-boot-rpi3/Makefile
index 0ba914341934..58afe44225e8 100644
--- a/sysutils/u-boot-rpi3/Makefile
+++ b/sysutils/u-boot-rpi3/Makefile
@@ -1,6 +1,9 @@
MASTERDIR= ${.CURDIR}/../u-boot-master
+U_BOOT_SLAVE_PORTREVISION_2023.10= 1
+
EXTRA_PATCHES?= ${.CURDIR}/files/
+PATCHFILES+= 1838641/raw
MODEL?= rpi3
BOARD_CONFIG?= rpi_3_defconfig
diff --git a/sysutils/u-boot-rpi4/Makefile b/sysutils/u-boot-rpi4/Makefile
index cf50d7a125dd..6a65891a041f 100644
--- a/sysutils/u-boot-rpi4/Makefile
+++ b/sysutils/u-boot-rpi4/Makefile
@@ -1,6 +1,9 @@
MASTERDIR= ${.CURDIR}/../u-boot-master
+U_BOOT_SLAVE_PORTREVISION_2023.10= 1
+
EXTRA_PATCHES= ${.CURDIR}/files/
+PATCHFILES+= 1838641/raw
MODEL= rpi4
BOARD_CONFIG= rpi_4_defconfig