aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:28:27 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:28:27 +0000
commit8be567026f3fd15bdc6e4bb7e585d12ed8619356 (patch)
tree968eaf0ae0fe08bf3650def584c7534060a129b1
parent977344b896efa7455ac4c3be4eee941ea457627e (diff)
downloadports-8be567026f3fd15bdc6e4bb7e585d12ed8619356.tar.gz
ports-8be567026f3fd15bdc6e4bb7e585d12ed8619356.zip
textproc/py-sphinx: Convert to USE_PYTHON=cython_test
- Add comment for UTF-8 filename
-rw-r--r--textproc/py-sphinx/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/textproc/py-sphinx/Makefile b/textproc/py-sphinx/Makefile
index ddef3226fb00..aa4fe1ed86df 100644
--- a/textproc/py-sphinx/Makefile
+++ b/textproc/py-sphinx/Makefile
@@ -35,15 +35,20 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinxcontrib-applehelp>=0:textproc/py-sphin
${PYTHON_PKGNAMEPREFIX}requests>=2.5.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=21.0:devel/py-packaging@${PY_FLAVOR} \
${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}html5lib>=0:www/py-html5lib@${PY_FLAVOR} \
- cython-${PYTHON_VER}:lang/cython@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}html5lib>=0:www/py-html5lib@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent pep517 pytest
+USE_PYTHON= autoplist concurrent cython_test pep517 pytest
NO_ARCH= yes
+PYTEST_BROKEN_TESTS= test_anchors_ignored \
+ test_defaults \
+ test_defaults_json \
+ test_ext_imgconverter \
+ test_latex_images
# Upstream archive contains files with UTF-8 names (#246618)
+# https://github.com/sphinx-doc/sphinx/issues/2395
EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
.include <bsd.port.pre.mk>
@@ -52,10 +57,4 @@ EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=4.8:devel/py-importlib-metadata@${PY_FLAVOR}
.endif
-PYTEST_BROKEN_TESTS= test_latex_images \
- test_ext_imgconverter \
- test_defaults \
- test_defaults_json \
- test_anchors_ignored
-
.include <bsd.port.post.mk>