aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-06 18:36:16 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-07 05:12:47 +0000
commit8cb77295b753892abb72056ae2938092adf2e46d (patch)
tree2728b638974e01ac130e8e7155c5be37cce7e161
parentecb22ce6d1e9b300c4f9bdd9369627967eeebad4 (diff)
downloadports-8cb77295b753892abb72056ae2938092adf2e46d.tar.gz
ports-8cb77295b753892abb72056ae2938092adf2e46d.zip
devel/py-ariadne: New port
Ariadne is a Python library for implementing GraphQL servers. - Schema-first: Ariadne enables Python developers to use schema-first approach to the API implementation. This is the leading approach used by the GraphQL community and supported by dozens of frontend and backend developer tools, examples, and learning resources. Ariadne makes all of this immediately available to you and other members of your team. - Simple: Ariadne offers small, consistent and easy to memorize API that lets developers focus on business problems, not the boilerplate. - Open: Ariadne was designed to be modular and open for customization. If you are missing or unhappy with something, extend or easily swap with your own.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-ariadne/Makefile25
-rw-r--r--devel/py-ariadne/distinfo3
-rw-r--r--devel/py-ariadne/pkg-descr11
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a8f88b7593fe..38bef4f01977 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4248,6 +4248,7 @@
SUBDIR += py-argh
SUBDIR += py-argparse
SUBDIR += py-args
+ SUBDIR += py-ariadne
SUBDIR += py-arpeggio
SUBDIR += py-array-api-compat
SUBDIR += py-arrow
diff --git a/devel/py-ariadne/Makefile b/devel/py-ariadne/Makefile
new file mode 100644
index 000000000000..2ff2a103e0cb
--- /dev/null
+++ b/devel/py-ariadne/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= ariadne
+PORTVERSION= 0.21
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= Python library for implementing GraphQL servers
+WWW= https://ariadnegraphql.org \
+ https://github.com/mirumee/ariadne
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>0:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}graphql-core>=3.2.0:devel/py-graphql-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}starlette>0.17:www/py-starlette@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.6.0:devel/py-typing-extensions@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-ariadne/distinfo b/devel/py-ariadne/distinfo
new file mode 100644
index 000000000000..89cd84f69663
--- /dev/null
+++ b/devel/py-ariadne/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1701885221
+SHA256 (ariadne-0.21.tar.gz) = 1d7f9fca17f5828a360417b7191310d4fe1506010f358470576450934ac0613b
+SIZE (ariadne-0.21.tar.gz) = 71867
diff --git a/devel/py-ariadne/pkg-descr b/devel/py-ariadne/pkg-descr
new file mode 100644
index 000000000000..be5498e14c6a
--- /dev/null
+++ b/devel/py-ariadne/pkg-descr
@@ -0,0 +1,11 @@
+Ariadne is a Python library for implementing GraphQL servers.
+
+- Schema-first: Ariadne enables Python developers to use schema-first approach
+ to the API implementation. This is the leading approach used by the GraphQL
+ community and supported by dozens of frontend and backend developer tools,
+ examples, and learning resources. Ariadne makes all of this immediately
+ available to you and other members of your team.
+- Simple: Ariadne offers small, consistent and easy to memorize API that lets
+ developers focus on business problems, not the boilerplate.
+- Open: Ariadne was designed to be modular and open for customization. If you
+ are missing or unhappy with something, extend or easily swap with your own.