aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-20 11:57:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-20 11:57:36 +0000
commit8cbc803ff71b5b2d99cd7463f6e8763bff742223 (patch)
tree0b616234cc1a1da0710a2581ef467be62ca3c570
parent401791425b840262429e64fa659430f20fb2b04d (diff)
downloadports-8cbc803ff71b5b2d99cd7463f6e8763bff742223.tar.gz
ports-8cbc803ff71b5b2d99cd7463f6e8763bff742223.zip
- Fix plist and unbreak [1, 2]
- Clean up Makefile and update pkg-message handling PR: ports/81492 [1], ports/83128 [2] Submitted by: Boris B. Samorodov <bsam@ipt.ru>, Norikatsu Shigemura <n-shigemura@ensure.jp> Approved by: maintainer timeout (2 months)
Notes
Notes: svn path=/head/; revision=139684
-rw-r--r--security/aide/Makefile20
-rw-r--r--security/aide/files/patch-Makefile.in11
-rw-r--r--security/aide/files/pkg-message.in (renamed from security/aide/pkg-message)4
-rw-r--r--security/aide/pkg-plist2
4 files changed, 20 insertions, 17 deletions
diff --git a/security/aide/Makefile b/security/aide/Makefile
index 9d97b6198624..f0370c7d2fe0 100644
--- a/security/aide/Makefile
+++ b/security/aide/Makefile
@@ -9,25 +9,13 @@ PORTNAME= aide
PORTVERSION= 0.10
PORTREVISION= 1
CATEGORIES= security
-MASTER_SITE_SOURCEFORGE+= http://unc.dl.sourceforge.net/%SUBDIR%/ \
- http://umn.dl.sourceforge.net/%SUBDIR%/ \
- http://twtelecom.dl.sourceforge.net/%SUBDIR%/ \
- http://aleron.dl.sourceforge.net/%SUBDIR%/ \
- http://easynews.dl.sourceforge.net/%SUBDIR%/ \
- http://switch.dl.sourceforge.net/%SUBDIR%/ \
- http://cesnet.dl.sourceforge.net/%SUBDIR%/ \
- http://flow.dl.sourceforge.net/%SUBDIR%/ \
- http://keihanna.dl.sourceforge.net/%SUBDIR%/ \
- http://heanet.dl.sourceforge.net/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTNAME}
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://www.cs.tut.fi/~rammer/ \
+ http://www.cs.tut.fi/~rammer/
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= cy@FreeBSD.org
COMMENT= A replacement and extension for Tripwire
-BROKEN= Incomplete pkg-plist
-
LIB_DEPENDS= mhash.2:${PORTSDIR}/security/mhash
USE_GMAKE= yes
@@ -42,13 +30,15 @@ CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
MAN1= aide.1
MAN5= aide.conf.5
+SUB_FILES= pkg-message
+
post-install:
@${INSTALL_DATA} ${FILESDIR}/aide.conf.freebsd ${PREFIX}/etc/aide.conf.sample
@if [ ! -d ${PREFIX}/etc/aide.conf ]; then \
${INSTALL_DATA} ${FILESDIR}/aide.conf.freebsd ${PREFIX}/etc/aide.conf ; \
fi
@if [ ! -d /var/db/aide/databases ]; then \
- ${MKDIR} -p /var/db/aide/databases; \
+ ${MKDIR} /var/db/aide/databases; \
${CHOWN} root:wheel /var/db/aide ; \
${CHOWN} root:wheel /var/db/aide/databases ; \
${CHMOD} 0700 /var/db/aide ; \
diff --git a/security/aide/files/patch-Makefile.in b/security/aide/files/patch-Makefile.in
new file mode 100644
index 000000000000..48c7b748d0f2
--- /dev/null
+++ b/security/aide/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sat Nov 29 00:14:08 2003
++++ Makefile.in Fri Jul 8 16:23:06 2005
+@@ -95,7 +95,7 @@
+ VERSION = @VERSION@
+ YACC = @YACC@
+
+-SUBDIRS = src doc po
++SUBDIRS = src doc
+
+ CLEANFILES = *~
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/security/aide/pkg-message b/security/aide/files/pkg-message.in
index 6fbea62fbd4f..8a0ca3c22a83 100644
--- a/security/aide/pkg-message
+++ b/security/aide/files/pkg-message.in
@@ -1,5 +1,5 @@
If you want to finish setting up AIDE, don't forget to customise your
-own aide.conf in ${PREFIX}/etc/aide.conf. You will also need to run
+own aide.conf in %%PREFIX%%/etc/aide.conf. You will also need to run
the following commands:
cd /var/db/aide
@@ -9,4 +9,4 @@ the following commands:
You may want to change the permissions of the /var/adm/aide/ directory tree.
For your reference, a copy of the original aide.conf is supplied in
-${PREFIX}/etc/aide.conf.sample.
+%%PREFIX%%/etc/aide.conf.sample.
diff --git a/security/aide/pkg-plist b/security/aide/pkg-plist
index 27bc6451f5fe..0351bfee5201 100644
--- a/security/aide/pkg-plist
+++ b/security/aide/pkg-plist
@@ -1,5 +1,7 @@
bin/aide
+@unexec if cmp -s %D/etc/aide.conf %D/etc/aide.conf.sample; then rm -f %D/etc/aide.conf; fi
etc/aide.conf.sample
+@exec [ ! -f %B/aide.conf ] && cp %B/%f %B/aide.conf
@exec /bin/mkdir -p /var/db/aide/databases
@exec [ -f /var/db/aide/aide.conf ] || /usr/sbin/chown root:wheel /var/db/aide
@exec [ -f /var/db/aide/aide.conf ] || /usr/sbin/chown root:wheel /var/db/aide/databases