aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-07-05 05:07:47 +0000
committerFernando Apesteguía <fernape@FreeBSD.org>2022-07-07 05:35:24 +0000
commit8ce2900d5aaffab13b961003114a97a48d00e59d (patch)
tree5c84b405a4fa92623d2756761c83abfe2394d843
parent5bf2947fce86388fd612492f980540c07d41f0b2 (diff)
downloadports-8ce2900d5aaffab13b961003114a97a48d00e59d.tar.gz
ports-8ce2900d5aaffab13b961003114a97a48d00e59d.zip
devel/schilybase: 2022 schilytools touchup
Following Jörg Schilling's death in 2021, this is a light touch up of the port in preparation of future updates at the project's new home. - Jörg's domains have started to run out. Change the WWW to our new project lest they point to some unrelated site. - Instead of building profiled libraries and then throwing them out, have -PROFILE not build these in the first place. - Enable symbol versioning for hardening against mismatched library versions. While tested well on Linux, this option was never enabled on FreeBSD due to Jörg's lack of experience with the system. Given that the toolchain is pretty much the same, little to now issues are to be expected. - Relax schilybase dependency to just LIB_DEPENDS to simplify partial upgrades. This is reasonably safe now that symbol versioning has been enabled. WWW: https://codeberg.org/schilytools/schilytools ChangeLog: https://codeberg.org/schilytools/schilytools PR: 265040 Reported by: fuz@fuz.su (maintainer)
-rw-r--r--archivers/star/pkg-descr2
-rw-r--r--devel/sccs/pkg-descr2
-rw-r--r--devel/schilybase/Makefile.master8
-rw-r--r--devel/schilybase/files/patch-RULES_i386-freebsd-clang.rul24
-rw-r--r--devel/schilybase/files/patch-RULES_i386-freebsd-gcc.rul24
-rw-r--r--devel/schilybase/pkg-descr2
-rw-r--r--devel/smake/pkg-descr2
-rw-r--r--devel/sunpromake/pkg-descr2
-rw-r--r--editors/ved/pkg-descr2
-rw-r--r--misc/schilytools/pkg-descr2
-rw-r--r--net/rscsi/pkg-descr2
-rw-r--r--sysutils/cdrtools/pkg-descr2
-rw-r--r--sysutils/schilyutils/pkg-descr2
13 files changed, 62 insertions, 14 deletions
diff --git a/archivers/star/pkg-descr b/archivers/star/pkg-descr
index 39a638d467b4..cfcfe8fc06e9 100644
--- a/archivers/star/pkg-descr
+++ b/archivers/star/pkg-descr
@@ -20,4 +20,4 @@ Main advantages over other tar implementations:
true incremental - star uses the same method as dump(8)/restore(8)
dump/restore features but acts OS and FS independent
-WWW: https://sourceforge.net/projects/s-tar/
+WWW: https://codeberg.org/schilytools/schilytools
diff --git a/devel/sccs/pkg-descr b/devel/sccs/pkg-descr
index 3cdfbdafaad9..6d02adf4e09d 100644
--- a/devel/sccs/pkg-descr
+++ b/devel/sccs/pkg-descr
@@ -3,4 +3,4 @@ System. It provides actively maintained code based on the original UNIX
SCCS code OpenSourced by Sun as part of OpenSolaris and was made
portable to other platforms.
-WWW: http://sccs.sourceforge.net/
+WWW: https://codeberg.org/schilytools/schilytools
diff --git a/devel/schilybase/Makefile.master b/devel/schilybase/Makefile.master
index 03f435424975..71a36612b07b 100644
--- a/devel/schilybase/Makefile.master
+++ b/devel/schilybase/Makefile.master
@@ -1,6 +1,7 @@
DISTVERSION= 2021-09-18
-PORTREVISION= 1
-MASTER_SITES= SF/schilytools
+PORTREVISION= 2
+MASTER_SITES= SF/schilytools \
+ http://fuz.su/~fuz/distfiles/schilytools/
DISTNAME= schily-${DISTVERSION}
MAINTAINER= fuz@fuz.su
@@ -26,8 +27,7 @@ LICENSE_PERMS_BSD1CLAUSE= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
# schilybase has all the libraries
.if ${PORTNAME} != "schilybase"
-BUILD_DEPENDS+= schilybase=${PORTVERSION}_${PORTREVISION}:devel/schilybase
-RUN_DEPENDS+= schilybase=${PORTVERSION}_${PORTREVISION}:devel/schilybase
+LIB_DEPENDS+= libschily.so:devel/schilybase
.endif
.if "${BOOTSTRAP_SMAKE}" != "yes"
diff --git a/devel/schilybase/files/patch-RULES_i386-freebsd-clang.rul b/devel/schilybase/files/patch-RULES_i386-freebsd-clang.rul
new file mode 100644
index 000000000000..2fa91bea4bd6
--- /dev/null
+++ b/devel/schilybase/files/patch-RULES_i386-freebsd-clang.rul
@@ -0,0 +1,24 @@
+--- RULES/i386-freebsd-clang.rul.orig 2022-07-05 01:45:06 UTC
++++ RULES/i386-freebsd-clang.rul
+@@ -38,4 +38,21 @@ LIB_KVM=
+
+ #LDOPTS= $(LIBS_PATH) $(LDPATH)
+
++#
++# Sunpro C/C++ run on Solaris and Linux and both have linkers
++# that support mapfiles
++#
++MAPVERS= $(_MAPVERS) # This enables to use mapfiles
++#
++# The GNU linker is buggy and does not like the official order in linker map
++# files for symbol versioning. The following command reverses the order of
++# the version names in the linker map file.
++#
++MAPFILE_POST= | sed 's/^SCHILY/+SCHILY/' | tr '\012' '@' | tr '+' '\012' | tail -r | tr '@' '\012'
++
++#LDOPTS= $(LIBS_PATH) $(LDPATH) $(RUNPATH:-R%=-Wl,-R%)
++#LDOPTS= $(LIBS_PATH) $(LDPATH)
++LDOPTMAP= $(PMAPVERS:%=-Wl,--version-script=%)
++LDOPTDYN= -shared -Wl,-soname,$(TARGET) $(LDOPTMAP)
++
+ RANLIB= $(NOECHO)echo " ==> RANDOMIZING ARCHIVE \"$@\""; ranlib
diff --git a/devel/schilybase/files/patch-RULES_i386-freebsd-gcc.rul b/devel/schilybase/files/patch-RULES_i386-freebsd-gcc.rul
new file mode 100644
index 000000000000..ffc7975e7845
--- /dev/null
+++ b/devel/schilybase/files/patch-RULES_i386-freebsd-gcc.rul
@@ -0,0 +1,24 @@
+--- RULES/i386-freebsd-gcc.rul.orig 2022-07-05 01:45:16 UTC
++++ RULES/i386-freebsd-gcc.rul
+@@ -38,4 +38,21 @@ LIB_KVM=
+
+ #LDOPTS= $(LIBS_PATH) $(LDPATH)
+
++#
++# Sunpro C/C++ run on Solaris and Linux and both have linkers
++# that support mapfiles
++#
++MAPVERS= $(_MAPVERS) # This enables to use mapfiles
++#
++# The GNU linker is buggy and does not like the official order in linker map
++# files for symbol versioning. The following command reverses the order of
++# the version names in the linker map file.
++#
++MAPFILE_POST= | sed 's/^SCHILY/+SCHILY/' | tr '\012' '@' | tr '+' '\012' | tail -r | tr '@' '\012'
++
++#LDOPTS= $(LIBS_PATH) $(LDPATH) $(RUNPATH:-R%=-Wl,-R%)
++#LDOPTS= $(LIBS_PATH) $(LDPATH)
++LDOPTMAP= $(PMAPVERS:%=-Wl,--version-script=%)
++LDOPTDYN= -shared -Wl,-soname,$(TARGET) $(LDOPTMAP)
++
+ RANLIB= $(NOECHO)echo " ==> RANDOMIZING ARCHIVE \"$@\""; ranlib
diff --git a/devel/schilybase/pkg-descr b/devel/schilybase/pkg-descr
index c2ca3e12e998..bdc2f28b6f5d 100644
--- a/devel/schilybase/pkg-descr
+++ b/devel/schilybase/pkg-descr
@@ -13,4 +13,4 @@ of programs by Joerg Schilling. This includes among others
* libshedit -- bsh command line editor
* libxtermcap -- extended termcap library
-WWW: http://schilytools.sourceforge.net
+WWW: https://codeberg.org/schilytools/schilytools
diff --git a/devel/smake/pkg-descr b/devel/smake/pkg-descr
index 97428964c242..6ca6af1ec5c5 100644
--- a/devel/smake/pkg-descr
+++ b/devel/smake/pkg-descr
@@ -6,4 +6,4 @@ compilation on all supported platforms. The system therefore allows the
re-use of a source tree for all supported platforms in contrast to the GNU
concept of untar -> configure -> make -> install -> remove
-WWW: https://sourceforge.net/projects/s-make/
+WWW: https://codeberg.org/schilytools/schilytools
diff --git a/devel/sunpromake/pkg-descr b/devel/sunpromake/pkg-descr
index d08523545f69..fd4f657254d7 100644
--- a/devel/sunpromake/pkg-descr
+++ b/devel/sunpromake/pkg-descr
@@ -5,4 +5,4 @@ never been open-sourced and is missing from this version of
SunPro Make, the parallel make functionality was succesfully
reconstructed from the present source.
-WWW: http://schilytools.sourceforge.net/sunpromake.html
+WWW: https://codeberg.org/schilytools/schilytools
diff --git a/editors/ved/pkg-descr b/editors/ved/pkg-descr
index 7510c7e582d2..f8d08596ddb7 100644
--- a/editors/ved/pkg-descr
+++ b/editors/ved/pkg-descr
@@ -5,4 +5,4 @@ vi and does not limit the work speed even of experienced users.
Ved has been inspired by an editor of the same name that appeared in
1980 as system editor on UNOS (the first UNIX clone).
-WWW: http://schilytools.sourceforge.net/ved.html
+WWW: https://codeberg.org/schilytools/schilytools
diff --git a/misc/schilytools/pkg-descr b/misc/schilytools/pkg-descr
index bcc8a5346c2f..a1764fe25117 100644
--- a/misc/schilytools/pkg-descr
+++ b/misc/schilytools/pkg-descr
@@ -14,4 +14,4 @@ Programs and tools included in the Schily-Tools bundle:
* star, the oldest free TAR implementation, started in 1982
* ved, A portable, easy to learn and extremely fast screen oriented editor.
-WWW: http://schilytools.sourceforge.net/
+WWW: https://codeberg.org/schilytools/schilytools
diff --git a/net/rscsi/pkg-descr b/net/rscsi/pkg-descr
index a879d575d224..ab96342faecc 100644
--- a/net/rscsi/pkg-descr
+++ b/net/rscsi/pkg-descr
@@ -10,4 +10,4 @@ the remote user.
The rscsi command must be installed setuid root for full functionality.
For this reason it is provided as a separate package to cdrtools.
-WWW: http://cdrtools.sourceforge.net/
+WWW: https://codeberg.org/schilytools/schilytools
diff --git a/sysutils/cdrtools/pkg-descr b/sysutils/cdrtools/pkg-descr
index 42c65306289a..571400d0927b 100644
--- a/sysutils/cdrtools/pkg-descr
+++ b/sysutils/cdrtools/pkg-descr
@@ -18,4 +18,4 @@ This package contains the following programs:
May be used to write to DVD-RAM and to copy Solaris boot CD's.
- scgcheck (checks and validates the ABI of libscg)
-WWW: http://cdrecord.org/
+WWW: https://codeberg.org/schilytools/schilytools
diff --git a/sysutils/schilyutils/pkg-descr b/sysutils/schilyutils/pkg-descr
index 6f3bf6ab8de9..65ea3d23f15c 100644
--- a/sysutils/schilyutils/pkg-descr
+++ b/sysutils/schilyutils/pkg-descr
@@ -4,4 +4,4 @@ preprocessor (krcpp), improved versions of standard UNIX utilities
(scal, sod, sprintf, scut, sdd, sfind, spatch), a C/C++ style checker
(cstyle.js, Cstyle) as well as various others.
-WWW: http://schilytools.sourceforge.net
+WWW: https://codeberg.org/schilytools/schilytools